Author Topic: Scanning files on a samba share gives error  (Read 2235 times)

0 Members and 1 Guest are viewing this topic.


  • Guest
Scanning files on a samba share gives error
« on: September 14, 2011, 12:55:36 PM »
I'm running Avast! Free and I'm having trouble scanning files on my Network Attached Storage (NAS) device. I'm running Windows 7 x64 and when I try to scan a network samba share on my NAS using the right click -> Scan blahblah.exe shell option, I get the following error:

Error: Logon failure: unknown user name or bad password (1326)

The share on my NAS is mounted in Windows 7 x64 and I have full read/write access. I have no problems reading and writing to this share in windows and it is mounted and fully working before attempting to scan. Outside of trying to virus scan files, the share on the NAS works perfectly. My NAS is a Synology DS211j.

Further, I looked through the configuration options in Avast! and cannot find a section that might allow me to input a user name or password to connect to the samba share to fix this problem.

I have further tried several Google searches for individuals having a similar problem. Several people on this unresolved thread using a QNAP NAS have the same problem with Avast!:

Another unanswered and unresolved thread on a QNAP NAS has the same problem:

Running the "net use" command on my Windows 7 x64 client shows that the share is connected and functioning as expected.

I further tried using the "Select folder to scan" ability in the Avast! control panel to scan the samba share, but it returns the same error.

My Avast! program and database are fully updated as of 9/14/2011. Avast! reports the following versions:

Virus definitions version: 110914-0
Program version: 6.0.1289

Does anyone have a solution to this problem?
« Last Edit: September 14, 2011, 01:12:04 PM by avastnoob1 »

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11867
    • AVAST Software
Re: Scanning files on a samba share gives error
« Reply #1 on: September 15, 2011, 12:57:25 PM »
Should hopefully be fixed by now.