Author Topic: avast!: The AAVM subsystem detected a RPC error.  (Read 4775 times)

0 Members and 1 Guest are viewing this topic.

Offline kiwanotree

  • Newbie
  • *
  • Posts: 3
  • I'm me, not you
avast!: The AAVM subsystem detected a RPC error.
« on: August 12, 2003, 08:08:24 AM »
After installing the system I let it perform a boot scan.  It found what it thought was a virus in a zip file, and told me I could delete, repair, ignore.  No key presses worked.  I eventually had to boot to last known good.

Once up and running, I did the same scan.  After deleting the two zip files avast! had a problem with, I tried to configure the package.  However, when I try to click on the On-Access Protection Control I get the message:
avast!: The AAVM subsystem detected a RPC error.

Anyone know what this is all about?

The program has been registered.  I am using the Home edition.  I have XP Profesional.

Offline kiwanotree

  • Newbie
  • *
  • Posts: 3
  • I'm me, not you
Re:avast!: The AAVM subsystem detected a RPC error.
« Reply #1 on: August 12, 2003, 08:23:18 AM »
This error is caused by the service not running.

I fixed it by fully uninstalling the package and then reinstalling, this time NOT running a boot check.

After entering the registration key and waiting for everything to load, the RPC is running and active.

Doing a quick scan now!

Offline vojtech

  • Avast team
  • Advanced Poster
  • *
  • Posts: 939
    • ALWIL Software
Re:avast!: The AAVM subsystem detected a RPC error.
« Reply #2 on: August 12, 2003, 10:41:58 AM »
The keyboard may not work during boot time scan if it is connected to USB. Is it your case ? But the scan should terminate itself in this case.

Offline kiwanotree

  • Newbie
  • *
  • Posts: 3
  • I'm me, not you
Re:avast!: The AAVM subsystem detected a RPC error.
« Reply #3 on: August 12, 2003, 06:37:41 PM »
It is indeed a USB keyboard.

I waited one hour, it did not continue. :(

I've installed Avast! 4 Home on my PC and my wife's PC - and it seems to be running fine now :)