Author Topic: error 17006 during updateing vps with latest mac beta (32436)  (Read 3469 times)

0 Members and 1 Guest are viewing this topic.

Rainer S. Webersinke

  • Guest
error 17006 during updateing vps with latest mac beta (32436)
« on: September 23, 2011, 11:34:10 PM »
Hi folks,

I'm running the latest build code of Avast Free Antivirus for Mac 1.0 (build 32436) and have the problem that it's impossible for me to download the latest CVS for that release.

While it was possible for build 30664 to detect there's a new version available to download, I never ever could download any cvs-updates.

I wonder if there are new CVS-builds available for this beta or if there's a proxy issue at my location. However, the older releases simply ran into a timeout but now, with latest build, I get an error: Update - An error 17006 occurred during updating.

Any clue if what I should do ???

Thanks in advance

Rainer

Rainer S. Webersinke

  • Guest
Re: error 17006 during updateing vps with latest mac beta (32436)
« Reply #1 on: September 24, 2011, 08:37:07 AM »
Me again...

After some investigation in the problem, I had to find out that the update module simply ignores the system proxy settings completely:

It tries to communicate with the update-servers (at least with two IP-addresses) directly per http (port 80).

So the workaround would be to allow my Mac to allow a range of servers (is a list for the update-servers available?).

Probably the best solution would be the update-module takes care about the system settings....

Regards

Rainer

iphone900

  • Guest
Re: error 17006 during updateing vps with latest mac beta (32436)
« Reply #2 on: September 24, 2011, 05:05:57 PM »
update working fine for me
restart avast and update again  ;D
« Last Edit: September 24, 2011, 05:08:15 PM by iphone900 »

Rainer S. Webersinke

  • Guest
Re: error 17006 during updateing vps with latest mac beta (32436)
« Reply #3 on: September 25, 2011, 10:55:03 AM »
Iphone900,

I'm afraid you don't understand: the scanner and all modules - well except the update module - work fine. The machine is shutdown daily as I don't want to have it run all over the night.

Never the less, my problem is that I am behind a local firewall which drops un-allowed traffic. And that's the problem: The update module ignores the system specific settings for network: I have specified a proxy server and all other software uses that information.  8)
The update module for Avast ignores theses settings and tries to get out directly via HTTP and maybe HTTPS. And that's the problem I want to get resolved. I believe it's a (currently) missing feature of the beta and I simply wanted to inform the developers about it.

Regards

Rainer