Author Topic: Programs will not open after Avast virus software update and boot scan  (Read 5053 times)

0 Members and 1 Guest are viewing this topic.

Offline 3-redheads

  • Newbie
  • *
  • Posts: 6
The problem started with my internet disconnecting several times an hour shortly after I updated the Avast program.

While annoying, it was tolerable.  I decided to do a full scan tonight and Avast found 4 high risk items, of which, only 3 would "move to the chest"  Avast recommended a boot scan.  Did the boot scan and system restarted.

Since then, none of my programs will open, even Avast.  Booted from safe mode.  No luck.  Even tried a system restore, to no avail.

As it stands now, my laptop is worthless.  There seems to be numerous problems, many similar, since the upgrade.  I would hate to have to pay to have someone fix my laptop.

I really need your advice.  Thanks in advance!

Offline AdrianH

  • Advanced Poster
  • **
  • Posts: 854
Re: Programs will not open after Avast virus software update and boot scan
« Reply #1 on: September 25, 2011, 07:14:15 AM »
http://forum.avast.com/index.php?topic=85415.msg692170#msg692170   

Start menu > CMD > Run as Admin > SFC /SCANNOW  let it run and see if that repairs the corrupt files.
Win8.1 Pro 64Bit  : KIS2014 : CryptoPrevent : Privazer:

Offline lmoss

  • Newbie
  • *
  • Posts: 4
Re: Programs will not open after Avast virus software update and boot scan
« Reply #2 on: September 25, 2011, 07:19:15 AM »
http://forum.avast.com/index.php?topic=85415.msg692170#msg692170   

Start menu > CMD > Run as Admin > SFC /SCANNOW  let it run and see if that repairs the corrupt files.

Sweet!  Thanks for everybody who found this.  This seems to have solved the problem on my as well.

Offline DonZ63

  • Poster
  • *
  • Posts: 469
Re: Programs will not open after Avast virus software update and boot scan
« Reply #3 on: September 25, 2011, 03:17:16 PM »
Note: sfc /scannow will only work w/o original Windows installation CD on WIN 7. I know for a fact for XP, you need the CD. That is unless you were smart enough to copy the i386 folder from the installation CD to your HDD and modify your registry to point to the location where the i386 folder is located.

Furthermore, if your CD is not the same SPx(softpac) as the SPx currently installed, sfc /scannow will not work. That is why people in the know always create "slipstreamed" installation CDs when they install a new SP.
AMD QUAD 945, 8 GB, NVidia GTS 450, 3 HDDs
Dual boot, MBAM Pro - both OSes, WIN 7 x64 SP1, NAV 2012, IE9; XP SP3, NIS 2011, IE8

Offline 3-redheads

  • Newbie
  • *
  • Posts: 6
Re: Programs will not open after Avast virus software update and boot scan
« Reply #4 on: September 25, 2011, 03:44:11 PM »
This worked!  Thank you so much.  Wish I could give you rep points.

Offline 3-redheads

  • Newbie
  • *
  • Posts: 6
Re: Programs will not open after Avast virus software update and boot scan
« Reply #5 on: September 25, 2011, 04:42:43 PM »
Just so I understand this and hope that it doesn't happen again, was the problem with the latest Avast update giving false positives or was there a virus?

I can't believe the fix was so easy!

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11805
    • AVAST Software
Re: Programs will not open after Avast virus software update and boot scan
« Reply #6 on: September 25, 2011, 06:50:52 PM »
Did you delete (or move to chest) any further files during the boot-time scan?
Do you still have those 3 files in Chest?
Thanks.

Offline 3-redheads

  • Newbie
  • *
  • Posts: 6
Re: Programs will not open after Avast virus software update and boot scan
« Reply #7 on: September 25, 2011, 08:55:06 PM »
Did you delete (or move to chest) any further files during the boot-time scan?
Do you still have those 3 files in Chest?
Thanks.

I moved 3 to the chest during the boot scan.  The chest now shows 4 files from yesterday:


Offline hlfrmies008

  • Newbie
  • *
  • Posts: 1
Re: Programs will not open after Avast virus software update and boot scan
« Reply #8 on: September 26, 2011, 11:56:13 AM »
I had the same problem. THANKS!!! IT WORKED!!! I was a little freaked about the whole situation, with needing my PC for school and all... THANK YOU!!!