Author Topic: Avast SBP setup_console_bp.exe fails during Service Installing  (Read 3794 times)

0 Members and 1 Guest are viewing this topic.

thowden

  • Guest
Avast SBP setup_console_bp.exe fails during Service Installing
« on: October 01, 2011, 01:39:49 AM »
Installing a new 15 user licence for Avast on a Windows 2008 RC2 32-bit server.

The install fails during the service install part and rolls back.

The log file that is relevant is found in C:\ProgramData\AVAST Software\Administration Console\Logs

Quote
10-01 09:14:07,892 [1] INFO  Scheduler - Stopping the scheduler thread...
10-01 09:14:07,892 [1] INFO  EntitiesInstaller - Creating native properties.
10-01 09:14:07,892 [SchedulerCacheMediator] INFO  CacheMediator - Scheduler cache received shutdown signal. Flushing...
10-01 09:14:09,125 [1] INFO  SbcServiceInstaller - Creating firewall exceptions.
10-01 09:14:09,156 [1] ERROR SbcServiceInstaller - Problem while installing the service.

System.Runtime.InteropServices.COMException (0x800706D9): Creating an instance of the COM component with CLSID {304CE942-6E39-40D8-943A-B913C40C9CD4} from the IClassFactory failed due to the following error: 800706d9.
   at System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandleInternal& ctor, Boolean& bNeedSecurityCheck)
   at System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean skipCheckThis, Boolean fillCache)
   at System.RuntimeType.CreateInstanceDefaultCtor(Boolean publicOnly, Boolean skipVisibilityChecks, Boolean skipCheckThis, Boolean fillCache)
   at System.Activator.CreateInstance(Type type, Boolean nonPublic)
   at Avast.Sbc.Service.FirewallWrapper.WinFirewallManager()
   at Avast.Sbc.Service.FirewallWrapper.AddPort(Int16 portNumber, String name, NET_FW_SCOPE_ scope, TLProtocol tlProtocol)
   at Avast.Sbc.Service.SbcServiceInstaller.Install(IDictionary stateSaver)
10-01 09:14:09,234 [1] WARN  SbcServiceInstaller - Rolling back the installation

From this it appears that the Windows Firewall is the issue (lines in bold).

I'll investigate that and see if I can trace the issue.

Tony
« Last Edit: October 08, 2011, 06:56:51 PM by igor »

thowden

  • Guest
Re: Avast SBP setup_console_bp.exe fails during Service Installing
« Reply #1 on: October 01, 2011, 01:59:17 AM »
From this it appears that the Windows Firewall is the issue (lines in bold).


Yes, that was it.

Windows Firewall Service was disabled. The Services setting for the Windows Firewall were set to Manual and Stopped. Set to Automatic and Started the service. Run setup_console_bp.exe again (Run As  Administrator) and it is now downloading the mirror files of Avast.

One more issue I noted was that if I tried to use an account other than the default Network Service (if you select Expert Install there is a prompt for this) then the installer will also fail at the Installing Service stage. This was because the user account requires the domain to be referenced as well.
I think that is kind of stupid as the Network Service is local and the account I had created for the purpose of running the service is also local. Why the coding cannot allow for MACHINENAME\ACCOUNT automatically is beyond me.

Now I'll move on to why the Console web site does not respond.......

And I give 5 thumbs down to the Avast Support Team who have had a week to reply to my ticket and have not bothered. Fully paid 15 users and I get to support myself. Great Software, Crap Service.

Tony
« Last Edit: October 08, 2011, 06:57:10 PM by igor »