Author Topic: attachments problem  (Read 7901 times)

0 Members and 1 Guest are viewing this topic.

Krzygaj

  • Guest
attachments problem
« on: November 13, 2004, 04:26:28 PM »
hello!
i have problem with avast. i cant send email with attachements
without attechement emails are sent
i tried on two different smtp servers and the problem is the same
so i think that sth is wrong with avast
i have w2k and newest wersion of avast
the problem is the same while using outlook or thunderbird
i you don't know what i'm takling about look at these movies:
http://krzygaj.internetdsl.pl/mail.swf
or
http://krzygaj.internetdsl.pl/mail.avi

here are the movie with avast turned off
http://krzygaj.internetdsl.pl/mail2.swf
or
http://krzygaj.internetdsl.pl/mail2.avi

on previous versions of avast i had turned off scanning of outgoing emails(they were not going through 127.0.0.1) but
in the newest wersion i can't just turn off these feature

if you need more information about my configuration ju let me know here or on email
sorry for my poor english  ;)

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31078
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re:attachments problem
« Reply #1 on: November 13, 2004, 04:34:51 PM »
Please check THIS THREAD and read what I, Igor and Vlk posted there. Does it help?

Krzygaj

  • Guest
Re:attachments problem
« Reply #2 on: November 13, 2004, 04:54:58 PM »
nope
my incoming and outgoing server are not set to 127.0.0.1 they are set to my mailbox provider
as you can see on videos when i remove attachement from letter(on mail viedo) or disable internet mail scanner(on mail2 video) the message is going to sent
so settings in my email client are ok

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31078
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re:attachments problem
« Reply #3 on: November 13, 2004, 05:05:53 PM »
What happens if you increase the timeout in your email client and in Avast4.ini?

Krzygaj

  • Guest
Re:attachments problem
« Reply #4 on: November 13, 2004, 05:28:43 PM »
which value i should change in avast4.ini file?

Krzygaj

  • Guest
Re:attachments problem
« Reply #5 on: November 13, 2004, 09:54:44 PM »
i have added Log=20 on [MailScanner] section in avast.ini and log file looks like these:
11/13/04 21:49:49:   Started, Log = 20(0x00000014)
11/13/04 21:49:49:   Build 4.5.518
11/13/04 21:49:49:   Using WinSock 2.0
11/13/04 21:49:49:   AutoRedirect settings changed 1(0x00000001)
11/13/04 21:49:49:   IgnoreLocalhost settings changed 1(0x00000001)
11/13/04 21:49:49:   POP Start settings changed: 1(0x00000001)
11/13/04 21:49:49:   POP Listen settings changed: 127.0.0.1 12110
11/13/04 21:49:49:   POP Listening daemon starting
11/13/04 21:49:49:   POP RedirectPort: 110
11/13/04 21:49:49:   Redirect set 110->127.0.0.1:12110
11/13/04 21:49:49:   POP Listening daemon started
11/13/04 21:49:49:   SMTP Start settings changed: 1(0x00000001)
11/13/04 21:49:49:   SMTP Listen settings changed: 127.0.0.1 12025
11/13/04 21:49:49:   SMTP Listening daemon starting
11/13/04 21:49:49:   SMTP RedirectPort: 25
11/13/04 21:49:49:   Redirect set 25->127.0.0.1:12025
11/13/04 21:49:49:   SMTP Listening daemon started
11/13/04 21:49:49:   IMAP Start settings changed: 1(0x00000001)
11/13/04 21:49:49:   IMAP Listen settings changed: 127.0.0.1 12143
11/13/04 21:49:49:   IMAP Listening daemon starting
11/13/04 21:49:49:   IMAP RedirectPort: 143
11/13/04 21:49:49:   Redirect set 143->127.0.0.1:12143
11/13/04 21:49:49:   IMAP Listening daemon started
11/13/04 21:49:58:   SMTP accept connection from: 127.0.0.1
11/13/04 21:49:58:   --SMTP command REDIRECT 212.77.101.160:25 328
11/13/04 21:49:58:   Connected to SMTP server 212.77.101.160 25
11/13/04 21:49:58:   --XXX sleep
11/13/04 21:49:58:   --XXX sleep
11/13/04 21:49:58:   <-SMTP (PID) 220 smtp.wp.pl ESMTP
 32811/13/04 21:49:58:   ->SMTP EHLO [127.0.0.1]
11/13/04 21:49:58:   --XXX sleep
11/13/04 21:49:58:   <-SMTP 250-smtp.wp.pl
250-PIPELINING
250-AUTH=LOGIN PLAIN
250-AUTH LOGIN PLAIN
250-STARTTLS
250-SIZE
250-X-RCPTLIMIT 100
250 8BITMIME
11/13/04 21:49:58:   ->SMTP AUTH PLAIN ...
11/13/04 21:49:58:   --XXX sleep
11/13/04 21:49:58:   <-SMTP 235 go ahead
11/13/04 21:49:58:   ->SMTP MAIL FROM:<krzygaj@wp.pl> SIZE=905
11/13/04 21:49:58:   --XXX sleep
11/13/04 21:49:58:   --XXX sleep
11/13/04 21:49:58:   <-SMTP 250 ok
11/13/04 21:49:58:   ->SMTP RCPT TO:<agajdka@wp.pl>
11/13/04 21:49:58:   --XXX sleep
11/13/04 21:49:58:   <-SMTP 250 ok
11/13/04 21:49:58:   ->SMTP DATA
11/13/04 21:49:58:   ProcessFile entrance C:\WINNT\TEMP\_avast4_\unp64558160
11/13/04 21:49:58:   ProcessFile 2 e-Mail '' From: Krzysztof G <krzygaj@wp.pl>, To: Agnieszka Gajdka WP <agajdka@wp.pl>
11/13/04 21:49:58:   ProcessFile scanDlgPID before e-Mail '' From: Krzysztof G <krzygaj@wp.pl>, To: Agnieszka Gajdka WP <agajdka@wp.pl>
11/13/04 21:49:58:   ProcessFile scanDlgPID after e-Mail '' From: Krzysztof G <krzygaj@wp.pl>, To: Agnieszka Gajdka WP <agajdka@wp.pl>
11/13/04 21:49:58:   ProcessFile exit 1(0x00000001)
11/13/04 21:49:58:   --SMTP Mail is clean
11/13/04 21:49:58:   --XXX sleep
11/13/04 21:49:58:   <-SMTP 354 go ahead
11/13/04 21:49:58:   --SMTP Modified message to send: C:\WINNT\TEMP\_avast4_\unp64558160
11/13/04 21:49:58:   --XXX sleep
11/13/04 21:49:58:   --XXX sleep
11/13/04 21:49:58:   --XXX sleep
11/13/04 21:49:58:   --XXX sleep
11/13/04 21:49:58:   --XXX sleep
11/13/04 21:49:58:   --XXX sleep
11/13/04 21:49:58:   --XXX sleep
11/13/04 21:49:59:   --XXX sleep
11/13/04 21:49:59:   --XXX sleep
11/13/04 21:49:59:   --XXX sleep
11/13/04 21:49:59:   --XXX sleep
11/13/04 21:49:59:   --XXX sleep
and so on...
till
11/13/04 21:50:55:   --XXX sleep
11/13/04 21:50:55:   RecvTimeout error 10053(0x00002745)
11/13/04 21:50:55:   --SMTP Finishing connection handler
i hope this help to solve the problem

Krzygaj

  • Guest
Re:attachments problem
« Reply #6 on: November 13, 2004, 10:05:41 PM »
here are the logs while i was sending email without attachment:
11/13/04 22:03:25:   SMTP accept connection from: 127.0.0.1
11/13/04 22:03:25:   --SMTP command REDIRECT 212.77.101.160:25 328
11/13/04 22:03:25:   Connected to SMTP server 212.77.101.160 25
11/13/04 22:03:25:   --XXX sleep
11/13/04 22:03:25:   <-SMTP (PID) 220 smtp.wp.pl ESMTP
 32811/13/04 22:03:25:   ->SMTP EHLO [127.0.0.1]
11/13/04 22:03:25:   --XXX sleep
11/13/04 22:03:25:   <-SMTP 250-smtp.wp.pl
250-PIPELINING
250-AUTH=LOGIN PLAIN
250-AUTH LOGIN PLAIN
250-STARTTLS
250-SIZE
250-X-RCPTLIMIT 100
250 8BITMIME
11/13/04 22:03:25:   ->SMTP AUTH PLAIN ...
11/13/04 22:03:25:   --XXX sleep
11/13/04 22:03:25:   <-SMTP 235 go ahead
11/13/04 22:03:25:   ->SMTP MAIL FROM:<krzygaj@wp.pl> SIZE=406
11/13/04 22:03:25:   --XXX sleep
11/13/04 22:03:25:   <-SMTP 250 ok
11/13/04 22:03:25:   ->SMTP RCPT TO:<agajdka@wp.pl>
11/13/04 22:03:25:   --XXX sleep
11/13/04 22:03:25:   <-SMTP 250 ok
11/13/04 22:03:25:   ->SMTP DATA
11/13/04 22:03:25:   ProcessFile entrance C:\WINNT\TEMP\_avast4_\unp1775945
11/13/04 22:03:25:   ProcessFile 2 e-Mail '' From: Krzysztof G <krzygaj@wp.pl>, To: Agnieszka Gajdka WP <agajdka@wp.pl>
11/13/04 22:03:25:   ProcessFile scanDlgPID before e-Mail '' From: Krzysztof G <krzygaj@wp.pl>, To: Agnieszka Gajdka WP <agajdka@wp.pl>
11/13/04 22:03:25:   ProcessFile scanDlgPID after e-Mail '' From: Krzysztof G <krzygaj@wp.pl>, To: Agnieszka Gajdka WP <agajdka@wp.pl>
11/13/04 22:03:25:   ProcessFile exit 1(0x00000001)
11/13/04 22:03:25:   --SMTP Mail is clean
11/13/04 22:03:25:   --XXX sleep
11/13/04 22:03:25:   <-SMTP 354 go ahead
11/13/04 22:03:25:   --SMTP Modified message to send: C:\WINNT\TEMP\_avast4_\unp1775945
11/13/04 22:03:26:   --XXX sleep
11/13/04 22:03:26:   --XXX sleep
11/13/04 22:03:26:   --XXX sleep
11/13/04 22:03:26:   --XXX sleep
11/13/04 22:03:26:   <-SMTP 250 ok 1100379806 qp 25440
11/13/04 22:03:26:   ->SMTP QUIT
11/13/04 22:03:26:   --XXX sleep
11/13/04 22:03:26:   <-SMTP 221 smtp.wp.pl
11/13/04 22:03:26:   --XXX testing second-side connection
11/13/04 22:03:26:   --SMTP Finishing connection handler

peterfu

  • Guest
Re:attachments problem
« Reply #7 on: November 13, 2004, 10:22:25 PM »
Seems Your SMTP Connection timed out - theres a timer which can be set in the advanced tab of the internet mail - think the default value is 120 and a check box what to do after the timeout. Try to increase this timeout and perform action "asked what to do". The timervalue should be in line with the timer setting of your mail client.
br
Peter

S.Z.Craftec

  • Guest
Re:attachments problem
« Reply #8 on: November 13, 2004, 10:38:33 PM »
Click on my signature and you'll find how to set internet communication(s) timeout in avast!

Krzygaj

  • Guest
Re:attachments problem
« Reply #9 on: November 14, 2004, 09:49:40 AM »
well....
i've tried that before and it won't help
maybe sth is wrong with my w2k
i've turned off scanning of outgoing emails and i can send them with attachemnts now

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re:attachments problem
« Reply #10 on: November 15, 2004, 06:22:14 PM »
Which value i should change in avast4.ini file?

Better is going to the Advanced tab of the Internet Mail provider (and MS Outlook plugin) and increase there the timeout.

You can see some other settings on section [Communication] of avast4.ini file. Details on the link 'Settings' in my signature  ;)

The best things in life are free.