Author Topic: 2 wishes: not rebooting after update avast home & VRDB...  (Read 2505 times)

0 Members and 1 Guest are viewing this topic.

Offline zivilist

  • Full Member
  • ***
  • Posts: 126
2 wishes: not rebooting after update avast home & VRDB...
« on: November 15, 2004, 12:38:50 PM »
hi,

recently I have installed Home Edition 4.5.518.
When I do a program update (to 4.5.523) I must restart windows. Why can shortly shutdown only avast and restarting it again?

another wish:
The VRDB wants a extra icon in the tastbar although I select merging to the other avast logo.
It splits in two icons again.

thanks

« Last Edit: November 15, 2004, 12:44:11 PM by zivilist »
OS: Windows 7 Professional x64, OS X 10.8.3
Avast Free (for Mac and Windows)

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11805
    • AVAST Software
Re:2 wishes: not rebooting after update avast home & VRDB...
« Reply #1 on: November 15, 2004, 01:25:34 PM »
Sorry, but it's not possible to update avast! without rebooting - some items are loaded in memory and simply cannot be unloaded without restart.

You are right, the VRDB icon is shown even when "merged" - but only when the real generation is in progress. When it's done, it will disappear.

Offline Lars-Erik

  • Avast Evangelist
  • Sr. Member
  • ***
  • Posts: 394
    • Lars-Erik Østerud
Re:2 wishes: not rebooting after update avast home & VRDB...
« Reply #2 on: November 15, 2004, 01:31:20 PM »
For XP this is true, the VRDB icon is displayed only when system is rebuilding the database. But under Win98 the VRDB icon is NEVER shown if you choose to merge them. Why (I never noticed the VRDB icon until I installed XP :-)
www.osterud.name - ICQ: 7297605 - AIM/Yahoo/Facebook/Skype/Astra: LarsErikOsterud

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11805
    • AVAST Software
Re:2 wishes: not rebooting after update avast home & VRDB...
« Reply #3 on: November 15, 2004, 02:01:10 PM »
Hm, seems you are right. However, it's rather a problem in Windows 98 preventing the icon to appear.
On the other hand, there is an .ini parameter ShowTaskbarIcon=0 (in [VRDB] section) that should prevent the icon to appear at all (ever). As I checked now, it doesn't work either... I'll fix at least this one.