Author Topic: Mail scanner broken with today's update?  (Read 43096 times)

0 Members and 1 Guest are viewing this topic.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re:Mail scanner broken with today's update?
« Reply #30 on: November 13, 2004, 07:59:32 PM »
Quote
If you leave your settings as they were before the update - it should work with avast4.5 as well. Especialy having pop3/smtp server set to 127.0.0.1, and username as my_real_name#my_pop3_server.domain.net.

It is NOT necessary but it shoud work.

We recommend to setup you mail client as if avast!  is not installed - but the old way works pretty the same as in previous versions.

This is simply not true. Well maybe it is, sort of.

If you leave the settings as they were BEFORE the update, it WON'T work. The reason is that you would have to change the ports in your mail program as well. The default port numbers are now 12025 for SMTP, 12110 for POP3 and 12143 for IMAP4.

So, the're basically two ways to make it work if you have set up the mail protection manually prior to updating to 4.5:

- either leave the 127.0.0.1 settings in your mail client as they were, BUT instruct the mail client to use the port numbers mentioned above

- OR reconfigure the mail clients as avast was not present at all (i.e. switch 127.0.0.1 back to pop.myprovider.com and username to myusername  instead of myusername#pop.myprovider.com.


Users of Zone Alarm may experience another problem when using the 2nd method, though. This is being discussed in different threads on the forum and we are working hard to solve it.


Thanks,
Vlk
If at first you don't succeed, then skydiving's not for you.

conazus

  • Guest
Re:Mail scanner broken with today's update?
« Reply #31 on: November 13, 2004, 08:06:27 PM »
Quote
If you leave your settings as they were before the update - it should work with avast4.5 as well. Especialy having pop3/smtp server set to 127.0.0.1, and username as my_real_name#my_pop3_server.domain.net.

It is NOT necessary but it shoud work.

We recommend to setup you mail client as if avast!  is not installed - but the old way works pretty the same as in previous versions.

This is simply not true. Well maybe it is, sort of.

If you leave the settings as they were BEFORE the update, it WON'T work. The reason is that you would have to change the ports in your mail program as well. The default port numbers are now 12025 for SMTP, 12110 for POP3 and 12143 for IMAP4.

So, the're basically two ways to make it work if you have set up the mail protection manually prior to updating to 4.5:

- either leave the 127.0.0.1 settings in your mail client as they were, BUT instruct the mail client to use the port numbers mentioned above

- OR reconfigure the mail clients as avast was not present at all (i.e. switch 127.0.0.1 back to pop.myprovider.com and username to myusername  instead of myusername#pop.myprovider.com.


Users of Zone Alarm may experience another problem when using the 2nd method, though. This is being discussed in different threads on the forum and we are working hard to solve it.


Thanks,
Vlk


Vlk.. okay now I am totally confused  :)

As I stated in the other thread a few minutes ago I did not change any of my settings , and 4.5 worked fine for me in Outlook Express and Thunderbird.    My settings ARE the 127.0.0.1 and  username#popusername  settings.   I just double checked and ports are 110 and 25.  

Its working in both programs.   I even ran the eicar test to be sure

*confused in AZ*

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re:Mail scanner broken with today's update?
« Reply #32 on: November 13, 2004, 08:13:09 PM »
Connie, I believe you're using Win9x. Everything I said only applies to NT-based systems. Sorry for not making this clear.

Cheers
Vlk
If at first you don't succeed, then skydiving's not for you.

conazus

  • Guest
Re:Mail scanner broken with today's update?
« Reply #33 on: November 13, 2004, 08:15:22 PM »
Vlk... ahhhhh okay...   thank you ...    

Offline Reiner

  • Jr. Member
  • **
  • Posts: 53
  • I'm a llama!
Re:Mail scanner broken with today's update?
« Reply #34 on: November 14, 2004, 06:36:42 PM »
Hi,

using the internet mail scanning function together with K9 (Spam-Filter) and The Bat! doesn't seem to work in the default settings. I changed everything back to my provider settings, but Incoming mails seem no to be scanned (no text is added). K9 fetches the mails directly from the mailserver bypassing avast!

Setting it to 12110 and using the old settings works. Is there a possibility using the "new" settings" together with K9 and the Bat!?

Reiner

Offline tigemac

  • Newbie
  • *
  • Posts: 16
Re:Mail scanner broken with today's update?
« Reply #35 on: November 14, 2004, 07:50:41 PM »
Vlk,

I noticed this issue as well.  I changed my settings per your instructions and it is working again.

However, I did use the MPW originally to setup my mail client and upon this update my 127.0.0.1 settings were not automatically reversed.  I had to do this step manually.

So, I don't think that the automated adjustment is working perfectly in all cases.  Just FYI...

-tigemac

P.S.  Thanks for making Avast transparent in Thunderbird!  It's much nicer this new way than having to do the loopback address and then the username#mailserver scenario.



Offline Bombos

  • Newbie
  • *
  • Posts: 3
Re:Mail scanner broken with today's update?
« Reply #36 on: November 14, 2004, 08:16:06 PM »
We had a similar problem and lost a lot of time because the help file  ;) told us to use the mail protection wizard, which was nowhere to be found.
Eventually we found the reply to a FAQ on the Avast site, saying this version does not work with 127.0.01 anymore.  Just leave the names of your regular pop and smtp server in the appropriate places of your e-mail program.
I did this manually for my wife and checked my Eudora settings and behold, it had already been changed!
So far so good, but...
I do not have these reassuring lines in my last e-mails:
X-Antivirus: avast! (VPS ###-#, mm/dd/yyyy), Inbound message
X-Antivirus-Status: Clean

Has Avast discontinued using these lines? Or were the mails not scanned at all?

Offline .: Mac :.

  • Avast Überevangelist
  • Ultra Poster
  • *****
  • Posts: 5092
Re:Mail scanner broken with today's update?
« Reply #37 on: November 14, 2004, 08:27:48 PM »
The have disapperaed from my incoming and outgoing email as well
"People who are really serious about software should make their own hardware." - Alan Kay

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 85959
  • No support PMs thanks
Re:Mail scanner broken with today's update?
« Reply #38 on: November 14, 2004, 08:37:57 PM »
They should still be there, is the total of scanned emails being increased?

This is from the headers of my last email
Quote
X-Antivirus: avast! (VPS 0446-2, 11/11/2004), Inbound message
X-Antivirus-Status: Clean
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.9.2494 (build 21.9.6698.703) UI 1.0.672/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Bombos

  • Newbie
  • *
  • Posts: 3
Re:Mail scanner broken with today's update?
« Reply #39 on: November 14, 2004, 08:48:15 PM »
Browsing different threads I came across the eicar-test virusses. I sent myself the first 6 tests - all except one were blocked. So it seems Avast is scanning (shshsh - don't tell anybody)
The only file not blocked was smime.p7s.
Maybe the Man From Avast wants to know.

Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31301
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re:Mail scanner broken with today's update?
« Reply #40 on: November 14, 2004, 08:51:18 PM »
What happens if you add the extension p7s to the Standard Shield provider?

Offline Bombos

  • Newbie
  • *
  • Posts: 3
Re:Mail scanner broken with today's update?
« Reply #41 on: November 14, 2004, 09:21:58 PM »
Thank you, Eddy -- I did it and retried. The file has been deleted by the Avast scanner. Bye now.

Offline Lars-Erik

  • Avast Evangelist
  • Sr. Member
  • ***
  • Posts: 394
    • Lars-Erik Østerud
Re:Mail scanner broken with today's update?
« Reply #42 on: November 14, 2004, 10:08:59 PM »
It works automatically ONLY IF they were previously set up by the Mail Protection Wizard (which was not the case here - I believe...).

Ouch..  All the friend I have helped will kill me :-(
Most of them are manual setups with WinXP :-(

Why can't the old way still work? I donæt want YET ANOTHER service that is filtering all communication. It's just another slowdown. The 127.0.0.1 system for mail-scanning was the part of avast! I liked most. Now it has become just as all the other scanners :-(

(well, well, for Win98 it still functions as before :-)
www.osterud.name - ICQ: 7297605 - AIM/Yahoo/Facebook/Skype/Astra: LarsErikOsterud

Offline .: Mac :.

  • Avast Überevangelist
  • Ultra Poster
  • *****
  • Posts: 5092
Re:Mail scanner broken with today's update?
« Reply #43 on: November 14, 2004, 10:37:56 PM »
Eicar it detected and removed from email so it works fine; I just miss the Email Scanned by Avast Antivirus etc at the bottom of my outgoing email
"People who are really serious about software should make their own hardware." - Alan Kay

Offline Tipton

  • Avast Evangelist
  • Advanced Poster
  • ***
  • Posts: 796
  • That 70's Car
Re:Mail scanner broken with today's update?
« Reply #44 on: November 14, 2004, 11:35:33 PM »
Eicar it detected and removed from email so it works fine; I just miss the Email Scanned by Avast Antivirus etc at the bottom of my outgoing email

I don't understand your concern about this. The outbound and inbound message clean tags are still there. Also the popup telling you it is scanning is still there.

Tipton
"I have lived through alot of horrible things in my life.......some of which actually happened"