Author Topic: Windows NT4 crash after Avast update  (Read 15629 times)

0 Members and 1 Guest are viewing this topic.

Reiner

  • Guest
Re:Windows NT4 crash after Avast update
« Reply #15 on: November 14, 2004, 03:23:02 PM »
Hi,

I'm using a german NT4/SP6 and tried the new asptdi.sys. The system booted OK but after logging on to the system, it waited for ever. It became unusable, because the cursor showed the hourglass permanently. With another system I connected to the machine and disbled the AVAST service and renamed all files starting with asw* in winnt/system32/drivers. After that I could restart the system, it works, but of course AVAST is not running.

What can I do to get my system as well as AVAST up and running again?

Greetings from Germany

Reiner

Offline pk

  • Avast team
  • Super Poster
  • *
  • Posts: 2084
Re:Windows NT4 crash after Avast update
« Reply #16 on: November 14, 2004, 03:27:23 PM »
so, you used the fixed nt4 aswtdi.sys, right ?
could you please test it also without aswtdi.sys (e.g. you can rename it) - it would be very useful to know if aswtdi.sys caused that. Thanks.

Reiner

  • Guest
Re:Windows NT4 crash after Avast update
« Reply #17 on: November 14, 2004, 03:35:16 PM »
I'am back in one hour to test it. But it seems like it. After I could use the system (deleting the asw* files) I started the update service and updated the system, restarted it and again the same problem.

Reiner

Offline pk

  • Avast team
  • Super Poster
  • *
  • Posts: 2084
Re:Windows NT4 crash after Avast update
« Reply #18 on: November 14, 2004, 03:43:33 PM »
Sorry i dont know if i got you: can you reinstall v4.5, just delete aswtdi.sys (from <winnt>\system32\drivers folder) and check it slows down your system or not? If it dont help, try to delete (or move to temp directory) aswMon.sys from the same directory ?

Reiner

  • Guest
Re:Windows NT4 crash after Avast update
« Reply #19 on: November 14, 2004, 04:22:56 PM »
Hi,

ok, that's what I did:

Using the update service I updated the system yesterday.
This morning I tried to start my system and what happend was: I got the normal blue start screen where NT normally shows the dots for the devices. I never saw the dots, but my system went directly to BIOS start screen.
After reading the forum, I exchanged the aswtdi.sys. This helped so far, that I saw the dots, the logon screen appeared and I could logon to the system. However, all my programs in autostart an from the run-HKEY never showed up. Instead I got the hourglass and the system seemed to lock-up.
I then stopped the avast service and renamed the asw* files in winnt/system32/drivers.
After that I could start and use my system normally. Of course avast was not running.
After that I started the update service manually and run Program-Update. What I think happend was that the update service realized that I had downloaded the update recently and reinstalled the previously renamed asw* files. I rebooted and the same thing (no dots, reboot from bios) happened. I checked again and saw that the update service had reinstalled the renamed files, and of course the old aswtdi.sys file as well.

Do you want me to do something else? Just let me know

Reiner

Offline pk

  • Avast team
  • Super Poster
  • *
  • Posts: 2084
Re:Windows NT4 crash after Avast update
« Reply #20 on: November 14, 2004, 04:29:38 PM »
Thanks for your useful info, one last test: you deleted two asw*.sys files in \drivers folder (aswtdi and aswmon) - i'd like to know which file caused that slow down - could you please delete only aswtdi, keep aswmon.sys there and test it ? it will be still slow, delete aswmon and let me know, thanks.
« Last Edit: November 14, 2004, 04:31:24 PM by pk »

Reiner

  • Guest
Re:Windows NT4 crash after Avast update
« Reply #21 on: November 14, 2004, 04:32:25 PM »
Hi,

in winnt/system32/drivers I've got aswtdi.sys, aswmon.sys and aswmon2.sys. What should I keep and what delete? Which aswtdi.sys should I use, the one provided with the update or the new one?

Offline pk

  • Avast team
  • Super Poster
  • *
  • Posts: 2084
Re:Windows NT4 crash after Avast update
« Reply #22 on: November 14, 2004, 04:34:58 PM »
- delete aswtdi.sys - restart and see if it slows down
- if yes, delete both aswmon/aswmon2 files; restart and check it system's slowing down

Reiner

  • Guest
Re:Windows NT4 crash after Avast update
« Reply #23 on: November 14, 2004, 04:40:35 PM »
I'm a bit confused right now. The new aswtdi.sys causes the same misbehaviour (reboot, no dots). I just deleted it. Without aswtdi.sys my system boots, I get the logon screen and it seems to work. However avast seems not to work

Reiner

  • Guest
Re:Windows NT4 crash after Avast update
« Reply #24 on: November 14, 2004, 04:47:59 PM »
To me it seems as if aswtdi.sys is the problem. Is aswtdi.sys the program beeing responsible for the avast-service? After deleting aswtdi.sys I'm not able to start the service anymore nor are any avast-providers running.

Reiner

  • Guest
Re:Windows NT4 crash after Avast update
« Reply #25 on: November 14, 2004, 05:04:55 PM »
Hi,

sorry for my "mess". After deleting, reinstalling, testing, etc. I checked the system again.

That the avast providers were not running was due to the fact, that I renamed aswmon.sys.

Now, only aswtdi.sys is deleted in winnt/system32/drivers. Still there are aswmon.sys and aswmon2.sys. Avast-providers are there and it looks normal. System is running OK. The only thing missing is aswtdi.sys.

What is this file used for?

Reiner

Offline pk

  • Avast team
  • Super Poster
  • *
  • Posts: 2084
Re:Windows NT4 crash after Avast update
« Reply #26 on: November 14, 2004, 05:15:04 PM »
aswtdi is for network shield provider; we install wint4 OS to check if it's all right, we didnt have problems with nt4 until some users compains there was BSOD in their system.

Reiner

  • Guest
Re:Windows NT4 crash after Avast update
« Reply #27 on: November 14, 2004, 05:27:17 PM »
OK,

is this linked to the problem that I can't receive e-mails anymore thru the Mail Shield of avast (I use the Bat!). Before the update everything was working.

Reiner

Reiner

  • Guest
Re:Windows NT4 crash after Avast update
« Reply #28 on: November 14, 2004, 07:02:39 PM »
Hi,

will there be a solution for this problem? When will you supply an update? I don't want to update AVAST automatically before the problem is solved  ;)

Regards

Reiner

Offline pk

  • Avast team
  • Super Poster
  • *
  • Posts: 2084
Re:Windows NT4 crash after Avast update
« Reply #29 on: November 14, 2004, 07:06:18 PM »
we want to test it on winnt4 yet (win2k+ is ok), but it seems we have simulated the problem - i will know more within some minutes...