Author Topic: Issues Deploying BPP To Servers  (Read 8572 times)

0 Members and 1 Guest are viewing this topic.

KyleL

  • Guest
Issues Deploying BPP To Servers
« on: September 21, 2011, 06:55:08 PM »
Hello Everyone,

I'm hoping someone out there can shed some light on this as it has been driving all of us at the office nuts for a few weeks. We are unable to deploy BPP to any server that we have installed it on (Server 2003, 2008, SBS 2008). Initially I wasn't even able to get the files to copy to the 2008 servers until I disabled UAC. I know the account I'm using has the correct permissions as in a lot of cases I'm just using our usual Administrator account. Secondly, I'm able to deploy to all the workstations on the network without issue. The other puzzling part is at a few of these sites we used the same account to deploy Avast 4.8 in the past to the server and workstations without issue. Other sites have never had Avast or any AV software installed on the server period as they are new deployments.

The account I'm using has local administrative rights and log on as service rights set via GP. I've ensured the Network Service account has the same rights. I also tried creating a new user account specifically for deployment with the required group membership and set Domain Admins as the primary group.

As you can see from the logs it actually copies all of the files and then runs into a problem after the files are copied. I can actually watch the files copy, I can browse the ~AVAST folder that the installer creates for a few seconds before it removes it. I have connected to the server's C$ share using the administrator account and I can create/delete/modify files and folders without issues.

I've contacted Avast for support and all they told me is the problem has to be on my end because it is a permissions problem. I pressed for further assistance as I was able to figure that much out myself but they stopped answering my messages.

I will include the log file in the next post as this one exceeds the character limit. The log file is the same on every server.

Thanks in advance to anyone who can help!

KyleL

  • Guest
Re: Issues Deploying BPP To Servers
« Reply #1 on: September 21, 2011, 07:02:46 PM »

Code: [Select]
09/21/11 10:31:52:   rinstInitLibrary 21
09/21/11 10:31:52:   rinstInstall begin
09/21/11 10:31:52:   Init 1 10 C:\ProgramData\AVAST Software\Administration Console\Mirror\Packages\admin.ini C:\ProgramData\AVAST Software\Administration Console\Mirror\Packages\setup.exe NULL NULL 0 9
09/21/11 10:31:52:   Starting "C:\ProgramData\AVAST Software\Administration Console\Mirror\Packages\setup.exe" /verysilent /managed /reboot "no" /edition "9" /netcl_addr "SERVER.centralsewing.local" /netcl_port "25322" /admin "C:\ProgramData\AVAST Software\Administration Console\Mirror\Packages\admin.ini" /sfxstorage "C:\ProgramData\AVAST Software\Administration Console\Mirror\Packages"
09/21/11 10:31:52:   Setup exit code 0x20000000
09/21/11 10:31:52:   Store
09/21/11 10:31:52:   Domains: centralsewing.local,
09/21/11 10:31:52:   Init centralsewing.local\SERVER
09/21/11 10:31:52:   SERVER: GetAccount
09/21/11 10:31:52:   SERVER: Queueing
09/21/11 10:31:52:   StartThread
09/21/11 10:31:52:   Loop
09/21/11 10:31:52:   SpawnThreads
09/21/11 10:31:52:   SERVER: StartSetup
09/21/11 10:31:52:   SERVER: Connecting
09/21/11 10:31:52:   SERVER: OpenSCManager error 5 (Access is denied.

)
09/21/11 10:31:52:   SERVER: OpenSCMImpersonated
09/21/11 10:31:52:   SERVER: AdjustTokenPrivileges return 1300
09/21/11 10:31:52:   SERVER: Copying files
09/21/11 10:31:52:   SERVER: Copying aswISvc.exe
09/21/11 10:31:52:   SERVER: Copying admin.ini
09/21/11 10:31:52:   SERVER: Copying ais_core-3f6.vpx
09/21/11 10:31:53:   SERVER: Copying ais_core-419.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_ara-2c8.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_ara-2eb.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_bel-292.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_bel-2b5.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_blg-32d.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_blg-350.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_cat-293.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_cat-2b6.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_chs-425.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_chs-448.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_cht-327.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_cht-34a.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_cro-2ce.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_cro-2f1.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_cze-423.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_cze-446.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_dan-266.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_dan-289.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_dut-2f1.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_dut-314.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_eng-44f.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_eng-472.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_esp-421.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_esp-444.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_est-32d.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_est-350.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_fin-2e9.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_fin-30c.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_fre-421.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_fre-444.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_ger-421.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_ger-444.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_gre-315.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_gre-338.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_heb-27d.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_heb-2a0.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_hun-33b.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_hun-35e.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_ind-156.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_ind-179.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_ita-41f.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_ita-442.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_jpn-3f1.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_jpn-414.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_kor-341.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_kor-364.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_nor-2e9.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_nor-30c.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_pir-23d.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_pir-260.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_pol-422.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_pol-445.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_por-425.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_por-448.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_ptg-2f1.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_ptg-314.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_rom-285.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_rom-2a8.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_rus-423.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_rus-446.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_slo-2e0.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_slo-303.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_srb-54.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_srb-77.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_svk-311.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_svk-334.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_swe-32d.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_swe-350.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_tha-5e.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_tha-81.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_tur-2de.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_tur-301.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_ukr-315.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_ukr-338.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_urd-242.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_urd-265.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_vie-2dc.vpx
09/21/11 10:31:53:   SERVER: Copying ais_dll_vie-2ff.vpx
09/21/11 10:31:53:   SERVER: Copying ais_fw-29c.vpx
09/21/11 10:31:54:   SERVER: Copying ais_fw-2bf.vpx
09/21/11 10:31:55:   SERVER: Copying ais_managed-9c.vpx
09/21/11 10:31:55:   SERVER: Copying ais_managed-bf.vpx
09/21/11 10:31:55:   SERVER: Copying ais_pro-459.vpx
09/21/11 10:31:55:   SERVER: Copying ais_pro-47c.vpx
09/21/11 10:31:55:   SERVER: Copying ais_res-33b.vpx
09/21/11 10:31:55:   SERVER: Copying ais_res-35e.vpx
09/21/11 10:31:55:   SERVER: Copying ais_snx1-b.vpx
09/21/11 10:31:55:   SERVER: Copying ais_snx2-7.vpx
09/21/11 10:31:56:   SERVER: Copying ais_snx3-2.vpx
09/21/11 10:31:56:   SERVER: Copying ais_spm-3f2.vpx
09/21/11 10:31:56:   SERVER: Copying ais_spm-415.vpx
09/21/11 10:31:56:   SERVER: Copying ais_srv-206.vpx
09/21/11 10:31:56:   SERVER: Copying ais_srv-229.vpx
09/21/11 10:31:56:   SERVER: Copying ais_x64-49d.vpx
09/21/11 10:31:56:   SERVER: Copying ais_x64-4c0.vpx
09/21/11 10:31:56:   SERVER: Copying chrome-2.vpx
09/21/11 10:31:56:   SERVER: Copying jollyroger.vpx
09/21/11 10:31:56:   SERVER: Copying jrog-a7.vpx
09/21/11 10:31:56:   SERVER: Copying jrog2-301.vpx
09/21/11 10:31:56:   SERVER: Copying part-jrog-a7.vpx
09/21/11 10:31:56:   SERVER: Copying part-jrog2-301.vpx
09/21/11 10:31:56:   SERVER: Copying part-prg_abp-4e5.vpx
09/21/11 10:31:56:   SERVER: Copying part-setup_abp-4e5.vpx
09/21/11 10:31:56:   SERVER: Copying part-vps_win32-11092100.vpx
09/21/11 10:31:56:   SERVER: Copying prod-abp.vpx
09/21/11 10:31:56:   SERVER: Copying servers.def
09/21/11 10:31:56:   SERVER: Copying servers.def.vpx
09/21/11 10:31:56:   SERVER: Copying setif_abp-4e5.vpx
09/21/11 10:31:56:   SERVER: Copying setup.exe
09/21/11 10:31:56:   SERVER: Copying setup_abp-4e5.vpx
09/21/11 10:31:56:   SERVER: Copying vps_32-5be.vpx
09/21/11 10:31:57:   SERVER: Copying vps_win32-5d2.vpx
09/21/11 10:31:57:   SERVER: Copying vps_win64-262.vpx
09/21/11 10:31:57:   SERVER: Copying winsys-4.vpx
09/21/11 10:31:57:   SERVER: Copying winsys64-1.vpx
09/21/11 10:31:57:   SERVER: NetShareGetInfo \\SERVER C$ error 5 (Access is denied.

)
09/21/11 10:31:57:   SERVER: RemoveOnError
09/21/11 10:31:57:   SERVER: RemoveFolder \\SERVER\C$\~AVINSTL
09/21/11 10:31:58:   SERVER: CloseConnection
09/21/11 10:31:58:   SERVER: Finished with error
09/21/11 10:31:58:   TerminateAll
09/21/11 10:31:58:   rinstInstall end 0

Offline spi

  • Poster
  • *
  • Posts: 514
  • 1st Services
Re: Issues Deploying BPP To Servers
« Reply #2 on: September 22, 2011, 05:01:23 AM »
Hi KyleL,

sometimes I try log in from command DOS prompt by typing "c:\net use x: \\servername\c$ /user:administrator"

if fail to login to server is mean the username is not grant to access the c$
 

Quote
09/21/11 10:31:57:   SERVER: NetShareGetInfo \\SERVER C$ error 5 (Access is denied.)
09/21/11 10:31:57:   SERVER: RemoveOnError
09/21/11 10:31:57:   SERVER: RemoveFolder \\SERVER\C$\~AVINSTL

from this log is shown the access is denied to created folder ~AVINSTL on the folder C

Windows 10 Pro 64-bit + avast Premium 11.1.2241
Network tools: Wireshark+CACE Pilot | Android Softphone + Grandstream UCM61xx | MI4i | Running Out of Time (1999)

MarKvi

  • Guest
Re: Issues Deploying BPP To Servers
« Reply #3 on: September 22, 2011, 09:59:27 AM »
Am I right, that you put Domain\ComputerName credentials instead of Domain\AccountName in Deployment job under Details tab -> User credentials section?

Currently,if you are running under domain, AccountName without Domain name should be sufficient.

Offline vojtech

  • Avast team
  • Advanced Poster
  • *
  • Posts: 939
    • ALWIL Software
Re: Issues Deploying BPP To Servers
« Reply #4 on: September 22, 2011, 02:36:30 PM »
Hello,
this problem will be fixed in the upcoming version released in the beginning of october.

KyleL

  • Guest
Re: Issues Deploying BPP To Servers
« Reply #5 on: September 22, 2011, 06:40:24 PM »
MarKvi - I am running under a domain and under the Deployment Job Details I have the account name without domain entered.

Spi - I gathered it was having permission problems with the ~AVINSTL folder as well which didn't make much sense to me considering it is writing all the files to that folder then removing them. If I catch the deployment and just the right time I can open the folder and watch it do this.

Vojtech - Your telling me it is a known issue that you can't deploy BPP to servers and we have to wait till October for a fix? This doesn't seem up to Avast's usual standards. I've come accustomed to a high quality product from your company over the years. I understand the pains of releasing a new version but this product really doesn't seem like it was ready for final release.

Paul Rodgers

  • Guest
Re: Issues Deploying BPP To Servers
« Reply #6 on: September 25, 2011, 06:14:32 PM »
Just log on to the servers and navigate to servername.domain/avast/install.aspx to install on your servers.

randydodd

  • Guest
Re: Issues Deploying BPP To Servers
« Reply #7 on: September 26, 2011, 07:23:26 AM »
Paul, thanks for a solution. Believe it or not, there are many of us out here having the same issues. I am using SBS 2003, and my 3-year licsense expired under 4.8. I had to get a new license and go to BPP.
Hasn't worked from day 1. Sales says wait till October; I cannot. Tech Support has me doing a bunch of stuff; not much works. Finally bypassed the main console; jumped to the services console and got the clients to setup and install. Now working on the server. Your trick worked.
Waiting till October is not much of a solution.

Still having some issues with some clients, but i think that's fixable.
I had almost a week without any protection - ouch.

Paul Rodgers

  • Guest
Re: Issues Deploying BPP To Servers
« Reply #8 on: September 26, 2011, 01:39:42 PM »
Paul, thanks for a solution. Believe it or not, there are many of us out here having the same issues. I am using SBS 2003, and my 3-year licsense expired under 4.8. I had to get a new license and go to BPP.
Hasn't worked from day 1. Sales says wait till October; I cannot. Tech Support has me doing a bunch of stuff; not much works. Finally bypassed the main console; jumped to the services console and got the clients to setup and install. Now working on the server. Your trick worked.
Waiting till October is not much of a solution.

Still having some issues with some clients, but i think that's fixable.
I had almost a week without any protection - ouch.


I have been breaking this product and fixing it since day 1. Only way to learn. I'm glad that my solution worked for you.

KyleL

  • Guest
Re: Issues Deploying BPP To Servers
« Reply #9 on: September 26, 2011, 06:24:19 PM »
Paul thank you very much for the solution! It is really pathetic we have to work around all these problems.
At least it is now installed on the servers I was having issues on!


studio_two

  • Guest
Re: Issues Deploying BPP To Servers
« Reply #10 on: October 24, 2011, 05:20:53 PM »
Forgive me for posting in a old thread, but should I use the built-in "Deploy/update avast! clients on selected computers" Job when deploying !avast to my Network Servers?

We have:
1 x Windows Server 2008 (64 Bit with SQL Server 2008)
1 x Windows Small Business Server 2008 (64 Bit with Exchange 2007)
1 x Windows Server 2003 (32 Bit)

Is the Client Software for Workstations and Servers the SAME?

Thanks in advance,
Stephen

Offline giogio

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 4088
Re: Issues Deploying BPP To Servers
« Reply #11 on: October 24, 2011, 05:28:43 PM »
Forgive me for posting in a old thread, but should I use the built-in "Deploy/update avast! clients on selected computers" Job when deploying !avast to my Network Servers?
Yes you should, if you get an error you can use avast_managed.exe.

Is the Client Software for Workstations and Servers the SAME?
No is not the same, but avast_managed.exe contain the package for client and server, but if you run
"Deploy/update avast! clients on selected computers" Job, there's no problem
Prima di scrivere sul forum per favore leggi le istruzioni qui https://forum.avast.com/index.php?topic=144453.0
Non inviatemi MP per supporto,grazie-No support PM please
Home: E8400-4GB RAM-500GB HDD-Win10.0.15063x64-Avast! Free 17.3.2291-CryptoPrevent-MBAM 2.2free-Chrome 57(uBlock origin)-TB52
Work: i5-2400-4GB RAM-500GB HDD-Win 7sp1x64-Avast!Business Security 12.3.2515,     
Cloud Console 2.18
-FF52-TB52

studio_two

  • Guest
Re: Issues Deploying BPP To Servers
« Reply #12 on: October 24, 2011, 05:33:43 PM »
That's great! Many thanks once again.  :)

Stephen

Offline giogio

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 4088
Re: Issues Deploying BPP To Servers
« Reply #13 on: October 24, 2011, 05:38:38 PM »
You're welcome..  ;)
Prima di scrivere sul forum per favore leggi le istruzioni qui https://forum.avast.com/index.php?topic=144453.0
Non inviatemi MP per supporto,grazie-No support PM please
Home: E8400-4GB RAM-500GB HDD-Win10.0.15063x64-Avast! Free 17.3.2291-CryptoPrevent-MBAM 2.2free-Chrome 57(uBlock origin)-TB52
Work: i5-2400-4GB RAM-500GB HDD-Win 7sp1x64-Avast!Business Security 12.3.2515,     
Cloud Console 2.18
-FF52-TB52

randydodd

  • Guest
Re: Issues Deploying BPP To Servers
« Reply #14 on: November 03, 2011, 02:04:48 AM »
Just installed yet another instance of Avast BPP, and the problems reported here are still happening. Either new release did not happen in October, or BPP still broken. had to run all the workarounds mentioned here. Still wating for the fix, so i can go back and get all my copies working properly on all my servers.