Author Topic: Java SE Runtime Environment 1.7.0_01 Incompatible with Firefox 7.0.1  (Read 6240 times)

0 Members and 1 Guest are viewing this topic.

Offline A. Chung

  • Jr. Member
  • **
  • Posts: 32
Having upgraded to Java Standard Edition Runtime Environment 1.7.0_01, it is reported by Firefox Add-on that Java Console 7.0.01 is not compatible with Firefox 7.0.1.  I am puzzled if which party should take appropriate action on remedying the adverse condition.

A. Chung

Offline A. Chung

  • Jr. Member
  • **
  • Posts: 32
Re: Java SE Runtime Environment 1.7.0_01 Incompatible with Firefox 7.0.1
« Reply #1 on: October 25, 2011, 10:30:32 AM »
My apologies as I have posted my query wrongly.  However, the Firefox Add-on Compatibility Report has indicated that avast! WebRep is not compatible with Firefox 7.0.1 - a compatibility problem.  A little technical help is highly appreciated.

A. Chung 

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67247
Re: Java SE Runtime Environment 1.7.0_01 Incompatible with Firefox 7.0.1
« Reply #2 on: October 25, 2011, 12:07:25 PM »
Strange the fact of WebRep... Are you really using the last Firefox and avast versions?
The best things in life are free.

Offline jrace

  • Sr. Member
  • ****
  • Posts: 381
Re: Java SE Runtime Environment 1.7.0_01 Incompatible with Firefox 7.0.1
« Reply #3 on: October 25, 2011, 01:22:54 PM »

First of all: Java 1.7xxx is compatible with FF 6+ !
There is only one term in the "install.rdf" from Java Plugin which obviously does not work on all systems.

Solution:
1. Get into your user account and draw the slider all the way down and reboot the system.
2. Navigate to your install folder of Mozilla Firefox\extensions\{CAFEEFAC-.....} with the youngest date/time stamp.
(You can delete all the older ones starting with the same characters. They are leftovers from older installations which are also still showing up in Firefox plugins!)
3. In the youngest folder open "install.rdf" with editor.
4. Search for the line:   <em:maxVersion>.....</em:maxVersion>
5. Alter the line so as to look like this:   <em:maxVersion>*</em:maxVersion>
6. Save the file.

Everything should be working now!
You may want to reset your user account to the original setting now and reboot the system.

If you install an update of Java you may have to do the same procedure again.
Sony VGN-SZ71VN/X, 4GB RAM, 256GB SSD, win7/32_ult_SP1-U
avast! pro 11.2.2255, Win7 Firewall, MBAM 2.2.0.1024
FF 45.0

Offline Gopher John

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2098
Re: Java SE Runtime Environment 1.7.0_01 Incompatible with Firefox 7.0.1
« Reply #4 on: October 25, 2011, 04:36:17 PM »
Having upgraded to Java Standard Edition Runtime Environment 1.7.0_01, it is reported by Firefox Add-on that Java Console 7.0.01 is not compatible with Firefox 7.0.1.  I am puzzled if which party should take appropriate action on remedying the adverse condition.

A. Chung

Java Console is not necessary to the function of Java.  If you are troubleshooting Java applets, the you might have a need for it.  I routinely delete all the folders that JRace mentioned in Item #2 without adverse effect.  Do so with Firefox closed to be safe.
AMD A6-5350M APU with Radeon HD Graphics, 8.0GB RAM, Win7 Pro SP1 64bit, IE11
i7-3610QM 2.3GHZ, 8.0GB Ram,  Nvidia GeForce GT 630M 2GB, Win7 Pro SP1 64bit, IE 11
Common to both: Avast Premium Security 19.7.2388, WinPatrol Plus, SpywareBlaster 5.5, Opera 12.18, Firefox 68.0.2, MBam Free, CCleaner

Offline Gopher John

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2098
Re: Java SE Runtime Environment 1.7.0_01 Incompatible with Firefox 7.0.1
« Reply #5 on: October 25, 2011, 04:41:07 PM »
My apologies as I have posted my query wrongly.  However, the Firefox Add-on Compatibility Report has indicated that avast! WebRep is not compatible with Firefox 7.0.1 - a compatibility problem.  A little technical help is highly appreciated.

A. Chung 

You must be running an older version of Avast.  Avast 6.0.1289 WebRep is fully compatible with Firefox 7.0.1. 
AMD A6-5350M APU with Radeon HD Graphics, 8.0GB RAM, Win7 Pro SP1 64bit, IE11
i7-3610QM 2.3GHZ, 8.0GB Ram,  Nvidia GeForce GT 630M 2GB, Win7 Pro SP1 64bit, IE 11
Common to both: Avast Premium Security 19.7.2388, WinPatrol Plus, SpywareBlaster 5.5, Opera 12.18, Firefox 68.0.2, MBam Free, CCleaner

Offline Asyn

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 72827
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Java SE Runtime Environment 1.7.0_01 Incompatible with Firefox 7.0.1
« Reply #6 on: October 25, 2011, 05:53:04 PM »
Avast 6.0.1289 WebRep is fully compatible with Firefox 7.0.1. 

Confirming this.
And btw, it's also compatible with all newer/upcoming versions of FF..!! ;)
Win 8.1 [x64] - Avast PremSec 21.10.6772.IBC [UI.679] - EEK - Firefox ESR 91.3 [NS/uBO/PB] - TB 91.3.2
Avast-Tools: Secure Browser 96.0 - Cleanup 21.3 - SecureLine 5.14 - Driver Updater 21.3 - CCleaner 5.87
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline A. Chung

  • Jr. Member
  • **
  • Posts: 32
Re: Java SE Runtime Environment 1.7.0_01 Incompatible with Firefox 7.0.1
« Reply #7 on: October 26, 2011, 04:21:58 AM »
Dear All

Thanks for your valuable feedback.

Regards,
A. Chung

Offline Asyn

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 72827
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Java SE Runtime Environment 1.7.0_01 Incompatible with Firefox 7.0.1
« Reply #8 on: October 26, 2011, 12:33:39 PM »
Dear All

Thanks for your valuable feedback.

Regards,
A. Chung

You're welcome..!
Win 8.1 [x64] - Avast PremSec 21.10.6772.IBC [UI.679] - EEK - Firefox ESR 91.3 [NS/uBO/PB] - TB 91.3.2
Avast-Tools: Secure Browser 96.0 - Cleanup 21.3 - SecureLine 5.14 - Driver Updater 21.3 - CCleaner 5.87
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0