Author Topic: Problems with Avast 4.5.523 Home and PegasusMail 4.23c  (Read 9372 times)

0 Members and 1 Guest are viewing this topic.

Offline holgerkaengu

  • Newbie
  • *
  • Posts: 18
Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
« Reply #15 on: November 16, 2004, 10:35:29 AM »
Thanks all for the tipps and tricks suggested so far.

Here are the results: Nothing worked so far. The error that occurs is remaining the same. Large mails (over 10kb) did not come through.

Here are the facts:
a) It cannot be the firewall because when I shut it down the same happens
b) It can not be Pegasus because when I shutdown the avast internet mail scanner everything works perfectly
c) It can not be wrong settings in some programmes because small mails come through even with enabled avast mail scanner

I tried with the 127.0.0.1 as well as pop.provider.com settings. I believe it is either depending on special settings of the avast.ini in the data folder or changes to ashmaisv.exe itself who has problems handling larger emails.

I tried very much but nothing helped so far. The error stays the same. Has someone a donwload link (URL) vor me that I can download an earlier version of avast before 4.5.xxx? so a 4.1 +x (e.g. 4.4.x) Version (published before 09.11.04) as the "old" avast worked very fine with Pegasus on my computer. Perhaps I can make some compares (settings and other things) to find a solution (perhaps I find what is wrong then I will publish it here immediatelly as a tryout tip). That would be great.  

Thanks in advance

Yours

Holger
« Last Edit: November 16, 2004, 10:39:12 AM by holgerkaengu »

Offline holgerkaengu

  • Newbie
  • *
  • Posts: 18
Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
« Reply #16 on: November 16, 2004, 12:08:06 PM »
Hello I have made all setting change proposals but the result stays the same. Meanwhile I believe it is due to the ashmaisv.exe that causes the problems (setting changes have no effect to the error). So I would be glad to have a URL to download the "old" 4.1 version. Can anyone help me to get a download URL. Thank you.

S.Z.Craftec

  • Guest
Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
« Reply #17 on: November 16, 2004, 12:12:33 PM »
Well, I don't have alink, but going back to older version is not the permanent solution. I'm sure someone will find a solution for you. It's working here without any problems, so that means nothing is wrong with 4.5

It's just compilation of all those settings in programs you are using. Wait a little bit and someone will come up with something.

Offline W

  • Jr. Member
  • **
  • Posts: 53
Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
« Reply #18 on: November 16, 2004, 12:34:02 PM »
holgerkaengu,

I just wondered if you had tried:-

1, making sure that you do not have a download limit set under 'Download Controls' in Pegasus's POP3· settings?.

2, increasing the 'time-out' values in Pegasus's POP· and SMTP settings?.

I can understand the frustration when it worked prior to the Avast update, but I am taking a big guess that it is to do with time-outs because prior to the update mail would be routed through the localhost (127.0.0.1) and this would pass through very quickly and/or possibly form a buffer that masked any time-out settings.

Good luck.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67259
Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
« Reply #19 on: November 16, 2004, 12:37:51 PM »
Holgerkaengu, listen to our master in Pegasus  8)
The best things in life are free.

Offline holgerkaengu

  • Newbie
  • *
  • Posts: 18
Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
« Reply #20 on: November 16, 2004, 01:07:29 PM »
Sure I listen to the master :-)

but there is no limitation which depends on Pegasus as if I switch off avast mail scanner everything works fine and fast. So if there is a general setting in Pegasus regarding limitation it would not work every time. But that is not the fact: Switching mail scanner off = everything works, switching avast mail scanner on = nothing works anymore.

I also tripled the time of timeouts in Pegasus but even after 5minute snothing happens.

I really tried several settings in the ini (under data folder) but the result stays the same. So I really think it is the ashmaisv.exe that causes the problem. Perhaps I can restore it to the old one. Can someone send me an "old" ashmaisv.exe just for testing purposes. Would be grat to know if I think in the right direction. Perhaps someone from alwil can post it.

Thanks all of you for your efforts.

Yours

Holger

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67259
Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
« Reply #21 on: November 16, 2004, 01:12:11 PM »
Maybe you can:

Add the following line to the [MailScanner] section of <avast>\data\avast4.ini:

Log=20

Then generate some traffic, simulate the problem (i.e. force the avast mail scanner to time out by sending an email with attachment) and then post here the contents of the file <avast>\data\log\aswMaiSv.log
The best things in life are free.

Offline holgerkaengu

  • Newbie
  • *
  • Posts: 18
Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
« Reply #22 on: November 16, 2004, 01:22:14 PM »
Have a look at the first page of this thread I have already mad and published shows a lot (perhaps little bit to much) sleep.

Would be fine to have an old version download just for testing purposes.

Bye

Offline W

  • Jr. Member
  • **
  • Posts: 53
Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
« Reply #23 on: November 16, 2004, 01:39:01 PM »
holgerkaengu,


Quote
but there is no limitation which depends on Pegasus as if I switch off avast mail scanner everything works fine and fast.

Well actually there is (or more correctly, can be) ;)

I thought I had read that you had returned to the 127.0.0.1 POP/SMTP settings. Apologies if I misread this.

Quote
So if there is a general setting in Pegasus regarding limitation it would not work every time. But that is not the fact: Switching mail scanner off = everything works, switching avast mail scanner on = nothing works anymore.

What I was trying to say was,going through localhost (with or without Avast! scanning) might have masked any time-out settings in Pegasus. Purely because sending to localhost is very quick and buffered.

However, sorry if it does not resolve the problem.

Offline namaste

  • Newbie
  • *
  • Posts: 4
Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
« Reply #24 on: November 17, 2004, 03:53:14 PM »
Hi, the same problem of holgerkaengu happens to me with OE 6.
Initially I thought it was an attachment problem (and I posted this wrong problem), but now I try to send an e-mail of 67 Kb without attachment and OE is not able to send it.
First appears the usually OE's message of no reply in 60 seconds by SMTP server and then the window of OE which explain that a timeout error (0x800CCC19) happens; after 300 seconds an Avast!'s message of no reply by SMTP server ... but with an ADSL line it's impossible wait 5 minutes to send a 67 Kb mail!
When I switch off Avast!'s mail provider all works fine and fast ... so I think it's an Avast! problem :'(
See you

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re:Problems with Avast 4.5.523 Home and PegasusMail 4.23c
« Reply #25 on: November 17, 2004, 05:06:44 PM »
Is this only a problem with outbound mail? Or inbound mail as well?

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.