Author Topic: Avast blocks Battlefield 3 join requests  (Read 10308 times)

0 Members and 1 Guest are viewing this topic.

Offline zmoose

  • Newbie
  • *
  • Posts: 1
Avast blocks Battlefield 3 join requests
« on: October 26, 2011, 07:40:53 AM »
See this thread for details:

http://battlelog.battlefield.com/bf3/forum/threadview/2832654347699167126/

Users of Battlefield 3 are having issues where Avast is blocking legit websocket connections.  As a result we do not receive a join request to play with our friends.  I can disable Avast! to work around this.

Avast info
Program version: 6.0.1289
Engine/virus definitions: 111025-1
« Last Edit: October 26, 2011, 07:42:57 AM by zmoose »

Offline Gargamel360

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2346
  • Memento Mori
Re: Avast blocks Battlefield 3 join requests
« Reply #1 on: October 26, 2011, 07:49:01 AM »
In the Web Shield's expert settings, there is a check box titled "Scan traffic from well known browser processes only".  Try to tick that on, see if you get results.

http://battlelog.battlefield.com/bf3/forum/threadview/2832654347699167126/
fyi, the link requires a login.
Signature?  But I gots no pen....

Offline acousticdank

  • Newbie
  • *
  • Posts: 1
Re: Avast blocks Battlefield 3 join requests
« Reply #2 on: October 26, 2011, 10:06:14 AM »
Hi,
Avast 6.0.1289
def: 111025-1

Basically, this is what's in that page.
Quote
Test websocket connections in Chrome
1. Go to http://websocket.org/echo.html [websocket.org]
2. Click on Connect. Do you get a line saying CONNECTED in the Log window?
3. Click on Send. Do you get SENT and RESPONSE lines in the Log window?
4. If you answered "No" to 2 or 3, check Use secure WebSocket (TLS) and try 2 and 3 again. Different result?

Please update your posts in this thread if you have Chrome installed and add your result from this test.
* Could you connect with/without TLS?
* Could you send messages with/without TLS?
* Could you receive messages with/without TLS?

Tested Anti-virus programs so far (Updated continously):

LATEST version available and DEFAULT settings if not stated otherwise:

Avast
Works if web shield is disabled/stopped.
Also reported to work if you go into the settings and check the box "Scan known processes only". Then everything else can be left on.

Ask Avast why they block legit websocket connections here:
http://forum.avast.com/index.php?board=2.0 [forum.avast.com]

For me, I do not get a response unless I disable webshield or use the TLS version.

Hope this can help?  I don't want to disable/stop webshield to play the game.

I tried what Gargamel said but it didn't help..

Offline Tburns65

  • Newbie
  • *
  • Posts: 2
Re: Avast blocks Battlefield 3 join requests
« Reply #3 on: October 27, 2011, 06:15:07 PM »
In the Web Shield's expert settings, there is a check box titled "Scan traffic from well known browser processes only".  Try to tick that on, see if you get results.

Tried the above with no result.

Offline Dommelrbb

  • Newbie
  • *
  • Posts: 2
Re: Avast blocks Battlefield 3 join requests
« Reply #4 on: October 30, 2011, 09:44:58 PM »
Would like to report that I am having the same issue.
Running latest Avast with latest updates.

Disabling webshield, or enabling "Scan traffic from well known browser processes only" works.

A copy/paste from my Battlelog forum post about this issue:
--------------------
--
Firefox 7.0.1
- Adblock plus 1.3.10
- Ant Video Downloader 2.4.4
- Download Statusbar 0.9.10
- IE tab 2 (FF 3.6+) 3.10.7.2
- NoScript 2.1.7
< disabling addons has no effect >

Avast! Free Antivirus 6.0.1289
- virus definitions: 111030-0
< is always updated >

Windows 7 firewall
< all windows 7 updates, including optional >

Router: Alcatel Speedtouch 510 (firmware 4.2.7.16.0)
< old router, with latest firmware >
--

I would like to report that adding *battlelog.battlefield.com/*, or any form of that. Has no effect on the issue, I cannot receive party invites and Battlelog doesn't not auto refresh. Only solution at the moment is either disable webshield, or enable "Scan known processes only".
---------------------
« Last Edit: October 30, 2011, 09:46:32 PM by Dommelrbb »

Offline outraged

  • Newbie
  • *
  • Posts: 2
Re: Avast blocks Battlefield 3 join requests
« Reply #5 on: November 08, 2011, 02:26:42 PM »
I have the same issue.  The shield log shows that it's taking no action, but disabling the web shield resolves it for some reason.

Offline Sambuccashake

  • Newbie
  • *
  • Posts: 3
Re: Avast blocks Battlefield 3 join requests
« Reply #6 on: November 09, 2011, 10:33:23 AM »
Same problem here.

Very annoying.

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 85628
  • No support PMs thanks
Re: Avast blocks Battlefield 3 join requests
« Reply #7 on: November 09, 2011, 01:46:44 PM »
As Dommelrbb mentioned there is a workaround:
<snip>
Disabling webshield, or enabling "Scan traffic from well known browser processes only" works.
<snip>
I would like to report that adding *battlelog.battlefield.com/*, or any form of that. Has no effect on the issue, I cannot receive party invites and Battlelog doesn't not auto refresh. Only solution at the moment is either disable webshield, or enable "Scan known processes only".

Obviously the lessor of the two evils so that you retain web shield protection is Don't disable the Web Shield, check the "Scan traffic from well known browser processes only" option in the avastUI, Real-Time Shields, Expert Settings, "Scan traffic from well known browser processes only."
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 21.8.2487 (build 21.8.6586.691) UI 1.0.666/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline heliaca

  • Newbie
  • *
  • Posts: 1
Re: Avast blocks Battlefield 3 join requests
« Reply #8 on: November 14, 2011, 03:55:41 PM »
As Dommelrbb mentioned there is a workaround:
<snip>
Disabling webshield, or enabling "Scan traffic from well known browser processes only" works.
<snip>
I would like to report that adding *battlelog.battlefield.com/*, or any form of that. Has no effect on the issue, I cannot receive party invites and Battlelog doesn't not auto refresh. Only solution at the moment is either disable webshield, or enable "Scan known processes only".

Obviously the lessor of the two evils so that you retain web shield protection is Don't disable the Web Shield, check the "Scan traffic from well known browser processes only" option in the avastUI, Real-Time Shields, Expert Settings, "Scan traffic from well known browser processes only."

This Check NOT work ... realy
battlelog work only if disable web shield ...

plz fix it..