Author Topic: Problem in the network transfer rate.  (Read 21219 times)

0 Members and 1 Guest are viewing this topic.

Offline slipperx

  • Newbie
  • *
  • Posts: 6
Re: Problem in the network transfer rate.
« Reply #15 on: June 27, 2012, 10:47:09 AM »
I have exactly the same problem with exactly the same ethernet driver

Can we please get some response. By the way I hnave no other Internet Security software installed in case that answer is trotted out again.

Thanks

Offline slipperx

  • Newbie
  • *
  • Posts: 6
Re: Problem in the network transfer rate.
« Reply #16 on: June 27, 2012, 12:24:56 PM »
Hi Guys

Ok well I upgraded my driver to version 2.0.14.15 - search in google to find it.  I didn't notice much difference.  I changed the network cable which was a CAT 5 to a CAT 6 cable and the problem has gone - I can't believe it was that simple.  It seems the cable was at fault.  Before changing it I was lucky to get 10k/sec - yes kilobytes.  No I am getting 12-13 Mb/sec so a vast improvement.  I suggest checking your cables first - it is the easiest and least time consuming thing to check (assuming you have a spare cable of course ha ha)

Offline slipperx

  • Newbie
  • *
  • Posts: 6
Re: Problem in the network transfer rate.
« Reply #17 on: June 27, 2012, 12:42:42 PM »
Hi again

One more thing that makes a significant difference is to go to Device Manager and open the propoerties for the Network Adapter, click the Advanced tab and disable Large Send Offload (IPv4) and enable Large Send Offload v2 (IPv4).  You can also try changing the Flow control from RX & TX to disabled and check, if no difference re-enable (because it is the default) and also try disabling the Interrupt Moderation and testing.  Test by sending a file to another computer on the network.. That is how I got mine working.
Hope it helps
 

Offline borisrd

  • Newbie
  • *
  • Posts: 3
Re: Problem in the network transfer rate.
« Reply #18 on: June 29, 2012, 03:00:29 PM »
Hello

Tested with slipperex advice and I must say thai it's working  ;)

This is my steep by steep how I resolve the issue on my Asus N76VZ notebook

01. Uninstall Microsoft Security Essential (just for antivirus conflict)
02. Uninstall Atheros Lan driver version 2.0.12.13
03. Restart notebook
04. Install new Atheros driver version 2.0.15.16 (found on internet thanks google)
05. Restart notebook
06. Fix my lan connection from automatic to static lan IP address
07. Restart notebook
08. Install Avast Internet Security version 7.0.1426
09. Restart notebook
10. Test upload ethernet transfering rate of 6Mb small file but my upload speed is in KB nothing change  >:(
11. Change cable, change port on switch, reload all network from switch to router nothing change only KB transfer rate  :'(
12. After tha t I decide to change atheros settings: CotrolPanel - System and Security - System - Device Manager - Network adapters - Atheros Lan Card - Propertie - Advanced (tab) and change next settings
     - Large Send Offload (IPv4) and dissable
     - Large Send Offload v2 (IPv4) and enable
     - Flow control from RX & TX and disabled
     - Interrupt Moderation and dissable
13. Try to upload the same 6MB file over ethernet and bang i recive transfer rate in MB/sec now I test with more biger file about 200MB and the transfer rate is about 11MB/sec  :)
14. Restart notebook (only to check that I fix the slow transfer rate)
15. Start the same transfer and yes it's working  ::)
16. Last 2 modfication to change: CotrolPanel - System and Security - System - Device Manager - Network adapters - Atheros Lan Card - Propertie - Advanced (tab) and change next settings
      - Flow control from dissable back to RX & TX enabled
      - Interupt Moderation from dissable to enable
and the transfer rate is in MB/sec  8)
17. Last thin I upgrade Avast Internet security to new version 7.0.1451 and the transfer rate becom better aprox to 12.5MB/sec transfer rate 8)

Thanks once again

Offline donoho

  • Newbie
  • *
  • Posts: 4
Re: Problem in the network transfer rate.
« Reply #19 on: December 16, 2012, 08:37:26 PM »
Hi again

One more thing that makes a significant difference is to go to Device Manager and open the propoerties for the Network Adapter, click the Advanced tab and disable Large Send Offload (IPv4) and enable Large Send Offload v2 (IPv4).  You can also try changing the Flow control from RX & TX to disabled and check, if no difference re-enable (because it is the default) and also try disabling the Interrupt Moderation and testing.  Test by sending a file to another computer on the network.. That is how I got mine working.
Hope it helps

I registered just to confirm that the above suggestions worked for me.  Same problem w slow network transfers 30Kb/s and less.  Network adapter: Atheros AR8151 PCI-E Gigabit Ethernet Controller (NDIS 6.20)

I install avast before doing anything else so I wasn't aware there might be a connection.  That said , I made all of the changes suggested above and the transfer of a 17MB file went from taking 10+ min to INSTANTANEOUS.

Specific Changes I made:
Flow Control: Tx & Rx Enabled > Disabled
FlowControl: Enabled > Disabled
Large Send Offload (IPv4): Enabled > Disabled
Large Send Offload v2 (IPv4): Disabled > Enabled

I performed NO un/installation.  As soon as I clicked ok, my existing connections were reset and speeds Jumped.  Tested larger files with these changes and saw 21MB/s.  Going to do some R&D on the settings I changed, but thought it was worth confirming validity of these suggestions

THANK YOU slipperx!

Offline ekitep67

  • Newbie
  • *
  • Posts: 1
Re: Problem in the network transfer rate.
« Reply #20 on: January 10, 2013, 10:06:53 AM »
Hi,

I've met the same issue.
Computer: Alienware m17x R3; Network card: Atheros Ar8151; AV: Avast Endpoint Protection Suite Plus.

Solution: It was quite enough to disable the "Largesend offload" option at the network adapter/properties/setup/special.
All the other options are not necessary to change.

Offline Frixion88

  • Newbie
  • *
  • Posts: 1
Re: Problem in the network transfer rate.
« Reply #21 on: February 18, 2013, 12:53:53 AM »
Borisrd,
Thank you for your input.  I spent all day trying to figure out why my NIC wouldn't transfer over 1MB.  Though it wasn't hampering my online experience greatly, it was driving me nuts.  The suggestion to disable "LargeSendOffload" did the trick.

Offline banditcoot

  • Newbie
  • *
  • Posts: 1
Re: Problem in the network transfer rate.
« Reply #22 on: June 06, 2013, 08:49:40 PM »
Wow! Thanks so much. Just building up a new system and I ran into the same problem with an Atheros AR8161/8165 ethernet controller giving perfect download speeds but horrendously slow uploads. The simple step of switching off "Large Send Offload (IPv4)" to "Disabled" fixed it. I went from like 0.25-0.6 (!) Mbps to 3.5-4 where it should be.

I don't even have Avast or anything of the sort even installed at the moment so it is something other than an Avast conflict issue alone.