Author Topic: I'm very angry with avast  (Read 30656 times)

0 Members and 1 Guest are viewing this topic.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
I'm very angry with avast
« on: November 20, 2011, 01:51:01 AM »
This is an OLD problem that got no attention from avast team.
When avast let Windows System Restore to work, it fails itself miserably.

1. It does not start the service by the interface.
2. It does not allow to correct (button) the problem.
3. It does not allow 1 and 2 at Safe Mode.
4. It does not allow to repair using Control Panel.
5. It does not allow to update or change using Control Panel.
6. It does not allow to run the full setup file.

IT'S A SHAME  :( >:( >:(
The best things in life are free.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: I'm very angry with avast
« Reply #1 on: November 20, 2011, 02:19:17 AM »
If anybody from avast team is reading this and need a log...

Code: [Select]
19.11.2011 16:25:32 general: Started: 19.11.2011, 16:25:32
19.11.2011 16:25:32 general: Running setup_ais-548 (1352)
19.11.2011 16:25:32 system: Operating system: Windows 7 ver 6.1, build 7601, sp 1.0 [Service Pack 1]
19.11.2011 16:25:32 system: Memory: 52% load. Phys:1561912/2097151K free, Page:4194303/4194303K free, Virt:2043752/2097024K free
19.11.2011 16:25:32 system: Computer WinName: Tech
19.11.2011 16:25:32 system: Windows Net User: Tech
19.11.2011 16:25:32 general: Cmdline: /uninstwiz 
19.11.2011 16:25:32 general: Old version: 548 (1352)
19.11.2011 16:25:32 registry: Deleted registry: Software\AVAST Software\Avast\UpdateReady
19.11.2011 16:25:32 system: Using temp: C:\Users\Tech\AppData\Local\Temp\_asw_aisI.tm~a07148 (57330M free)
19.11.2011 16:25:32 general: SGW32AIS::CheckIfInstalled set m_bAlreadyInstalled to 1
19.11.2011 16:25:32 general: DldSrc set to inet
19.11.2011 16:25:32 internet: SYNCER: Agent=Syncer/5.00 (ais-1352;p)
19.11.2011 16:25:32 system: Computer DnsName: IICSNOTE355.iics.local
19.11.2011 16:25:32 system: Computer Ip Addr: 192.168.0.58
19.11.2011 16:25:32 system: Installed in: C:\Util\Security\avast (57330M free)
19.11.2011 16:25:32 internet: SYNCER: Type: use IE settings
19.11.2011 16:25:32 internet: SYNCER: Auth: another authentication, use WinInet
19.11.2011 16:25:32 package: Part prg_ais-548 is installed
19.11.2011 16:25:32 package: IsInstalledPartVpuOkay: C:\Util\Security\avast\Setup\part-vps_win32-11111801.vpx does not exist
19.11.2011 16:25:32 package: Part vps_win32-11111900 was guessed as installed
19.11.2011 16:25:32 package: Part setup_ais-548 is installed
19.11.2011 16:25:32 package: Part jrog-a7 is installed
19.11.2011 16:25:32 package: IsInstalledPartVpuOkay: C:\Util\Security\avast\Setup\part-jrog2-376.vpx does not exist
19.11.2011 16:25:32 package: Part jrog2-377 was guessed as installed
19.11.2011 16:25:32 general: LoadState: Edition=3
19.11.2011 16:25:32 general: Old version: 548 (1352)
19.11.2011 16:25:37 file: SetExistingFilesBitmap: 947->537->532
19.11.2011 16:25:37 general: GUID: 6ec1dc1e-59c2-46df-96bc-72daab0f41f3
19.11.2011 16:25:37 general: Server definition(s) loaded for 'main': 299 (maintenance:0)
19.11.2011 16:25:37 general: SelectCurrent: selected server 'Download316 AVAST5 Server' from 'main'
19.11.2011 16:25:37 internet: SYNCER: Type: use IE settings
19.11.2011 16:25:37 internet: SYNCER: Auth: another authentication, use WinInet
19.11.2011 16:25:40 general: Operation set to INST_OP_REPAIR
19.11.2011 16:25:40 general: Entered SetupProcessAIS::Do( INST_OP_REPAIR )
19.11.2011 16:25:40 general: Entered SetupProcessWin32Avast::Do( INST_OP_REPAIR )
19.11.2011 16:25:40 general: Entered SetupProcessWin32::Do( INST_OP_REPAIR )
19.11.2011 16:25:40 general: Entered SetupProcess::Do( INST_OP_REPAIR )
19.11.2011 16:25:40 general: Entered SetupProcessAIS::Do( INST_OP_UPDATE_INSTALL_PACKAGES )
19.11.2011 16:25:40 general: Entered SetupProcessWin32Avast::Do( INST_OP_UPDATE_INSTALL_PACKAGES )
19.11.2011 16:25:40 general: Entering:UpdateInstallPackages
19.11.2011 16:25:40 general: progress thread start
19.11.2011 16:25:41 package: LoadProductVpu: C:\Util\Security\avast\Setup\prod-ais.vpx
19.11.2011 16:25:41 package: LoadPartInfo: jrog = jrog-a7 returned 00000000
19.11.2011 16:25:41 package: LoadPartInfo: jrog2 = jrog2-377 returned 00000000
19.11.2011 16:25:41 package: LoadPartInfo: program = prg_ais-548 returned 00000000
19.11.2011 16:25:41 package: LoadPartInfo: setup = setup_ais-548 returned 00000000
19.11.2011 16:25:41 package: LoadPartInfo: vps = vps_win32-11111900 returned 00000000
19.11.2011 16:25:41 package: LoadProductVpu: C:\Util\Security\avast\Setup\prod-ais.vpx ended with 00000000
19.11.2011 16:25:41 package: FilterOutExistingFiles: 537 & 532 = 5
19.11.2011 16:25:41 package: IsFullOkay: vps_32-648.vpx - not okay (doesn't exist)
19.11.2011 16:25:41 package: SetDownloadBits: vps_32 setting 1 diffs to process
19.11.2011 16:25:41 package: IsFullOkay: vps_win32-65c.vpx - not okay (doesn't exist)
19.11.2011 16:25:41 package: SetDownloadBits: vps_win32 setting 1 diffs to process
19.11.2011 16:25:41 package: ArePartsInstallable: 0
19.11.2011 16:25:41 package: Error processing packages. 0x20000011
The best things in life are free.

Offline jadinolf

  • Avast Evangelist
  • Advanced Poster
  • ***
  • Posts: 1090
Re: I'm very angry with avast
« Reply #2 on: November 20, 2011, 02:26:36 AM »
Sorry Tech. ;)
printed on 100% recycled bytes

Offline Rednose

  • Pirate Party Member
  • Avast Überevangelist
  • Massive Poster
  • *****
  • Posts: 3739
  • Bits of Freedom : https://www.bof.nl
    • Nederlandstalig Avast! forum
Re: I'm very angry with avast
« Reply #3 on: November 20, 2011, 02:47:14 AM »
Tech,

Why are you using Windows System Restore ? It is a crap meganism, and is normally causing more problems than it solves. Better use an image backup - combined with a file backup policy. Never never never use WSR !

Greetz, Red.
« Last Edit: November 20, 2011, 02:50:00 AM by Rednose »
OS: Win 10 / iOS 17 / Debian 12 / Tails 5
Real Time: Avast Premium Security
On Demand: Malwarebytes
VPN: NordVPN ( NordLynx ) with Threat Protection ( Lite )

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: I'm very angry with avast
« Reply #4 on: November 20, 2011, 02:57:20 AM »
Red, please, don't say that. We know the limitations of Windows System Restore.
But it is a Windows feature since XP...
avast can't ignore it. Comodo Time Machine that could replace it, stop being developed.

avast should take a look. I could search the forum for other recent user having the same problem.
Bashing or saying anything about Windows System Restore won't help imho.
The best things in life are free.

Tgell

  • Guest
Re: I'm very angry with avast
« Reply #5 on: November 20, 2011, 03:19:32 AM »
Hello Tech,
I tried to do a system restore with avast installed and System Restore failed. Is this because of avast's self-protection module and does this have to be disabled before using System Restore? I never had a failure with System Restore before.

Offline RejZoR

  • Polymorphic Sheep
  • Serious Graphoman
  • *****
  • Posts: 9408
  • We are supersheep, resistance is futile!
    • RejZoR's Flock of Sheep
Re: I'm very angry with avast
« Reply #6 on: November 20, 2011, 10:26:56 AM »
System Restore is not crap, it's a very useful feature and i often use it. So Tech's rant is well placed. I haven't had such problem yet but still it's worth re-checking it.

Tech, have you restored the system to a point before avast! installation? Such problems usually happen in such scenarios. Program stills tarts itself but since many things were removed by System Restore, it just fails.
Visit my webpage Angry Sheep Blog

Frank Bullitt

  • Guest
Re: I'm very angry with avast
« Reply #7 on: November 20, 2011, 10:54:48 AM »
Hello guys,

I believe that WSR is a handy functionality from MS.  My WSR stopped working for some unknown reason in both my PCs quite sometime now.  But when it was up and running I used it quite a lot.

Anyway, I also believe that this is not the point of discussion.  Irrespectively of whether someone uses the WSR or not, I have to agree with Tech, that the Avast Team should really have a look into this.

All the best,

Frank.

 

Offline NON

  • Japanese User
  • Avast Überevangelist
  • Ultra Poster
  • *****
  • Posts: 5513
  • Whatever will be, will be.
Re: I'm very angry with avast
« Reply #8 on: November 20, 2011, 11:32:43 AM »
I often find System Restore being stopped and all restore points are gone... is this also avast related? :-\
« Last Edit: November 20, 2011, 11:35:56 AM by NON »
Desktop: Win10 Pro 22H2 64bit / Core i5-7400 3.0GHz / 32GB RAM / Avast 23 Premium Beta(Icarus) / Comodo Firewall
Notebook: Win10 Pro 22H2 64bit / Core i5-3340M 2.7GHz / 12GB RAM / Avast 23 Free / Windows Firewall Control
Server: Win11 Pro 23H2 64bit / Core i3-4010U 1.7GHz / 12GB RAM / Avast One 23 Essential

Avast の設定について解説しています。よろしければご覧ください。

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11658
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: I'm very angry with avast
« Reply #9 on: November 20, 2011, 12:23:33 PM »
This issue was supposed to be fixed.
Which version of avast are you using, Tech?

The problem here is that System Restore is deleting avast's own files so it's quite difficult to cope with that.

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

Offline jacal

  • Jr. Member
  • **
  • Posts: 31
Re: I'm very angry with avast
« Reply #10 on: November 20, 2011, 01:23:14 PM »
I also used to have problems with System Restore; more often than not I was unable to restore restore points that were made with avast's self-defense module enabled. I think with that module disabled I have never had problems, and I know that System Restore was always stable and reliable on my PC when avast was, well, not installed.

My last (and problematic) version of avast free was 6.0.1289 on windows 7/64. Now I'm running it on a virtual machine, waiting for this to be fixed.

DonZ63

  • Guest
Re: I'm very angry with avast
« Reply #11 on: November 20, 2011, 03:21:22 PM »
WIN 7 x64 SP1, Avast! 6.0.1289

I had to do a system restore a while back and I did get it to work. It was with a few heart flutters however.

First, I had forgotten about disabling the resident protection feature. The first boot after system restore totally hung my system - black screen. Manually powered down the PC. Next boot got me to the desktop and system froze again. Manually powered down again and third boot did work. Received message from WIN 7 that the system had been sucessfully restored.

BTW - Avast is not the only one with system restore issues. Norton's products have problems also. Probably due to it's resident protection features which are extremely aggresive.

twl845

  • Guest
Re: I'm very angry with avast
« Reply #12 on: November 20, 2011, 03:39:33 PM »
As an alternative that works, I installed Rollback Rx on my computer and shut SR off. Restoring to an earlier snapshot takes 10 seconds. Wait for a sale to purchase at BitsDuJour. ;)

Offline RejZoR

  • Polymorphic Sheep
  • Serious Graphoman
  • *****
  • Posts: 9408
  • We are supersheep, resistance is futile!
    • RejZoR's Flock of Sheep
Re: I'm very angry with avast
« Reply #13 on: November 20, 2011, 03:48:59 PM »
Haha, Rollback Rx used avast! 4.8 detection message in its video...
Visit my webpage Angry Sheep Blog

Nesivos

  • Guest
Re: I'm very angry with avast
« Reply #14 on: November 20, 2011, 04:48:08 PM »
This issue was supposed to be fixed.
Which version of avast are you using, Tech?

The problem here is that System Restore is deleting avast's own files so it's quite difficult to cope with that.

Thanks
Vlk

Since avast! is working with MSFT in developing avast! 7 then this problem should be fixed in avast! 7 correct ???