Author Topic: Port 587  (Read 4244 times)

0 Members and 1 Guest are viewing this topic.

Offline mastersoft

  • Newbie
  • *
  • Posts: 2
Port 587
« on: February 19, 2011, 05:37:44 AM »
Hi,

I have Avast Free and I love it. Many thanks.

I use extensively Outlook Expres 6. I have a lot of emails and news that control in Outlook. Today I setup a new email with SMTP Port 587, without SSL. It receives emails but doesn´t send emails. If I disable Avast or Uncheck "Scan outbound messages" in Mail Shield option, it works fine. if I send an email with Avast Mais Shield "Scan outbound messages" checked I get the next error:

"Error desconocido. Cuenta: 'mail.mastersoft3000.info', Servidor: 'mail.mastersoft3000.info', Protocolo: SMTP, Respuesta del servidor: '421 Cannot connect to SMTP server 184.168.85.176 (184.168.85.176:465), connect error 10061', Puerto: 587, Seguridad (SSL): No, Error de servidor: 421, Número de error: 0x800CCC67"

I repeat: if I uncheck "Scan outbound messages" it works fine.

Could you help me ?

Thanks in advance,

Carlos Gallego

Offline scythe944

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 2913
    • My Tech Blog
Re: Port 587
« Reply #1 on: February 19, 2011, 05:57:52 AM »
Your error message is in spanish, but I have a feeling I know what's going on.

It seems that you're using a non-standard (Sorry, that's not correct, 587 is "standard" but not the most popular) port.

It seems that your client believes that you're using SSL by the message I think (again, it's not in english).

Can you verify that SSL isn't checked in your email client?

From the looks of it, it's trying to use SSL even though it's not supposed to be.
For generic computer (not avast) problems, you can also visit my forum for help: http://www.jacobytech.net/forum

Offline scythe944

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 2913
    • My Tech Blog
Re: Port 587
« Reply #2 on: February 19, 2011, 06:01:24 AM »
Also, post: http://forum.avast.com/index.php?topic=18176.from1135132098;topicseen seems to be related to your issue.
For generic computer (not avast) problems, you can also visit my forum for help: http://www.jacobytech.net/forum

Offline mastersoft

  • Newbie
  • *
  • Posts: 2
Re: Port 587
« Reply #3 on: February 19, 2011, 07:15:13 PM »
Thanks for your answer.

This is the error:

"Unknown error. Account: 'mail.mastersoft3000.info', Server: 'mail.mastersoft3000.info', Protocol: SMTP, Server response: '421 Cannot connect to SMTP server 184.168.85.176 (184.168.85.176:465), connect error 10061', Port: 587, Secure (SSL): No, Server Error: 421, Error number: 0x800CCC67"

As you can see, Secure (SSL) is NO (becouse it is not checked in my email client).

The strange thing is that it shows "(184.168.85.176:465)" pointing to port 465, but next says "Port: 587"

The issue is that if I Turn Off Avast or with Avast Turn On but UNCHECKED "Scan outbound messages" option in Mail Shield, I can send emails without problem, so I think I must configure something in Avast, but I don´t know wath to do.

Any idea ?

Thansk for your help. 

Offline scythe944

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 2913
    • My Tech Blog
Re: Port 587
« Reply #4 on: February 20, 2011, 03:47:37 AM »
What version of Avast do you have?

I have the newest beta version installed right now, but there really aren't any settings to speak of for non-ssl accounts.

That port number is strange, since it says 465 and 587.  That doesn't make much sense.

Maybe a repair of Avast would help in this case?
For generic computer (not avast) problems, you can also visit my forum for help: http://www.jacobytech.net/forum

Offline urielmx

  • Newbie
  • *
  • Posts: 1
SOLUTION
« Reply #5 on: November 22, 2011, 07:02:17 AM »
I almost format my computer because no one seemd to have the answer to this (same) error. But thanks God I found this thread so I could have an idea about what was happenig.

Solution is simple (sorry if is not exactly named like I say. I have spanish version):
Go to "Temporal Shield" > "Email shield" > "Advanced Options" > "SSL acoounts"

Identify those IP's and domain names on SMTP that are related to your error and delete them. Then click on accept, and that's all.

Why could this happen? Preatty sure that was about a change on your IPS, or in my case: a visit to a client that use a special configuration to have internet connection.

Hope this avoid an unnecesary formating like to me.