Author Topic: Problem with Chinese fonts of another user in Wilders  (Read 3693 times)

0 Members and 1 Guest are viewing this topic.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67235
Problem with Chinese fonts of another user in Wilders
« on: November 24, 2011, 12:44:16 PM »
Quote from: Dr33
Hello everybody:

I have a very interesting problem with avast internet security 6 when i uninstall it in my laptop (Win7 SP1 Home Premium x64 English) stops displaying correctly the Traditional Chinese Fonts, and when i reinstall Avast IS the chinese fonts display correctly in chrome tabs and file names. this problems appear again if i uninstall avast is 6.

:blink:
Source: http://www.wilderssecurity.com/showthread.php?t=312750

Igor, can you help?
The best things in life are free.

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11818
    • AVAST Software
Re: Problem with Chinese fonts of another user in Wilders
« Reply #1 on: November 24, 2011, 02:10:10 PM »
I must say it doesn't make much sense to me...
First, I'd like to see a screenshot of the problem in effect (especially on the "file names"), second I'd like to know what is set in Control Panel / Region and Language / Administrative / Language for non-Unicode programs. But I somehow expect it not to reveal anything helpful.


Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11818
    • AVAST Software
Re: Problem with Chinese fonts of another user in Wilders
« Reply #3 on: November 24, 2011, 05:14:46 PM »
If you navigate to the Fonts folder (either via Control Panel or by going into C:\Windows\Fonts), go to "Font settings" and uncheck the option "Hide fonts based on language settings" (if checked) - does it help?

Dr33

  • Guest
Re: Problem with Chinese fonts of another user in Wilders
« Reply #4 on: November 24, 2011, 06:38:10 PM »
I unchecked the option and after a reboot it seems the problem was solved , now the question is why Avast messed the fonts  ???

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11818
    • AVAST Software
Re: Problem with Chinese fonts of another user in Wilders
« Reply #5 on: November 24, 2011, 10:32:43 PM »
I don't think it does (also because this is the first time I hear something like that, and there are quite a few hits on that problem on google without any apparent connection to avast), but I admit I have no idea what that particular checkbox does, I'd have to dig a bit deeper (if time permits).
But it's strange, even if avast! was actually "fixing" the problem that was already there, it wouldn't be completely right...
« Last Edit: November 24, 2011, 10:38:37 PM by igor »

Dr33

  • Guest
Re: Problem with Chinese fonts of another user in Wilders
« Reply #6 on: November 25, 2011, 04:28:37 AM »
after i shut it down i turn it on the problem is back i need to reinstal avast and fonts are working again  ???

Dr33

  • Guest

Dr33

  • Guest
Re: Problem with Chinese fonts of another user in Wilders
« Reply #8 on: November 25, 2011, 04:39:02 PM »
after uninstalling and having the same issue i think i found that avast some how seems to corrupt fntcache.dat i deleted after uninstalling avast and after a reboot windows 7 it regenerates the file and the Chinese font error seems to be gone, after few reboots i see still correctly the fonts
 ;D or maybe i have the new DUQU rootkit and is messing with my fonts  ;D