Author Topic: Script shield doesn't work with Firefox  (Read 5561 times)

0 Members and 1 Guest are viewing this topic.

LorenzoC

  • Guest
Script shield doesn't work with Firefox
« on: December 03, 2011, 01:51:53 PM »
Mozilla/5.0 (Windows NT 5.1; rv:8.0) Gecko/20100101 Firefox/8.0
Avast v.6.0.1397 (updated from previous version)

Script Shield logs something only while using IE.
With Firefox no script is scanned/logged.
« Last Edit: December 03, 2011, 01:54:47 PM by LorenzoC »

Offline mikaelrask

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 1556
Re: Script shield doesn't work with Firefox
« Reply #1 on: December 04, 2011, 03:42:44 PM »
hey latest version of firefox is 8.0.1.

to topic try a clean installation of avast i suggest and see if that helps.

download the lastest version of avast from avast.com

uninstall avast with the uninstall tool

reboot your system

clean any leftover from avast with cclener

install the latest version of avast you downloaded.

registry the program.

http://www.avast.com/en-se/free-antivirus-download -to the program file

http://www.avast.com/en-se/uninstall-utility -to the uninstall tool

http://filehippo.com/download_ccleaner/ -to cclener

good luck and let us know how it goes or if you need further support.

« Last Edit: December 04, 2011, 03:49:33 PM by mikaelrask »
Windows 8.1 amd a10-5700 64 bit
12 GB ram 1 tb hard drive. Avast 18, MBAM

LorenzoC

  • Guest
Re: Script shield doesn't work with Firefox
« Reply #2 on: December 04, 2011, 05:38:01 PM »
Nope, Firefox 8.0.1 is meant to fix bugs on MAC then since it doesn't contain any improvement it wasn't distributed as update on Windows.

Anyway, I followed these steps:
1. rebooted Windows in safe mode
2. used the uninstaller tool to remove Avast
3. rebooted Windows and cleaned the registry
4. re-installed the latest version of Avast, re-registered it offline with the proper key

I confirm Script Shield still logs/scans with IE while it looks dead as a door knob with Firefox. The Real-Time Shields / Script Shield panel doesn't show anything being logged/scanned. I don't see any error, just while being on the same page with IE and Firefox, with IE stuff is logged/scanned while with Firefox nothing happens.

My OS is Windows XP Home Edition, version 2002, service pack 3, italian.
Information about Firefox and Avast same as above.
« Last Edit: December 04, 2011, 05:46:41 PM by LorenzoC »

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 88445
  • No support PMs thanks
Re: Script shield doesn't work with Firefox
« Reply #3 on: December 04, 2011, 06:04:28 PM »
Currently with this 6.0.1367, see image. This wasn't the case in earlier versions of avast and firefox, I even put script shield exclusions on forum.avast.com and static.avast.com (as I trust them and to hopefully speed page loading).

Like you if use IE (and I generally never do) I get script shield activity. I went to shis link as I know it generates scripts, http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager06.html and I got 18 scripts scanned in IE8 (see image2), visiting the same site in firefox 8.0 the activity stays at 18, no scanning within firefox.

For me that isn't an issue as I have the NoScript add-on installed and obviously the web shield and network shield. I did allow scripts on the link to ensure NoScript wasn't blocking them so there were some running for the script shield to scan, assuming it worked.

However, it would be nice for everyone else if this were resolved.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 23.10.6086 (build 23.10.8563.800) UI 1.0.784/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

LorenzoC

  • Guest
Re: Script shield doesn't work with Firefox
« Reply #4 on: December 04, 2011, 06:19:17 PM »
Thanks for confirming. Exactly the same here.

Now, yes it should be resolved.
I do wonder how it can happen when I read in the changelog that ALL Firefox versions are supported. Did anybody test Script Shield before releasing?

Edit: I don't use NoScript, so that can't be the reason.
« Last Edit: December 04, 2011, 09:31:35 PM by LorenzoC »

DavidCo

  • Guest
Re: Script shield doesn't work with Firefox
« Reply #5 on: December 04, 2011, 06:49:10 PM »
Is it just an XP issue?
FireFox 8.0.1 Script Shield scans fine here (Vista 32Bit)

Offline Gopher John

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2098
Re: Script shield doesn't work with Firefox
« Reply #6 on: December 04, 2011, 07:07:35 PM »
Script Shield is working here with Firefox 8.0.  I can visit any site that I allow JavaScript, and see the activity in Avast Real Time Shields | Script Shield presentation.
AMD A6-5350M APU with Radeon HD Graphics, 8.0GB RAM, Win7 Pro SP1 64bit, IE11
i7-3610QM 2.3GHZ, 8.0GB Ram,  Nvidia GeForce GT 630M 2GB, Win7 Pro SP1 64bit, IE 11
Common to both: Avast Premium Security 19.7.2388, WinPatrol Plus, SpywareBlaster 5.5, Opera 12.18, Firefox 68.0.2, MBam Free, CCleaner

LorenzoC

  • Guest
Re: Script shield doesn't work with Firefox
« Reply #7 on: December 08, 2011, 06:49:49 PM »
Bump. Could somebody from Avast give me a feedback, please?

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 88445
  • No support PMs thanks
Re: Script shield doesn't work with Firefox
« Reply #8 on: December 08, 2011, 08:00:37 PM »
I have tried to get someone to look into this.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 23.10.6086 (build 23.10.8563.800) UI 1.0.784/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security