Author Topic: no avast icon in system tray - windows xp  (Read 21680 times)

0 Members and 1 Guest are viewing this topic.

Offline zam

  • Newbie
  • *
  • Posts: 16
no avast icon in system tray - windows xp
« on: December 04, 2011, 01:42:07 PM »
We're having a problem with the Avast icon not appearing in the system tray. I saw some posts
saying to look for ashDisp.exe. I looked for this file in "Program Files/Avast Software/Avast" and couldn't find it. I also did a search in the Avast folder and it wasn't found.

Help appreciated.

Offline Pondus

  • Probably Bot
  • ****
  • Posts: 36729
Re: no avast icon in system tray - windows xp
« Reply #1 on: December 04, 2011, 01:44:26 PM »
Have you tried  avast repair and reboot ?

For a repair of avast. Windows, Add Remove programs, select 'avast! Anti-Virus,' click the Change/Remove button from the pop-up window, scroll down to Repair, click next and follow.


Offline ady4um

  • Massive Poster
  • ****
  • Posts: 2667
Re: no avast icon in system tray - windows xp
« Reply #2 on: December 04, 2011, 04:35:21 PM »
"ashdisp.exe" is for an older version of Avast, not for the current 6.x.

Usually the repair of avast and reboot would solve this.

If you use CCleaner, there is an option to clean the tray icons cache (but if you don't use it already, I wouldn't start now just for this). Right click the "Tray notifications cache" (it is in "cleaner -> advanced") and select "clean" from the context menu (not from the main button). Then reboot.

For whichever method you use, please report back.
ADD/REMOVE PROGS -> avast -> CHANGE/REMOVE -> REPAIR & REBOOT
Avast! 7 FAQ | FAQ & KB | Docs | Removal Utils | Configure Mail Shield | report FP | License Registration | UNSECURED?

Offline zam

  • Newbie
  • *
  • Posts: 16
Re: no avast icon in system tray - windows xp
« Reply #3 on: December 07, 2011, 01:17:02 PM »
I tried the repair (control panel/add-remove programs) and it still has the problem. I just noticed
the recommendation to reboot. Although I did change from admin to limited user, I didn't try rebooting.
Will try that tomorrow. (It's a friend's machine.)
« Last Edit: December 07, 2011, 01:20:49 PM by zam »

Offline iYogisolutions1

  • Sr. Member
  • ****
  • Posts: 285
  • Great Tech Support. Good Karma
    • iYogi Tech Support.
Re: no avast icon in system tray - windows xp
« Reply #4 on: December 07, 2011, 02:13:23 PM »
Hi,

   If you are using Windows XP in your computer, the steps provided above might fix the issue. If incase it didn't fix, download and run Dial-A-Fix. This tool will re-register all the .dll files related with Internet Explore, Windows Updates and other Windows Applets. You can download the tool from http://majorgeeks.com/downloadget.php?id=4899&file=15&evp=7d21ae5c611baf9a52b1750805534dda.

Make sure that you repair Avast! after running Dial-A-Fix.
Hope your issue will be fixed by this.

« Last Edit: December 07, 2011, 04:09:02 PM by iYogisolutions1 »
Have a wonderful day. Good Karma! :)

Merry Christmas and a Happy New Year!!

Offline ady4um

  • Massive Poster
  • ****
  • Posts: 2667
Re: no avast icon in system tray - windows xp
« Reply #5 on: December 07, 2011, 05:16:09 PM »
Running the repair from an admin user account might help (as a common user account has less permissions).

Since you haven't reported about CCleaner method I posted, here is the equivalent manual method for that (but please, try first the repair of avast and reboot first, as that may be enough).

Quote
Regedit

Vista/seven:
HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\TrayNotify


XP:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\TrayNotify


Delete the IconStreams and PastIconsStream values


log off immediately.
ADD/REMOVE PROGS -> avast -> CHANGE/REMOVE -> REPAIR & REBOOT
Avast! 7 FAQ | FAQ & KB | Docs | Removal Utils | Configure Mail Shield | report FP | License Registration | UNSECURED?

Offline zam

  • Newbie
  • *
  • Posts: 16
Re: no avast icon in system tray - windows xp
« Reply #6 on: December 08, 2011, 12:32:28 PM »
As I mentioned, I tried the repair from the admin account but didn't reboot. Today, on reboot, the icon appeared in the system tray of the admin account but it still wasn't in the system tray of the user account (which is the account we usually use.)


Offline ady4um

  • Massive Poster
  • ****
  • Posts: 2667
Re: no avast icon in system tray - windows xp
« Reply #7 on: December 08, 2011, 01:22:00 PM »
Yes, you already said you didn't reboot then. That's why I insisted again in that point, as it is crucial to see the results.

Please confirm the tray icon is not simply hidden, behind the "<" arrow (or set as permanently hidden in the task bar properties).

In addition, have you tried cleaning the tray icons cache (for that user) as suggested?
ADD/REMOVE PROGS -> avast -> CHANGE/REMOVE -> REPAIR & REBOOT
Avast! 7 FAQ | FAQ & KB | Docs | Removal Utils | Configure Mail Shield | report FP | License Registration | UNSECURED?

Offline zam

  • Newbie
  • *
  • Posts: 16
Re: no avast icon in system tray - windows xp
« Reply #8 on: December 10, 2011, 08:42:33 AM »
I tried using ccleaner and rebooting. Problem still happening. There is no "<"
because it's not set for hiding inactive icons. There is an option for
"hide inactive icons" but nothing for the individual icons.

Thanks.


Offline ady4um

  • Massive Poster
  • ****
  • Posts: 2667
Re: no avast icon in system tray - windows xp
« Reply #9 on: December 10, 2011, 10:13:56 AM »
For CCleaner, you need to select the specific item "tray notification cache" so to clean it.

You can try also the registry key I posted, according to your OS.

About the task bar properties, if you select the checkbox for "hide inactive icons", you can "customize" it and there you can select each program and each icon with its status.
ADD/REMOVE PROGS -> avast -> CHANGE/REMOVE -> REPAIR & REBOOT
Avast! 7 FAQ | FAQ & KB | Docs | Removal Utils | Configure Mail Shield | report FP | License Registration | UNSECURED?

Offline zam

  • Newbie
  • *
  • Posts: 16
Re: no avast icon in system tray - windows xp
« Reply #10 on: December 11, 2011, 08:34:06 AM »
For CCleaner, you need to select the specific item "tray notification cache" so to clean it.
Yes, that's what I did.

Quote
About the task bar properties, if you select the checkbox for "hide inactive icons", you can "customize" it and there you can select each program and each icon with its status.
I just tried that and the avast icon isn't listed.

Offline ady4um

  • Massive Poster
  • ****
  • Posts: 2667
Re: no avast icon in system tray - windows xp
« Reply #11 on: December 11, 2011, 08:43:13 AM »
Please don't look for the icon, but for the programs listed, whether in the current active items or the older ones.

Whichever the icon used in the *avast* program line listed there in the tray notifications icons, set it to "show" (as in permanently being displayed). Then save and reboot.
ADD/REMOVE PROGS -> avast -> CHANGE/REMOVE -> REPAIR & REBOOT
Avast! 7 FAQ | FAQ & KB | Docs | Removal Utils | Configure Mail Shield | report FP | License Registration | UNSECURED?

Offline zam

  • Newbie
  • *
  • Posts: 16
Re: no avast icon in system tray - windows xp
« Reply #12 on: December 11, 2011, 11:27:51 AM »
I will look again, just to be sure, but I didn't see avast listed at all.

Offline Dch48

  • Massive Poster
  • ****
  • Posts: 3151
Re: no avast icon in system tray - windows xp
« Reply #13 on: December 12, 2011, 12:16:32 AM »
XP is notorious for not showing system tray icons properly. If too many things that display icons are trying to load too fast or too simultaneously, many times, some will not show at all. When I was using Comodo on XP, it's icon would never show until I clicked on the desktop icon to open the GUI. Then the system tray one would show up. One thing you could try is to set Avast to load only after all other system services. This is found in the troubleshooting settings. Also, make sure the box to show the icon is checked in the basic settings. The real solution I found for the same problem using Comodo was to install a little utility called StartupDelayer. You can set how programs load at boot. I delayed Comodo by 10 seconds and that fixed the problem. 
« Last Edit: December 12, 2011, 12:19:44 AM by Dch48 »
Avatar FX6327X desktop, FX-6300 CPU, RX 470 GPU, 8GB RAM, Windows 10 Home 64 bit
HP dv6-6140us laptop, A8-3500M APU, 8GB RAM, Windows 7 Home Premium 64 bit
RCA W101 v2 10" tablet, Intel Atom Bay Trail Z3735F processor, 2GB RAM, Windows 10 Home 32 bit

Offline zam

  • Newbie
  • *
  • Posts: 16
Re: no avast icon in system tray - windows xp
« Reply #14 on: December 12, 2011, 08:04:31 AM »
XP is notorious for not showing system tray icons properly. If too many things
that display icons are trying to load too fast or too simultaneously, many times,
some will not show at all.
However, the icon shows up when using the admin account. (Both accounts have the
same programs loading.)

I tried doing a control panel/add-remove programs/avast repair from the limited
account and got the message: "A setface error has occurred: 2
Try to reinstall or contact support".