Author Topic: no avast icon in system tray - windows xp  (Read 21659 times)

0 Members and 1 Guest are viewing this topic.

Offline YoKenny

  • Serious Graphoman
  • **
  • Posts: 8788
Re: no avast icon in system tray - windows xp
« Reply #30 on: December 17, 2011, 03:32:01 PM »
Its best not to change screen resolution from 96 dpi as that will mess up the icons.
E5200 2.5GHZ, 4GB RAM, 320GB HD, Windows 7 Home Premium 64bit, avast! V9.0 Free, IE10
P4 2.8GHZ, 1.5GB RAM, 40GB HD, XP Pro SP3 32bit, avast! V9.0 Free, Google Chrome
with hpHosts, MVPS HOSTS files, SpeedFan, WinPatrol PLUS

Offline Dch48

  • Massive Poster
  • ****
  • Posts: 3152
Re: no avast icon in system tray - windows xp
« Reply #31 on: December 18, 2011, 02:53:08 AM »
I would tend to agree, especially in XP. I never have changed that setting in any version of Windows.
Avatar FX6327X desktop, FX-6300 CPU, RX 470 GPU, 8GB RAM, Windows 10 Home 64 bit
HP dv6-6140us laptop, A8-3500M APU, 8GB RAM, Windows 7 Home Premium 64 bit
RCA W101 v2 10" tablet, Intel Atom Bay Trail Z3735F processor, 2GB RAM, Windows 10 Home 32 bit

Offline zam

  • Newbie
  • *
  • Posts: 16
Re: no avast icon in system tray - windows xp
« Reply #32 on: December 18, 2011, 09:06:26 AM »
Let me understand, exactly which settings do you have:

A_ For Admin account? Is the tray icon being displayed correctly?

Yes.
Quote

B_ For normal user account?
No.
Quote
What you need to find out is which of the settings is the one triggering the problem,
exactly.

Is it the fonts DPI? Is it the screen resolution? Is it the number of colors?

Once you find out which setting is, then which values of that settings are the ones triggering the problem?

Is the exact same setting displaying the tray icon in one account, but not in the other one? Meaning, if you set, for example, 32bit colors for BOTH accounts, then one shows the icon and the other doesn't?

Please report back. In the meantime, I'll make some test by myself (so to compare), and then we can report this to the developers.

So - sorry to have to say - I tried setting the colors separately - still no icon in
user account. I tried setting dpi separately - no icon. (Xp doesn't allow separate
settings for dpi.) I then tried setting both dpi and colors (both accounts at same
time) and this time there was still no icon in user account. Will try the removal
utility.

Offline ady4um

  • Massive Poster
  • ****
  • Posts: 2667
Re: no avast icon in system tray - windows xp
« Reply #33 on: December 18, 2011, 10:00:25 AM »
Maybe I am not clear enough?

Zam, you need to post the EXACT values that worked for each account. You already posted that changing them was successful, but then when you set them back to what they were before, the icon disappeared again.

So, please complete the following tables.

Admin account, settings working correctly (tray icon shown):
screen refresh frequency:
screen resolution:
colors:
fonts DPI:

Admin account, settings not working correctly (tray icon not shown):
screen refresh frequency:
screen resolution:
colors:
fonts DPI:

simple user account, settings working correctly (tray icon shown):
screen refresh frequency:
screen resolution:
colors:
fonts DPI:

simple user account, settings not working correctly (tray icon not shown):
screen refresh frequency:
screen resolution:
colors:
fonts DPI:


In addition, please indeed run the removal utility for previous security tools, before testing the combination of settings that work or doesn't work.
ADD/REMOVE PROGS -> avast -> CHANGE/REMOVE -> REPAIR & REBOOT
Avast! 7 FAQ | FAQ & KB | Docs | Removal Utils | Configure Mail Shield | report FP | License Registration | UNSECURED?

Offline pabloinla

  • Newbie
  • *
  • Posts: 7
Re: no avast icon in system tray - windows xp
« Reply #34 on: December 18, 2011, 09:57:06 PM »
I solved the issue once and for always as follows: goal is to create a registry entry which will launch the tray icon for you. Start > Run > regedit. In the regedit user interface drill down as follows: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

You should see folders on the left and some icons and text on the right. In the upper left of the Registry Editor click on Edit > New > String Value. This will create a small dialog box on the right side waiting for your input. Type TrayIcon, hit enter. Now double click on that icon. A dialog box will open. In the dialog box enter the path to avastui.exe, usually on your C:\ drive. In my case the result looks like this and please note the command at the end of the entry: c:\program files\alwil software\avast5\avastui.exe /nogui

Once you enter this string command, click OK. Close the registry editor, restart the computer and you should see the tray icon. Now, it has no choice but to appear until you uninstall avast or get a version of avast that changes the path to the command file. Works for me, hope it does well for you.

Offline zam

  • Newbie
  • *
  • Posts: 16
Re: no avast icon in system tray - windows xp
« Reply #35 on: December 19, 2011, 06:58:22 AM »
So - I have no idea why this is happening, but the icons are now showing up in
both accounts today.

The settings are the same in both accounts.

Resolution 1024x678
Color High 24 bit
Dpi large 120 dpi

 ???

Offline ady4um

  • Massive Poster
  • ****
  • Posts: 2667
Re: no avast icon in system tray - windows xp
« Reply #36 on: December 19, 2011, 07:09:23 AM »
Well, I have no idea either.

Next time this happens, try 96 dpi and 32 bits colors. The screen resolution you are using could potentially be a problem. I'm not sure if it really is a problem in this case, but it could be.

Some screens MUST use a specific screen resolution and screen frequency. This may sometimes influence how you see what is being displayed (correctly or not). I have no idea if this is your case.

ADD/REMOVE PROGS -> avast -> CHANGE/REMOVE -> REPAIR & REBOOT
Avast! 7 FAQ | FAQ & KB | Docs | Removal Utils | Configure Mail Shield | report FP | License Registration | UNSECURED?