Author Topic: "SSL/TLS Connection Detected" alert always flashing on screen, won't go away  (Read 67382 times)

0 Members and 1 Guest are viewing this topic.

Offline macmomma08

  • Full Member
  • ***
  • Posts: 132
  • I know nothing except that I know nothing.
I'm confused, isn't turning off SSL bad? I want my messages secure.

Offline hrmm

  • Newbie
  • *
  • Posts: 2
I too get the annoying ssl pop ups. I use Postbox express with imap gmail.
I tried to resolve the problem using the tips I found here, moved the server
to keychain system, disabled ssl on Postbox, added server on avast advanced
setup, and several combinations of all the tips, but nothing,...

If done the right way, it must work. The whole procedure in 3 steps:
  • Download the Equifax Secure Certificate Authority certificate (http://www.geotrust.com/resources/root-certificates/) and install it into your System keychain using the keychain utility
  • Add imap.gmail.com (or pop.gmail.com for POP3) to the list of SSL-only servers in the avast! preferences
  • Disable SSL in your mail client

If you still see error/warning popups, look into the system log

I'm disappointed with the way Avast tries to tackle email protection, the solution
should be a simple drop in, you can't expect the users to start fiddling around with
system configuration options just to get Avast to work...

There will probably be some automatic configuration in the future, but note, that the auto-configuration tool  has to "play" with your security settings, so let it "somehow work" without knowing what is going on is not very recommended...

I followed the above directions however I am still getting the popups saying "SSL certificate check faild - host: smtp.gmail.com". I am using mail.app with the latest version of avast for mac.

Offline mproudfit

  • Newbie
  • *
  • Posts: 1
One of five email accounts will not work with Use SSL unchecked.  It is an account from my web account at imhosted.com.  "The server returned the error: The attempt to read data from the server “mail.<mywebsite>.com” failed." Any ideas?

Offline macmomma08

  • Full Member
  • ***
  • Posts: 132
  • I know nothing except that I know nothing.
I turned off the SSL in my apple mail thing like you guys said, but everytime I try to go into the preferences in Avast, when I get to the advanced menu in Mail Shield the whole preferences crashes, and it won't even let me send an error report. :(

Offline tumic

  • Moderator
  • Advanced Poster
  • *
  • Posts: 724
when I get to the advanced menu in Mail Shield the whole preferences crashes, and it won't even let me send an error report. :(

This is a known bug that will be fixed in the next program update.

Offline trintrax

  • Newbie
  • *
  • Posts: 2
I am using iCloud as mail provider. As imap server iCloud uses: p02-imap.mail.com
I disabled SSL(Mail-accounts-advanced) and entered the server name into avast preferences. Works fine.

Now my question. In Mail(OSX included) I have no settings for the outgoing smtp server when using iCloud. When disabling SSL I suppose the outgoing smtp connection will be not encrypted anymore.
As Avast only checks the incoming traffic my outgoing mail will be insecure.

Is that true? Unencrypted outgoing mail is not what I want!






Offline MattRidge

  • Newbie
  • *
  • Posts: 6
Hi all, first post regretfully...

I am also getting this error. All of my google accounts have SSL/TLS disabled, and yet for some reason it shows it as going forward as having it. I also have google's imap, and pop, and smtp in the Mail Shield -> Advanced -> SSL settings.

I am using Mail 5.2 and Lion 10.7.3... 16GB ram (soon to be 32GB), and half a Petabyte of HD space. 8TB on my computer alone. Yes I'm a geek...


I am using Avast Beta 7.0 (36454)... so just reporting in the bug...

Offline trintrax

  • Newbie
  • *
  • Posts: 2
I am using iCloud as mail provider. As imap server iCloud uses: p02-imap.mail.com
I disabled SSL(Mail-accounts-advanced) and entered the server name into avast preferences. Works fine.

Now my question. In Mail(OSX included) I have no settings for the outgoing smtp server when using iCloud. When disabling SSL I suppose the outgoing smtp connection will be not encrypted anymore.
As Avast only checks the incoming traffic my outgoing mail will be insecure.

Is that true? Unencrypted outgoing mail is not what I want!

ping

Offline tumic

  • Moderator
  • Advanced Poster
  • *
  • Posts: 724
I am using iCloud as mail provider. As imap server iCloud uses: p02-imap.mail.com
I disabled SSL(Mail-accounts-advanced) and entered the server name into avast preferences. Works fine.

Now my question. In Mail(OSX included) I have no settings for the outgoing smtp server when using iCloud. When disabling SSL I suppose the outgoing smtp connection will be not encrypted anymore.
As Avast only checks the incoming traffic my outgoing mail will be insecure.

Is that true? Unencrypted outgoing mail is not what I want!

The avast! mailshield indeed only scans incoming mail (POP3, IMAP). Outgoing mail (SMTP) is not handled by the mailshield in any way, so there is no reason, any SMTP setting should be changed in your mail client. In other words - leave SSL enabled for SMTP in your mail client and everything will work fine.

Offline whtrabit49

  • Newbie
  • *
  • Posts: 1
I'm still getting the pop up thingys, even though I followed the procedure here.  ????
« Last Edit: May 03, 2012, 05:23:27 AM by whtrabit49 »

Offline spl889

  • Newbie
  • *
  • Posts: 4
How do l disable the SSL in Outlook for Mac?
Using Gmail.

Offline spl889

  • Newbie
  • *
  • Posts: 4
How do l disable the SSL in Outlook for Mac?
Using Gmail.

Answered my own Q

Outlook
Preferences
Accounts
Then de-select SSL for the accounts.

Then went -
System
Avast
Mail Shield
Advanced
SSL
Then there is nothing there to select, it's blank.



Offline bash103

  • Newbie
  • *
  • Posts: 1
Having the same issue with Comcast mail server. I disable SSL in Mail, but when I go to the SSL window it won't let me add anything. If I need to maunally add the cert to the system keychain, where can I get it and how do I install?

I have to get this worked out as Comcast doesn't allow non SSL connections.

Really don't want to have to go back Sophos, but...

Offline rhgrant1

  • Newbie
  • *
  • Posts: 1
Hi all

Having the same issue really.

I have followed the instructions re Mac Mail for the SSL but am still getting the popup.

Also when I have web shield enabled, I cannot connect to the internet.

I am running OS Lion, with Safari and using a VPN programme as I am in the Middle East.

a question in 2 parts:

will the vpn affect the mail scans and
how do I configure Avast to allow internet connection using the VPN client

thanks in advance

Offline tome10

  • Newbie
  • *
  • Posts: 1
@SPL889: You have to hit the 'Unlock Button' which allows you to make changes.

Everybody else:
1) I have a MAC, and am using MAC Mail Ver 5.2. AOL is my Mail Provider
2) I had this same problem, but I configured the settings, and now don't get the popup saying there is a SSL/TLS connection. But, I can't receive e-mails with SSL disabled Port 143.
3) I can receive e-mails with SSL enabled Port 993. what am I missing? And how do I insert a screenshot?