Author Topic: Strange computer issue, maybe virus/malware? Hijackthis.log  (Read 6108 times)

0 Members and 1 Guest are viewing this topic.

Offline Jawsofhana

  • Newbie
  • *
  • Posts: 14
Strange computer issue, maybe virus/malware? Hijackthis.log
« on: December 16, 2011, 05:38:51 PM »
Hi there.

I registered because I'm having a very strange problem. or quite a lot of them.

First symptom was that Flash videoes could not be played. It said the addon crashed. In both Firefox and Explorer. A reboot fixed it. But then it would return. When this happened, the sound went away on the whole computer as well. No sound on anything. Yet the sound card reported to be working correctly in hardware management.

Then after a while, explorer started crashing when I right click. Normal illegal operation dialog. The weird thing was that it said explorer.EXE. Not explorer.exe. This was the first time it crashed. Subsequent crashes reported all lower case letters.

This made me think I had a virus, so I installed Spybot Search and Destroy. ( I already had/have fully updated Avast! antivirus installed).

But it did not find anything.

Later, I have also had some strange reports of files not being correctly written. So I assumed it could be a hard drive problem. I really do not want to run a complete disk scan with sectors and all, since I have 1,5Tb diskspace. But a normal scan only came back with some incorrect space values. (don't remember the exact text) Anyway. All errors was fixed.

So now I ran HiJackThis. I don't see anything strange in the start of the log, but the last few lines report important files to be missing?

I hope someone more experienced with the program, or have had similar issues, could give me a hand:

Since there was a text limit (even with /code), here is the hijackthis log file:

http://pastebin.com/6CeHxVsH


« Last Edit: December 16, 2011, 06:59:46 PM by Jawsofhana »

Offline Pondus

  • Probably Bot
  • ****
  • Posts: 37643
  • F-Secure user
Re: Strange computer issue, maybe virus/malware? Hijackthis.log
« Reply #1 on: December 16, 2011, 05:47:25 PM »
follow the guide here, and attach all logs....not copy and paste
http://forum.avast.com/index.php?topic=53253.0

lower left corner > additional options > attach

Essexboy will then help you when he arrive here......will take some hours before he does

Offline Jawsofhana

  • Newbie
  • *
  • Posts: 14
Re: Strange computer issue, maybe virus/malware? Hijackthis.log
« Reply #2 on: December 16, 2011, 07:09:02 PM »
Due to size limit, here is the disk management screen, and the avast log:


No errors came up during those searches. I hope someone might have an idea about what's wrong.
« Last Edit: December 16, 2011, 07:19:30 PM by Jawsofhana »

Offline essexboy

  • Malware removal instructor
  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 40589
  • Dragons by Sasha
    • Malware fixes
Re: Strange computer issue, maybe virus/malware? Hijackthis.log
« Reply #3 on: December 16, 2011, 08:27:38 PM »
Hi there was no apparent malware on your system.  Hijackthis does not report 64bit systems properly hence the missing files

Lets check out your file status

Go Start > All Programmes > Accessories
Right click Command Prompt and select run as Administrator
In the balck box type in the following:

sfc /scannow

On completion let me know if it remedied any errors


 

Offline Jawsofhana

  • Newbie
  • *
  • Posts: 14
Re: Strange computer issue, maybe virus/malware? Hijackthis.log
« Reply #4 on: December 16, 2011, 08:51:14 PM »
I am running the scan now.

I forgot to mention that when the sound is gone, no full screen applications will launch. Like games f.ex. One of two things happen:

They come up as a black screen and hang, or they come up as a small white 'window' where clicking anything comes up with a 'This program does not respond' promt.

At the worst point I pressed ctrl+alt+del to get task manager, because alt+tab doesn't work in this state, and the entire computer locked up for about a minute. Then it popped up with a promt saying something about the system shortcut being unable to execute. I have never seen that particular error message before.

After that it returned to windows and I was able to close the program and reboot. (since everything stopped working again)..

That's when I thought I was really fracked, but I haven't had anything that bad afterwards.


The scan finished now, and said that windows resource protection reported no integrity.. transgressions? (Windows ressursbeskyttelse fant ingen integritetsovertredelser).


I believe I should just reinstall the computer, and hope for the best. It is strange, because the problems just started 5 days ago. No notable changes had been made to the computer which has been working perfectly since I bought it two months ago.


Offline essexboy

  • Malware removal instructor
  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 40589
  • Dragons by Sasha
    • Malware fixes
Re: Strange computer issue, maybe virus/malware? Hijackthis.log
« Reply #5 on: December 16, 2011, 08:55:00 PM »
Generally you tend to get that sort of problem after running "registry fixing tools" I can look deeper if you wish - but as you are going for a re-install it might not be worth that

Offline Jawsofhana

  • Newbie
  • *
  • Posts: 14
Re: Strange computer issue, maybe virus/malware? Hijackthis.log
« Reply #6 on: December 16, 2011, 09:04:32 PM »
I don't think I've run anything suspect. I really appreachiate the help. Did not know about the resource protection scan.

I've only used this computer for two months, and it is not worth the hours of troubleshooting (Only 3gb's of personal files). It's just soo horribly annoying, not knowing what's wrong. And feeling completely computer illiterate for not being able to fix it. >.<

Of course, if you don't mind, I'll be very happy for further suggestions. :)

Offline essexboy

  • Malware removal instructor
  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 40589
  • Dragons by Sasha
    • Malware fixes
Re: Strange computer issue, maybe virus/malware? Hijackthis.log
« Reply #7 on: December 16, 2011, 09:09:56 PM »
The next area to check would be the hard drive for errors


1.Open Computer by clicking the Start button , and then clicking Computer.

2.Right-click the hard disk drive that you want to check (C), and then click Properties.

3.Click the Tools tab, and then, under Error-checking, click Check Now.  If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

To check for both file errors and physical errors, select both Automatically fix file system errors and Scan for and attempt recovery of bad sectors.

4.Click Start.

5.You will be prompted to reschedule the disk check for the next time you restart your computer.  OK that and reboot


Offline Jawsofhana

  • Newbie
  • *
  • Posts: 14
Re: Strange computer issue, maybe virus/malware? Hijackthis.log
« Reply #8 on: December 18, 2011, 05:19:43 PM »
I haven't done this last step, yet. I keep forgetting to start disk scanning when I go to sleep. :/

But I had an idea to look for previous versions of explorer.exe, which I did not have. But it turns out it's been modified.

The modification date is -before- the file creation date.

Creation date: 25. October, 2011. Which is pretty accurate for when I bought and installed this machine.

It claims it was changed 26th of February, 2011. But at this time I did not own the computer. :P

I believe this might be a malicious change, which tries to mask itself by setting the change date earlier than the actual change? Or am I being paranoid here?


Offline essexboy

  • Malware removal instructor
  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 40589
  • Dragons by Sasha
    • Malware fixes
Re: Strange computer issue, maybe virus/malware? Hijackthis.log
« Reply #9 on: December 18, 2011, 05:42:00 PM »
Explorers MD5 and size are correct - but the modification date is the last time Microsoft changed the file
The screenshot is of my explorer and I did not get this system till Oct/Nov  ;D


Offline Jawsofhana

  • Newbie
  • *
  • Posts: 14
Re: Strange computer issue, maybe virus/malware? Hijackthis.log
« Reply #10 on: December 19, 2011, 10:47:07 AM »
Okay, now I just feel silly. Paranoid and silly. But this problem really bugs me.

The Chkdsk found no bad sectors. But it did fix some other problems.

Now I am starting to blame my power supply. Or maybe some sort of damage to the mainboard.

USB devices now sometimes stop working. Almost as if they just don't get power anymore, and has to be re-connected. I almost panicked when Windows reported that it could not recognise my full 2Tb drive, because it could have been damaged. however, my laptop found it just fine.

Later when I tried connecting it to the stationary again, it worked as normal.

The same evening, I got that error on a usb pen, as well. Then my keyboard had to be re-connected every restart. But that has fixed itself. Atm. everything seems to be working as normal. Until it randomly looses sound, all browser plugins crashes constantly, and refuses to start anything at all.


« Last Edit: December 19, 2011, 10:56:14 AM by Jawsofhana »

Offline essexboy

  • Malware removal instructor
  • Avast Überevangelist
  • Probably Bot
  • *****
  • Posts: 40589
  • Dragons by Sasha
    • Malware fixes
Re: Strange computer issue, maybe virus/malware? Hijackthis.log
« Reply #11 on: December 19, 2011, 09:18:10 PM »
Is the computer still under warranty...  As the problems described would tend to suggest a motherboard problem

Offline Jawsofhana

  • Newbie
  • *
  • Posts: 14
Re: Strange computer issue, maybe virus/malware? Hijackthis.log
« Reply #12 on: December 20, 2011, 12:32:14 PM »
Yeah, it is. Thanks for all your help.

It's not a virus at least. I'll see how it works after a re-install. If it's still the same, I'll start switching parts.