Author Topic: Stealth mode not working  (Read 11675 times)

0 Members and 1 Guest are viewing this topic.

Offline dratsab

  • Newbie
  • *
  • Posts: 3
Stealth mode not working
« on: December 07, 2011, 12:59:03 AM »
I've just installed this product on my Samung Galaxy SII running Android 2.3.3 (non-rooted) and find that the avast! icon stsys in the notification bar, even through hard resets and the anti-theft option enabled. Not much use... Perhaps I'm missing something?

Any help appreciated.
Steve

Offline Jan Svehlak

  • Avast team
  • Poster
  • *
  • Posts: 521
Re: Stealth mode not working
« Reply #1 on: December 07, 2011, 01:45:02 AM »
Hi Steve, does it mean, that you can still find antitheft application in apps list or in running applications list? The icon indicates, that avast client is running, says generally nothing about antitheft..

Offline dratsab

  • Newbie
  • *
  • Posts: 3
Re: Stealth mode not working
« Reply #2 on: December 07, 2011, 04:53:17 AM »
Hi, thanks for the reply. If I pull the notification bar down, it clearly states that avast! Mobile security is running. I can clear the notification by going into the task manager and exiting the program but have not had time to see if it stops other processes working. But really I shouldn't need to do this...

If I clear the notification, it doesn't come back if I activate the program via the keypad, but it does come back if the phone is reset.

Cheers
Steve

Offline Jan Gahura

  • Avast team
  • Full Member
  • *
  • Posts: 162
    • ALWIL Software
Re: Stealth mode not working
« Reply #3 on: December 07, 2011, 08:03:42 AM »
The stealth mode applies to the anti-theft. Uninstalling mobile security doesn't remove the anti-theft application. So if your phone is stolen it won't be easy to get rid of the anti-theft solution even if a thief checks and uninstall avast. Hiding an antivirus doesn't make sense. It'd be only harder to use it by a legitimate user.

Just a note: Anti-Theft has to be set up after installation of mobile security by a tap on the Anti-Theft item on Dashboard. We'll make this requirement more apparent in UI in a subsequent beta refreshes.

Offline dratsab

  • Newbie
  • *
  • Posts: 3
Re: Stealth mode not working
« Reply #4 on: December 07, 2011, 09:05:39 AM »
Ah - now I understand. Thanks for clearing that up :)

Offline reinhardholzner

  • Super Poster
  • ***
  • Posts: 1363
Re: Stealth mode not working
« Reply #5 on: December 07, 2011, 12:27:40 PM »
as one of the makers of avast! Anti-Theft and former Theft Aware i think what you describe is actually a very cool feature! imagine a thief is absolutely confident that he removed the avast! Mobile Security he found. BUT - there is STILL the Anti-Theft component sitting in the background - LOL. and if you installed it rooted, it will also survive hard resets. How cool is that?

regards
Reinhard

Offline jaxf250

  • Newbie
  • *
  • Posts: 2
Re: Stealth mode not working
« Reply #6 on: December 07, 2011, 04:11:15 PM »
Hi Reinhard -

Just recently started using TA only a week ago, when I see it is replaced by avast! now - cool! I like the new
UI very much.

Please, provide us an option to turn off the avast! orange icon in the notification bar if we so choose... it is really not
pleasing to me to see it there all the time... I know the app is running... you can add notifications as things get scanned
and then allow me to dismiss them... those sorts of things I expect to see... just please let me remove the one that stays lit all the time.... thanks!

Offline reinhardholzner

  • Super Poster
  • ***
  • Posts: 1363
Re: Stealth mode not working
« Reply #7 on: December 08, 2011, 03:29:07 PM »
jaxf ... it is already on the list of improvements for the next beta update

Offline cooby

  • Poster
  • *
  • Posts: 441
Re: Stealth mode not working
« Reply #8 on: December 08, 2011, 03:49:07 PM »
Please, make it optional. I want to see Avast icon at all times. Thank you.
1. Toshiba Satellite A75, Windows XP-Pro-SP3, Avast! free v9, Sunbelt Firewall 4.7.4.0, SSM, Opera 12.17, SeaMonkey+NoScript, mvps hosts, (MalwareBytes updated and run on demand only, rarely used), Acronis v11, SUMo
2. Toshiba Thrive tablet (rooted) ICS, AdAway (hosts), Opera, Avast Mobile Security 3.0.7801, Titanium Backup, App Backup&Restore

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67255
Re: Stealth mode not working
« Reply #9 on: December 08, 2011, 04:02:09 PM »
Please, make it optional. I want to see Avast icon at all times. Thank you.
+1 :)
The best things in life are free.

Offline Jan Gahura

  • Avast team
  • Full Member
  • *
  • Posts: 162
    • ALWIL Software
Re: Stealth mode not working
« Reply #10 on: December 13, 2011, 08:04:32 PM »
I'm really glad that I'm not alone in liking that icon :). We are currently working on making that icon even more close to its windows counterpart.

Offline steadiman

  • Newbie
  • *
  • Posts: 1
Re: Stealth mode not working
« Reply #11 on: June 12, 2013, 03:50:04 AM »
I made the mistake of reading too much into the stealthiness of stealth mode.  The Avast icon sits up in the corner of the screen letting everyone know that Avast Mobile Security is running.  Yes you can force stop it and the icon goes away along with virus protection and you can restart the phone and the scanner will restart also.  The program's menu presents by touching the icon and Anti-Theft shows as disabled.  Personally (and maybe a million other people) I'd like to be able to turn off the icon for a cleaner look and also so as to not lead a thief directly to his next problem with a stolen phone. Hiding the entire program behind another name and having to dial the program to open with the pin would be my choice for operability.

Offline Filip Havlicek

  • Moderator
  • Massive Poster
  • *
  • Posts: 2653
Re: Stealth mode not working
« Reply #12 on: June 12, 2013, 07:43:45 AM »
Hi,

in that case you can just uninstall Mobile Security. The Anti-Theft will remain.

Filip