Author Topic: Exclusion does not work after the new Avast-update 6.0.1367  (Read 31299 times)

0 Members and 1 Guest are viewing this topic.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: Exclusion does not work after the new Avast-update 6.0.1367
« Reply #15 on: December 17, 2011, 03:54:04 PM »
It will be fixed in the next program update.
avast 6 or avast 7 ???
The best things in life are free.

lifeson99

  • Guest
Re: Exclusion does not work after the new Avast-update 6.0.1367
« Reply #16 on: December 17, 2011, 04:23:10 PM »
I switched to Avast from Avira for this very reason.
Avira exclusions would not work !!!

But ever since I installed Avast, the Exclusions have NEVER worked.
Very frustrating because I use VideoFixer to repair corrupt AVI files and it always find a virus in VideoFixer, as has every antivirus program done for years.
But it is a False Positive.  I even reported it in the form to Avast as a false Positive and it is till being scanned.

I excluded the entire folder and the file itself - to no avail.

As a programmer, I would think implementing exclusions would be a simple matter.  And if they suddenly stop working, then the fix would be simple as well.  Not sure why Avast does not quickly post the fix in an update but I don't work there so have no idea.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: Exclusion does not work after the new Avast-update 6.0.1367
« Reply #17 on: December 17, 2011, 05:59:01 PM »
I excluded the entire folder
Did you use an * after it?

Not sure why Avast does not quickly post the fix in an update but I don't work there so have no idea.
They will release the fix in the next program update.
The best things in life are free.

Kostronor

  • Guest
Re: Exclusion does not work after the new Avast-update 6.0.1367
« Reply #18 on: December 17, 2011, 06:10:53 PM »
It will be fixed in the next program update.
Thanks for the quick answer!
Waiting for the update now

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: Exclusion does not work after the new Avast-update 6.0.1367
« Reply #19 on: December 17, 2011, 06:15:14 PM »
Thanks for the quick answer!
Waiting for the update now
Secret... Can Igor answer my question?
The best things in life are free.

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11864
    • AVAST Software
Re: Exclusion does not work after the new Avast-update 6.0.1367
« Reply #20 on: December 17, 2011, 06:22:33 PM »
It will be fixed in the next program update.
avast 6 or avast 7 ???

That's not completely clear at the moment... could be 7.

But ever since I installed Avast, the Exclusions have NEVER worked.
Very frustrating because I use VideoFixer to repair corrupt AVI files and it always find a virus in VideoFixer, as has every antivirus program done for years.

I'm not familiar with VideoFixer, so I may be wrong, but I guess you're setting an incorrect exclusion. The thing is that the only thing that doesn't work is the exclusion "on write" - but if the file is already there, exclusions for reading or executing do work. So unless something is constantly modifying your executable (unlikely), or unless the executable is actually some kind of extractor which drops another executable when you run it, the problem doesn't apply here.
So, what exactly and where exactly are you setting? What is the exact detection (full path shown) you get?

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: Exclusion does not work after the new Avast-update 6.0.1367
« Reply #21 on: December 17, 2011, 06:26:43 PM »
That's not completely clear at the moment... could be 7.
Seems there are other staff members that are more self confident than you ;D
But thanks anyway.
The best things in life are free.

lifeson99

  • Guest
Re: Exclusion does not work after the new Avast-update 6.0.1367
« Reply #22 on: December 17, 2011, 10:12:15 PM »
Here are my settings - I run a scan nightly and every morning I have an Avast message that a "Threat" has been delected.
Then I click on the details of the threat and it says VideoFixer.exe was detected as having a virus.  7 days a week I get the same message and have to then tell it to "Ignore" it.

Here is a screenshot of my settings.  I have tried using ONLY the folder, and ONLY the file, and also tried using BOTH as shown below.  Nothing works:




Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11864
    • AVAST Software
Re: Exclusion does not work after the new Avast-update 6.0.1367
« Reply #23 on: December 17, 2011, 10:15:26 PM »
These are exclusions for the File System Shield (to prevent scanning/detection when you run the application) - not for on-demand scans.
You can either set the exclusion in the settings of the particular scan (the one you have scheduled to run nightly), or in program settings, which would cover all on-demand scans.

lifeson99

  • Guest
Re: Exclusion does not work after the new Avast-update 6.0.1367
« Reply #24 on: December 19, 2011, 02:19:42 PM »
Sorry - wrong screenshot as you noted.
I also have had the folder Excluded in the master "Settings".
So long as this is fixed I am not in a mad rush and will not switch.
I love the interface and surprisingly even like the voice since it is only very occasional.  Very Professional look and feel.


« Last Edit: December 19, 2011, 02:22:08 PM by lifeson99 »

chrysalis

  • Guest
Re: Exclusion does not work after the new Avast-update 6.0.1367
« Reply #25 on: December 19, 2011, 08:50:34 PM »
I switched to Avast from Avira for this very reason.
Avira exclusions would not work !!!

But ever since I installed Avast, the Exclusions have NEVER worked.
Very frustrating because I use VideoFixer to repair corrupt AVI files and it always find a virus in VideoFixer, as has every antivirus program done for years.
But it is a False Positive.  I even reported it in the form to Avast as a false Positive and it is till being scanned.

I excluded the entire folder and the file itself - to no avail.

As a programmer, I would think implementing exclusions would be a simple matter.  And if they suddenly stop working, then the fix would be simple as well.  Not sure why Avast does not quickly post the fix in an update but I don't work there so have no idea.

They have never worked for me either I think.

I have an app that avast seems to scan very slowly, its only a very small tiny app and takes about 3 seconds to launch.  I disabled auto sandbox, no good, excluded the folder, no good.  It  only starts fast when I disable file shield.  Also I thought avast caches positive scan results for performance yet this file still keeps been scanned.

chrysalis

  • Guest
Re: Exclusion does not work after the new Avast-update 6.0.1367
« Reply #26 on: December 23, 2011, 01:00:06 PM »
I think I dived in too quick here, this was a problem on the older version but it seems now my exclusion is working.

Maccara

  • Guest
Re: Exclusion does not work after the new Avast-update 6.0.1367
« Reply #27 on: December 26, 2011, 05:23:09 AM »
This needs to be fixed ASAP!

Interferes with my build system, tried exclusions and noticed they do jack. Thread found, so subscribing so I might remember to turn avast back on when fixed.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: Exclusion does not work after the new Avast-update 6.0.1367
« Reply #28 on: December 26, 2011, 11:52:39 AM »
This needs to be fixed ASAP!
Next program release. Probably avast 7 beta next weeks.
The best things in life are free.

Offline pk

  • Avast team
  • Super Poster
  • *
  • Posts: 2078
Re: Exclusion does not work after the new Avast-update 6.0.1367
« Reply #29 on: December 26, 2011, 12:19:11 PM »
@Kostronor, lifeson99, Maccara,

please apply ap2011-26-12-001: Patch for aswMonFlt.sys, on-close exclusions (IS) patch from http://public.avast.com/~kurtin/patches page.