Author Topic: Avast Shields are down after rebooting  (Read 6296 times)

0 Members and 1 Guest are viewing this topic.

Verticity

  • Guest
Avast Shields are down after rebooting
« on: December 15, 2011, 12:38:37 PM »
Hey,
My computer restarted last night for updates.
When I woke up, 3 of the shields were down. So I reinstalled.
Now all of the shields are down. When I try to enable them, it doesn't do anything. Doesn't say anything, either. I tried "Repair" on the uninstall menu.

I'm on Vista SP2, Avast version 6.0.1367

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67198
Re: Avast Shields are down after rebooting
« Reply #1 on: December 15, 2011, 12:42:02 PM »
Hmmm...
1. Did you update Windows? It brought back the MSE as an optional update.
2. Did you use Windows system restore?
The best things in life are free.

Verticity

  • Guest
Re: Avast Shields are down after rebooting
« Reply #2 on: December 15, 2011, 12:43:42 PM »
Hmmm...
1. Did you update Windows? It brought back the MSE as an optional update.
2. Did you use Windows system restore?

My computer restarted last night for updates, so yes, I updated windows. That's when the problems started happening.

No, I haven't used System Restore.

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11848
    • AVAST Software
Re: Avast Shields are down after rebooting
« Reply #3 on: December 15, 2011, 12:48:49 PM »
Are there any recent files called unpXXXXX.mdmp (where X are some numbers) in the folder
c:\Users\All Users\AVAST Software\Avast\log
?

Verticity

  • Guest
Re: Avast Shields are down after rebooting
« Reply #4 on: December 15, 2011, 12:56:46 PM »
Are there any recent files called unpXXXXX.mdmp (where X are some numbers) in the folder
c:\Users\All Users\AVAST Software\Avast\log
?

I don't have the "Avast Software" folder, only "Alwil Software" from Avast 5 - and that only has "Setup" in the log folder.

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11848
    • AVAST Software
Re: Avast Shields are down after rebooting
« Reply #5 on: December 15, 2011, 01:01:49 PM »
OK, if you updated avast! from version 5, it could be Alwil Software folder, instead of Avast Software, but having only one file in the Log subfolder... strange.

If you go to Control Panel / Administrative Tools / Services and check the status of "avast! Antivirus" service - is it started? If not, what happens when you select it and choose "Start"?

Verticity

  • Guest
Re: Avast Shields are down after rebooting
« Reply #6 on: December 15, 2011, 08:49:37 PM »
OK, if you updated avast! from version 5, it could be Alwil Software folder, instead of Avast Software, but having only one file in the Log subfolder... strange.

If you go to Control Panel / Administrative Tools / Services and check the status of "avast! Antivirus" service - is it started? If not, what happens when you select it and choose "Start"?

It says:
Windows could not start the avast! Antivirus service on Local Computer.
Error 1075: The dependency service does not exist or has been marked for deletion.

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11848
    • AVAST Software
Re: Avast Shields are down after rebooting
« Reply #7 on: December 15, 2011, 10:49:31 PM »
Hmm... that service should have only two dependencies - first the RPC, which should certainly be present on the system, and second avast! aswMonFlt driver.
If you open the properties of the "avast! Antivirus" service and switch to the Dependencies page, what does it show (it may take a while before the content is filled in)?

Verticity

  • Guest
Re: Avast Shields are down after rebooting
« Reply #8 on: December 16, 2011, 02:33:06 AM »
Hmm... that service should have only two dependencies - first the RPC, which should certainly be present on the system, and second avast! aswMonFlt driver.
If you open the properties of the "avast! Antivirus" service and switch to the Dependencies page, what does it show (it may take a while before the content is filled in)?
Hey, it reads:
This Service Depends on the following components:
Remote Procedure Call (RPC)
when I click the expand button beside it it shows "DCOM Server Process Launcher"

Thanks :)


Verticity

  • Guest
Re: Avast Shields are down after rebooting
« Reply #9 on: December 16, 2011, 08:41:50 PM »
Anyone know?

iyogisolutions1

  • Guest
Re: Avast Shields are down after rebooting
« Reply #10 on: December 16, 2011, 08:50:39 PM »
Hi,

  Please try  to reinstall avast! from scratch.

1. Download the latest version of avast! Uninstall Utility and save it.
       You can download it from http://files.avast.com/files/eng/aswclear.exe
2. Download the latest avast! version that you have purchased and save it.
3.Run the avast! Uninstall Utility in safe mode and restart to Normal mode. (Run the tool two or three times by selecting the respective folder)
4. Install avast! using the setup saved
5. Check the status and post back with the results.


ady4um

  • Guest
Re: Avast Shields are down after rebooting
« Reply #11 on: December 17, 2011, 03:08:37 AM »
Anyone know?

I don't know why you have those 2 services stopped. Select one of them (DCOM, for example) -> properties -> startup type -> "automatic". Repeat with the other (RPC).

Now reboot. Go to Control Panel -> Add/Remove Programs -> Avast -> change -> repair. Once the repair finishes, reboot.

Test and report back.

Verticity

  • Guest
Re: Avast Shields are down after rebooting
« Reply #12 on: December 20, 2011, 09:17:28 PM »
Hi,

  Please try  to reinstall avast! from scratch.

1. Download the latest version of avast! Uninstall Utility and save it.
       You can download it from http://files.avast.com/files/eng/aswclear.exe
2. Download the latest avast! version that you have purchased and save it.
3.Run the avast! Uninstall Utility in safe mode and restart to Normal mode. (Run the tool two or three times by selecting the respective folder)
4. Install avast! using the setup saved
5. Check the status and post back with the results.


Sorry for the late reply!

Thanks, this solved my problem.  ;D

iyogisolutions1

  • Guest
Re: Avast Shields are down after rebooting
« Reply #13 on: December 20, 2011, 09:19:49 PM »
Hi,

  Please try  to reinstall avast! from scratch.

1. Download the latest version of avast! Uninstall Utility and save it.
       You can download it from http://files.avast.com/files/eng/aswclear.exe
2. Download the latest avast! version that you have purchased and save it.
3.Run the avast! Uninstall Utility in safe mode and restart to Normal mode. (Run the tool two or three times by selecting the respective folder)
4. Install avast! using the setup saved
5. Check the status and post back with the results.


Sorry for the late reply!

Thanks, this solved my problem.  ;D


You are welcome