Author Topic: [SOLVED] Web Shield not working?  (Read 8112 times)

0 Members and 1 Guest are viewing this topic.

Online NON

  • Japanese User
  • Avast Überevangelist
  • Ultra Poster
  • *****
  • Posts: 4869
  • Whatever will be, will be.
[SOLVED] Web Shield not working?
« on: December 17, 2011, 09:16:03 AM »
I downloaded eicar.com from the Internet with default browser, but Web Shield not alerted and download completed. :(

And one thing... I can see eicar.com on SD card after deletion by avast! scanner, but it disappears after reboot.
Is it Android's data caching or like that?

avast! Mobile Security 1.0.1123
Virus def: 111204-01 (no update available)
IS05 Android 2.3.4
« Last Edit: December 20, 2011, 10:31:00 AM by NON »
Main: Win10 Pro 20H2 64bit / Core i5-7400 3.0GHz / 16GB RAM / Avast 21 Premium Beta(Icarus) / Comodo Firewall (testing again)
Mobile: Win10 Pro 20H2 64bit / Core i5-3340M 2.7GHz / 8GB RAM / Avast 21 Free / Windows Firewall Control

Avast の設定について解説しています。よろしければご覧ください。

Offline Filip Havlicek

  • Moderator
  • Massive Poster
  • *
  • Posts: 2653
Re: Web Shield not working?
« Reply #1 on: December 17, 2011, 10:06:31 AM »
Try loading we-shield-test.avast.com to test if the webshield is working.

It might be a caching of your file manager.

Offline TheUntouchable

  • EX-TheftAware Mod
  • Avast Überevangelist
  • Jr. Member
  • *****
  • Posts: 55
Re: Web Shield not working?
« Reply #2 on: December 17, 2011, 01:16:15 PM »
Same here, downloaded the eicar testfile with any warning from avast. I opend it too but no warning. A system scan found it.

Cant open that page on my phone or on my pc.
Device: HTC One (UL)
ROM: ViperOne 1.2.1 / latest Beta
1 click debug log creation: General Feedback Tool 3.1.01 (Win, 30.07.13)

Online NON

  • Japanese User
  • Avast Überevangelist
  • Ultra Poster
  • *****
  • Posts: 4869
  • Whatever will be, will be.
Re: Web Shield not working?
« Reply #3 on: December 17, 2011, 01:47:42 PM »
Cant open that page on my phone or on my pc.
True, correct address seems web-shield-test.avast.com. ;D

Try loading we-shield-test.avast.com to test if the webshield is working.

It might be a caching of your file manager.
Web shield phishing alert appears. :)
So, web shield does not block Windows malwares but block phishing sites and Android malwares?
« Last Edit: December 17, 2011, 01:51:40 PM by NON »
Main: Win10 Pro 20H2 64bit / Core i5-7400 3.0GHz / 16GB RAM / Avast 21 Premium Beta(Icarus) / Comodo Firewall (testing again)
Mobile: Win10 Pro 20H2 64bit / Core i5-3340M 2.7GHz / 8GB RAM / Avast 21 Free / Windows Firewall Control

Avast の設定について解説しています。よろしければご覧ください。

Offline TheUntouchable

  • EX-TheftAware Mod
  • Avast Überevangelist
  • Jr. Member
  • *****
  • Posts: 55
Re: Web Shield not working?
« Reply #4 on: December 17, 2011, 01:54:06 PM »
Jep, now it works, thanks :D
Device: HTC One (UL)
ROM: ViperOne 1.2.1 / latest Beta
1 click debug log creation: General Feedback Tool 3.1.01 (Win, 30.07.13)

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Web Shield not working?
« Reply #5 on: December 18, 2011, 11:19:45 PM »
Hi NON,

In order to understand what's going on, it's important to realize that the Web Shield in Avast Mobile Security can only check the URLs you visit, not the actual content. This is because of the technical limitation of the Android platform, and is how all other security products work as well.

As there are no (or very very few) web-based attacks for the Android platform at the moment, the main goal of our Web Shield is to protect against phishing sites.

True, we could have also blocked the eicar URLs (on eicar.com / eicar.org) but we'd find this a bit lame (doing that just for the sake of passing those "tests"...).

Hope this helps,
Vlk
If at first you don't succeed, then skydiving's not for you.

Online NON

  • Japanese User
  • Avast Überevangelist
  • Ultra Poster
  • *****
  • Posts: 4869
  • Whatever will be, will be.
Re: Web Shield not working?
« Reply #6 on: December 20, 2011, 10:30:43 AM »
Thanks Vlk, now it's clear. :)
Main: Win10 Pro 20H2 64bit / Core i5-7400 3.0GHz / 16GB RAM / Avast 21 Premium Beta(Icarus) / Comodo Firewall (testing again)
Mobile: Win10 Pro 20H2 64bit / Core i5-3340M 2.7GHz / 8GB RAM / Avast 21 Free / Windows Firewall Control

Avast の設定について解説しています。よろしければご覧ください。