Author Topic: freezing after upgrade to 4.6.652  (Read 16374 times)

0 Members and 1 Guest are viewing this topic.

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11655
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: freezing after upgrade to 4.6.652
« Reply #15 on: April 28, 2005, 07:50:33 PM »
I'd need someone computer-proficient to follow the steps described later in this thread ( namely here: http://forum.avast.com/index.php?topic=12998.msg110335#msg110335 ) and send me the dump...


Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

biftek

  • Guest
Re: freezing after upgrade to 4.6.652
« Reply #16 on: April 28, 2005, 11:52:34 PM »
win xp sp2 same exact problem as previous replier.  mouse moves but entire desktop freezes, and cursor hourglasses on taskbar.  Remove avast and problem disappears.  If you need me to try anything ( short of a format:)) let me know.  I miss avast already :(


I have the same problem than rapunzel and aiiee on my ACER Aspire 1511 LMi laptop.

Windows XP Home SP2. Mouse moves but the entire desktop freezes and it is impossible to launch a programm.


aiiee

  • Guest
Re: freezing after upgrade to 4.6.652
« Reply #17 on: April 29, 2005, 01:23:34 AM »
I'd need someone computer-proficient to follow the steps described later in this thread ( namely here: http://forum.avast.com/index.php?topic=12998.msg110335#msg110335 ) and send me the dump...


Thanks
Vlk

OK I'll do this tonight and upload it.  Thanks for looking into it

aiiee

  • Guest
Re: freezing after upgrade to 4.6.652
« Reply #18 on: April 29, 2005, 04:09:36 AM »
Hmm, this is going to be difficult to solve... :-\

The only possibility I see right now is follow the procedure I described here: http://forum.avast.com/index.php?topic=2850.msg20171#msg20171

When you have the dump file, you can ZIP it up and upload it to ftp://ftp.asw.cz (you don't have read access to this ftp site, just write).


Thanks
Vlk

OK, it's being uploaded to your ftp site, in the incoming directory.   If I can do anything further please let me know
« Last Edit: April 29, 2005, 04:19:33 AM by aiiee »

rapunzel

  • Guest
Re: freezing after upgrade to 4.6.652
« Reply #19 on: April 29, 2005, 11:30:42 AM »
I have done some testing and I have it working now.

I have done the following:

1. Uninstall avast in safe mode.
2. Reboot to normal mode
3. Re-install the latest version of avast. (did not set any avast settings).
4. Reboot

5.
Check if everything works without any modifications of the avast settings. (in my case it worked correctly).

6. Reboot and check again if the pc works fine.
7. In that case it is a avast-setting (that was the problem in my case).

8.
Change only one shield (e.g. webshield) settings to your needs.
Reboot
check if the pc still works. If it doesn't work, you now know where the problem sits.

9.
Repeat this for all the diffrent shields. To see when the problem comes up.
I think it is best to do the standard shield als last, becouse that was were my problem was.

My error was a result of an * whitch i had place in "standard shield -> advanced settinges -> scan this extentions when opened" (topmost editbox).
When i deleted this * and leaved the editbox blank, avast worked perfectly.

I hope some of you can trace your problem en fix it too, like I did.

Good luck You all.



Offline chameleon

  • Full Member
  • ***
  • Posts: 164
Re: freezing after upgrade to 4.6.652
« Reply #20 on: April 30, 2005, 06:35:27 AM »
Rapunzel: "My error was a result of an * whitch i had place in "standard shield -> advanced settinges -> scan this extentions when opened" (topmost editbox).
When i deleted this * and leaved the editbox blank, avast worked perfectly."


Same issue here after updating to 4.6.652: freezing at log in screen.

Rapunzel's advice worked for me. I tried  a system restore, a repair, a re-install.

I found that once I re-installed avast! and added a * in standard shield in advanced settings my computer froze again.

I followed Rapunzel's advice and have left avast! at the default settings and now avast! appears to be working fine.

My only concern is that the * in advanced settings was recommended for FireFox users. But I can live with this until the bugginess is resolved.

Thanks for your diligence Rapunzel.
« Last Edit: April 30, 2005, 06:39:29 AM by chameleon »

warp10

  • Guest
Re: freezing after upgrade to 4.6.652
« Reply #21 on: April 30, 2005, 08:52:01 AM »
After testing, I also find that the freezes only occur after placing an asterisk in the scan options. Is the asterisk really neccessary? What file types does avast scan without it?

Vlk, I am uploading a crash dump now (compressed with 7zip, 1GB compressed to 64MB) file name is warp10.7z.


warp10

dannybelle

  • Guest
Re: freezing after upgrade to 4.6.652
« Reply #22 on: May 01, 2005, 02:43:45 AM »
) I had the same problem, except that sometimes my machine was freezing at startup, and sometimes at shutdown.  I contacted MS tech support, because I had no idea what was going on.  We finally concluded that Avast! was fouling up the script, (either startup or shutdown). The tech walked me through disabling the four avast! services in msconfig, and everything works fine.  The odd thing is that my wife's computer is using avast! and she is not experiencing any problems.  I want to use avast!, but I also want to use my machine.  What to do?

dannybelle

  • Guest
Re: freezing after upgrade to 4.6.652
« Reply #23 on: May 01, 2005, 02:58:16 AM »
OOPS!  I'll get the hang of this yet.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: freezing after upgrade to 4.6.652
« Reply #24 on: May 01, 2005, 04:47:19 AM »
The tech walked me through disabling the four avast! services in msconfig, and everything works fine.
Do you have any other antivirus in your system?
Did you have in the past? Which one?
Which is your operational system? Do you use a firewall?
The best things in life are free.

aiiee

  • Guest
Re: freezing after upgrade to 4.6.652
« Reply #25 on: May 01, 2005, 05:51:49 PM »
tried rapunzel's fix, didn't work.  switched to AVG until things are fixed here.  best of luck

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11655
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: freezing after upgrade to 4.6.652
« Reply #26 on: May 02, 2005, 07:44:55 AM »
OK guys so you had * in the "scan on-open" field, and it started freezing with the 4.6.652 update? I.e. it was working correctly with 4.6.623?

BTW that's quite an overhead to have the * in that field - this basically turns on scanning on each and every file accessed on your system - which will slow things down considerably...
If at first you don't succeed, then skydiving's not for you.

Offline chameleon

  • Full Member
  • ***
  • Posts: 164
Re: freezing after upgrade to 4.6.652
« Reply #27 on: May 02, 2005, 07:56:09 AM »
Yes. That is correct. And in removing the * , avast! works fine again/is not freezing. And yes, in the previous version avast!  worked fine with * option.

Some time ago, the * star action was recommended for avast! users of firefox as we noted that the avast! ball was not spinning/scanning.

However, with the new versions of avast! the problem seems to be resolved so far as scanning in firefox. (I assume, from appearances).

 :)

PS: I did not notice that the system was slower for the *, though my computer is relatively smooth.
« Last Edit: May 02, 2005, 08:00:21 AM by chameleon »