Author Topic: Avast POP mail with SSL is now broken.  (Read 2848 times)

0 Members and 1 Guest are viewing this topic.

Timon

  • Guest
Avast POP mail with SSL is now broken.
« on: November 24, 2004, 06:59:25 AM »
Running version 4.5

I had to turn off my mail servers SSL for POP3 because avast is 4.5 is now broken. It causes all SSL transactions to fail. I thought I could turn off avast monitoring of POP3 but you can't or at least I can't find away that really turns it off. This was working.

This needs to be checked ASAP and corrected.


BTW, Running Pegasus Mail with Mercury Mail server. These are both free and can be downloaded at www.pmail.com
« Last Edit: November 24, 2004, 07:00:08 AM by Timon »

shatadal

  • Guest
Re:Avast POP mail with SSL is now broken.
« Reply #1 on: November 24, 2004, 09:20:24 AM »

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re:Avast POP mail with SSL is now broken.
« Reply #2 on: November 24, 2004, 06:52:09 PM »
In short, the avast mail scanner doesn't support SSL (it has never had).

1. interception of the traffic by avast
2. actual scanning of the traffic

Unchecking the SMTP box in Internet Mail provider's settings disables 2 but not 1. This is what you're experiencing.

To prevent avast from doing 1 (which makes sense in your case as you're using SSL), please open the file <avast>\data\avast4.ini, and to the [MailScanner] section, add the following line:

StartSMTP=0

Besides using Outllook and The Bat! for SSL, here is a workaround for SSL and POP3 accounts:
http://forum.avast.com/index.php?board=2;action=display;threadid=8775
to use SSL with other clients and also have the protection of avast.
The best things in life are free.