Author Topic: Avast! Web Shield blocking access to sites  (Read 21423 times)

0 Members and 1 Guest are viewing this topic.

Offline L551

  • Newbie
  • *
  • Posts: 18
Avast! Web Shield blocking access to sites
« on: January 28, 2012, 01:21:52 PM »
Hello there. I have noticed that when Avast's web shield is enabled, it will block access to certain sites. Not all, though. Now this wouldn't be a problem if it were blocking access to bad sites, that would be a good thing. However, when it is active it will block many legitimate sites from being accessed.

These include the avast forums, the mozilla addons site, some reading sites, and some others I can't quite remember at the present time. Avast doesn't give any sort of notification when this happens, so I assume it is a bug of sorts.

Any help would be appreciated, I have turned off Avast's web shield for the time being as a workaround.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67274
Re: Avast! Web Shield blocking access to sites
« Reply #1 on: January 28, 2012, 05:23:04 PM »
avast! blocks all sites infected it can detect.
It does not block legitimate sites (unless by mistake). They are far from being a lot. You must know and be sure that a lot of "legitimate" sites are hacked and got infected.
Turning off the Web Shield is not recommended at all...

Post dead links to these sites please (change http for hxxp, for instance or add spaces between the url).
Quote
The vast majority of malware today is distributed over the web, mostly by means of hacked (otherwise legitimate) sites. The attacker usually injects malicious some scripts into some (or all) pages on the site, waiting for an unsuspecting user to visit the site and possible infect his/her machine.

And this is where avast’s detection capabilities really excel. Its abilities to detect these web-based malicious scripts are second to none, and thanks to the Web Shield and Script Blocking providers, they are used exactly when needed, doing an excellent job stopping the web-based malware right on the entry point.
The best things in life are free.

Offline L551

  • Newbie
  • *
  • Posts: 18
Re: Avast! Web Shield blocking access to sites
« Reply #2 on: January 28, 2012, 09:03:21 PM »
If you read, I said it was blocking access to legitimate sites. Now, if you want to go and say these very forums are bad, which I am unable to access when the web shield is active, please do.

I am also unable to access the mozilla addons while it is active.

Trying to access those with the web shield enabled will give me "The server closed the connection without sending any data."

There is no log or notification from avast whatsoever when this happens.

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 67895
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Avast! Web Shield blocking access to sites
« Reply #3 on: January 28, 2012, 09:09:45 PM »
If you read, I said it was blocking access to legitimate sites. Now, if you want to go and say these very forums are bad, which I am unable to access when the web shield is active, please do.

Well, nobody said so.
Interesting is that nobody else has this problem..!! ;)
Let's start with some basic questions:
Which avast!..?? (Free/Pro/IS)
Which version..??
OS..?? (32/64 Bit - which SP)
Other security related software installed..??
Win 8.1 [x64] - Avast PremSec 20.10.2439.Beta#2 [UI.580] - CC 5.74 - EEK - FF ESR 78.5 [NS/AOS/uBO/PB] - TB 78.5 - SB/CP/SL/DU.B
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline L551

  • Newbie
  • *
  • Posts: 18
Re: Avast! Web Shield blocking access to sites
« Reply #4 on: January 28, 2012, 09:13:30 PM »
If you read, I said it was blocking access to legitimate sites. Now, if you want to go and say these very forums are bad, which I am unable to access when the web shield is active, please do.

Well, nobody said so.
Interesting is that nobody else has this problem..!! ;)
Let's start with some basic questions:
Which avast!..?? (Free/Pro/IS)
Which version..??
OS..?? (32/64 Bit - which SP)
Other security related software installed..??

Well, considering this is the Avast Mac forum... which it seems a lot of people aren't aware.

Avast! Mac Beta
1.0 35889b
OSX 10.6.8
No other security.

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 67895
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Avast! Web Shield blocking access to sites
« Reply #5 on: January 28, 2012, 09:20:38 PM »
Well, considering this is the Avast Mac forum... which it seems a lot of people aren't aware.

Well, I know that this is the Mac section, but you would wonder how often people post in the wrong section. ;) And as your initial post didn't include any specs...
Anyway, as you posted in the right section, I leave you to the Mac guys.
Good luck..!
Win 8.1 [x64] - Avast PremSec 20.10.2439.Beta#2 [UI.580] - CC 5.74 - EEK - FF ESR 78.5 [NS/AOS/uBO/PB] - TB 78.5 - SB/CP/SL/DU.B
Deutschsprachiger Bereich -> Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline tumic

  • Moderator
  • Advanced Poster
  • *
  • Posts: 724
Re: Avast! Web Shield blocking access to sites
« Reply #6 on: January 30, 2012, 12:52:02 PM »
Hello there. I have noticed that when Avast's web shield is enabled, it will block access to certain sites. Not all, though. Now this wouldn't be a problem if it were blocking access to bad sites, that would be a good thing. However, when it is active it will block many legitimate sites from being accessed.

These include the avast forums, the mozilla addons site, some reading sites, and some others I can't quite remember at the present time. Avast doesn't give any sort of notification when this happens, so I assume it is a bug of sorts.

Any help would be appreciated, I have turned off Avast's web shield for the time being as a workaround.

We need the exact URLs that seem to be blocked to have a look at it.

Offline logos

  • Avast Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 9442
Re: Avast! Web Shield blocking access to sites
« Reply #7 on: January 30, 2012, 12:57:17 PM »
I've never seen the web shield block a legit site, never (from a PC at least ;D ) ... but yeah as said provide the URLs ;)
w7 - ais7

Offline L551

  • Newbie
  • *
  • Posts: 18
Re: Avast! Web Shield blocking access to sites
« Reply #8 on: January 30, 2012, 08:28:50 PM »
Please remember, Avast! Does NOTcome up with any bubble/notification/whatever you want to call it when it happens. The site will simply not load and come up with the error "The server closed the connection without sending any data."

There are also no logs in avast about it. But, turning off the web shield works.

http://forum.avast.com (Unable to access while webshield is active)
http://addons.mozilla.org (Same)
http://www.fimfiction.net (Again, same)

Offline logos

  • Avast Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 9442
Re: Avast! Web Shield blocking access to sites
« Reply #9 on: January 30, 2012, 08:53:06 PM »
then there must be something wrong in the Mac version, the devs should have a look. As you know, most of us run PCs so we can't even try to reproduce your issue. May be try to pm another MacOS user about that and ask him if he's got the issue too, that would be a first step in the right direction.
w7 - ais7

Offline ericthebunny

  • Newbie
  • *
  • Posts: 7
Re: Avast! Web Shield blocking access to sites
« Reply #10 on: January 30, 2012, 10:48:58 PM »
@logos - I was under the impression that this was an Avast for Mac users forum?

@L551 - using Lion latest and Chrome beta latest I have no problem accessing these site, have also tried with Safari and FF latest beta and again have had had no problems accessing the site you list. I appreciate that this won't help you in any way...

Offline logos

  • Avast Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 9442
Re: Avast! Web Shield blocking access to sites
« Reply #11 on: January 30, 2012, 10:53:34 PM »
@logos - I was under the impression that this was an Avast for Mac users forum?

how strange, I was under this impression too ;D ... look it's taking ages until a Mac user pops in finally, so don't be surprised when some of us evil PC addicts interfere once in a while ::)
w7 - ais7

Offline tumic

  • Moderator
  • Advanced Poster
  • *
  • Posts: 724
Re: Avast! Web Shield blocking access to sites
« Reply #12 on: January 31, 2012, 01:05:24 PM »
Please remember, Avast! Does NOTcome up with any bubble/notification/whatever you want to call it when it happens. The site will simply not load and come up with the error "The server closed the connection without sending any data."

There are also no logs in avast about it. But, turning off the web shield works.

http://forum.avast.com (Unable to access while webshield is active)
http://addons.mozilla.org (Same)
http://www.fimfiction.net (Again, same)


I'm sorry, but I'm not able to reproduce this. All the listed URLs are loading fine with the webshield enabled.

Offline L551

  • Newbie
  • *
  • Posts: 18
Re: Avast! Web Shield blocking access to sites
« Reply #13 on: January 31, 2012, 01:50:11 PM »
Please remember, Avast! Does NOTcome up with any bubble/notification/whatever you want to call it when it happens. The site will simply not load and come up with the error "The server closed the connection without sending any data."

There are also no logs in avast about it. But, turning off the web shield works.

http://forum.avast.com (Unable to access while webshield is active)
http://addons.mozilla.org (Same)
http://www.fimfiction.net (Again, same)



I'm sorry, but I'm not able to reproduce this. All the listed URLs are loading fine with the webshield enabled.

That's weird... because it's still doing it to me.
« Last Edit: January 31, 2012, 02:01:25 PM by L551 »

Offline ericthebunny

  • Newbie
  • *
  • Posts: 7
Re: Avast! Web Shield blocking access to sites
« Reply #14 on: January 31, 2012, 04:32:37 PM »
Just a thought - are you using NoScript ?