Author Topic: VPSUPD.EXE "ha smesso di funzionare"  (Read 5662 times)

0 Members and 1 Guest are viewing this topic.

Offline Marcolazzo

  • Newbie
  • *
  • Posts: 4
VPSUPD.EXE "ha smesso di funzionare"
« on: January 23, 2012, 06:32:20 PM »
Ho installato con successo la versione 6.0.1125.0 di Avast! Free Antivirus in un netbook con Windows 7 Starter SP1 e precedente Norton Internet Security 2011 (correttamente disinstallato con Unistall e Removal Tool).
Collego raramente il netbook a internet ma prima di farlo ho tentato invano di aggiornare le definizioni dei virus, ferme al 10/5/2011, eseguendo il vpsupd.exe (non vorrei beccarmi un virus proprio mentre aggiorno l'antivirus!).

Purtroppo, nonostante ripetuti tentativi, ottengo sempre il messaggio di errore "avast.setup ha smesso di funzionare" e a volte il successivo "programma non installato correttamente".

Ho provato di tutto:
- esegui come Win XP SP2,
- disabilito il modulo di auto-difesa di avast!,
- disabilito protezione avast!,
- arresto servizi e termino processi avast! (da gestione attività Windows),
- avvio del PC in "modalità provvisoria".

Niente da fare: sempre "avast.setup ha smesso di funzionare".

Successivamente ho scaricato un nuovo vpsupd e con questo ottengo un errore diverso: "This VPS database requires latest program version".

Sarà possibile scompattare manualmente le definizioni nella cartella di destinazione ?

Quale altro tentativo posso fare prima di tentare l'aggiornamento on-line ?

Grazie.

Offline giogio

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 4115
Re: VPSUPD.EXE "ha smesso di funzionare"
« Reply #1 on: January 23, 2012, 07:51:47 PM »
Ciao,
Ho installato con successo la versione 6.0.1125.0 di Avast! Free Antivirus..
Scarica l'ultima versione 6.0.1367 qui e installala
http://www.avast.com/it-it/free-antivirus-download

Successivamente ho scaricato un nuovo vpsupd e con questo ottengo un errore diverso: "This VPS database requires latest program version".

il VPS richiede l'ultima versione di avast installata.
Facci sapere poi se hai ancora problemi.


(non vorrei beccarmi un virus proprio mentre aggiorno l'antivirus!).
se usi il metodo di aggiornamento dall'interno del programma non ti becchi nessun virus!
(MANUTENZIONE->AGGIORNAMENTO->AGGIORNA IL PROGRAMMA)
« Last Edit: January 23, 2012, 07:54:23 PM by giogio »
Prima di scrivere sul forum per favore leggi le istruzioni qui https://forum.avast.com/index.php?topic=144453.0
Non inviatemi MP per supporto,grazie-No support PM please
Home: E8400-4GB RAM-500GB HDD-Win10.0.15063x64-Avast! Free 17.3.2291-CryptoPrevent-MBAM 2.2free-Chrome 57(uBlock origin)-TB52
Work: i5-2400-4GB RAM-500GB HDD-Win 7sp1x64-Avast!Business Security 12.3.2515,     
Cloud Console 2.18
-FF52-TB52

Offline Marcolazzo

  • Newbie
  • *
  • Posts: 4
Re: VPSUPD.EXE "ha smesso di funzionare"
« Reply #2 on: January 24, 2012, 07:07:07 PM »
Ok giogio,
comincio con la cosa più elementare: l'aggiornamento delle definizioni dal programma stesso !

Forse è una mia fissazione, una precauzione eccessiva, ma quando le definizioni sono troppo vecchie come in questo caso (nuovo antivirus) o quando ho preso il netbook (Norton preinstallato) scarico sempre da un altro PC l'aggiornamento per sentirmi un po' più protetto...

Faccio qualche prova poi ti faccio sapere.

Ciao.

Offline giogio

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 4115
Re: VPSUPD.EXE "ha smesso di funzionare"
« Reply #3 on: January 24, 2012, 08:07:50 PM »
Prova e facci sapere..
Oppure scarica dal PC "protetto" la nuova versione insieme al VPS aggiornato
ciao
Prima di scrivere sul forum per favore leggi le istruzioni qui https://forum.avast.com/index.php?topic=144453.0
Non inviatemi MP per supporto,grazie-No support PM please
Home: E8400-4GB RAM-500GB HDD-Win10.0.15063x64-Avast! Free 17.3.2291-CryptoPrevent-MBAM 2.2free-Chrome 57(uBlock origin)-TB52
Work: i5-2400-4GB RAM-500GB HDD-Win 7sp1x64-Avast!Business Security 12.3.2515,     
Cloud Console 2.18
-FF52-TB52

Offline Marcolazzo

  • Newbie
  • *
  • Posts: 4
Re: VPSUPD.EXE "ha smesso di funzionare"
« Reply #4 on: January 28, 2012, 07:00:13 PM »
Ho aggiornato senza problemi le definizioni dei virus on-line.
Aspetto un paio di giorni per essere sicuro di trovare delle definizioni nuove poi scarico il VPS con l'altro PC.
Eseguo e ottengo il solito messaggio: "This VPS database requires latest program version".

Certo che è strano: è possibile aggiornare la vers. 4, 5, la 6.0.1367 e non la 6.0.1125 ?
Eppure sono entrambi 6 !
Penso che sia la mia installazione ad avere qualche problema.

Per il momento vado avanti così, poi aggiornerò il programma da avast stesso o meglio disinstallo tutto e installo il nuovo.

Vedo dai post che altri hanno problemi con l'aggiornamento automatico (firewall o altro) e sono costretti ad aggiornare manualmente,
io sono l'unico ad avere il problema opposto ;).

Ciao e grazie ancora.

Offline giogio

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 4115
Re: VPSUPD.EXE "ha smesso di funzionare"
« Reply #5 on: January 28, 2012, 08:03:53 PM »
Certo che è strano: è possibile aggiornare la vers. 4, 5, la 6.0.1367 e non la 6.0.1125 ?
Eppure sono entrambi 6 !
Non ho provato ma se esce quel messaggio di errore vuol dire che sia della 4, che la 5 e la 6 devi avere l'ultima versione stabile, ovvero:
Per la versione 4: 4.8.1368
Per la versione 5: 5.1.889
Per la versione 6: 6.0.1367
Credo che avast lo fa in modo da far aggiornare i pc all'ultima versione stabile.

poi aggiornerò il programma da avast stesso
E' la cosa migliore da fare..

ciao
Prima di scrivere sul forum per favore leggi le istruzioni qui https://forum.avast.com/index.php?topic=144453.0
Non inviatemi MP per supporto,grazie-No support PM please
Home: E8400-4GB RAM-500GB HDD-Win10.0.15063x64-Avast! Free 17.3.2291-CryptoPrevent-MBAM 2.2free-Chrome 57(uBlock origin)-TB52
Work: i5-2400-4GB RAM-500GB HDD-Win 7sp1x64-Avast!Business Security 12.3.2515,     
Cloud Console 2.18
-FF52-TB52

Offline Marcolazzo

  • Newbie
  • *
  • Posts: 4
Re: VPSUPD.EXE "ha smesso di funzionare"
« Reply #6 on: February 23, 2012, 05:54:47 PM »
Sono tornato ! (finalmente).

Scusa giogio se non mi sono fatto più sentire, ma avast si aggiorna così bene in automatico che non ho più sentito la necessità del file VPS.

Comunque, almeno per curiosità, ho aggiornato avast dalla V.6.0.1125 alla 6.0.1367 e, dopo alcuni giorni, ho scaricato un nuovo VPSUPD con il quale ho aggiornato con successo le definizioni. :D

È proprio come dicevi tu: l'aggiornamento off-line richiede l'ultima sotto-versione del programma.
Non ho provato ma se esce quel messaggio di errore vuol dire che sia della 4, che la 5 e la 6 devi avere l'ultima versione stabile, ovvero:
Per la versione 4: 4.8.1368
Per la versione 5: 5.1.889
Per la versione 6: 6.0.1367
Credo che avast lo fa in modo da far aggiornare i pc all'ultima versione stabile.

Ciao e grazie ancora dei consigli.
« Last Edit: February 23, 2012, 05:57:51 PM by Marcolazzo »

Offline giogio

  • Avast Evangelist
  • Massive Poster
  • ***
  • Posts: 4115
Re: VPSUPD.EXE "ha smesso di funzionare"
« Reply #7 on: February 23, 2012, 08:04:42 PM »
Di niente!
Ciao e guarda che è stata rilasciata la nuova versione 7.0.1407!

Ciao
Prima di scrivere sul forum per favore leggi le istruzioni qui https://forum.avast.com/index.php?topic=144453.0
Non inviatemi MP per supporto,grazie-No support PM please
Home: E8400-4GB RAM-500GB HDD-Win10.0.15063x64-Avast! Free 17.3.2291-CryptoPrevent-MBAM 2.2free-Chrome 57(uBlock origin)-TB52
Work: i5-2400-4GB RAM-500GB HDD-Win 7sp1x64-Avast!Business Security 12.3.2515,     
Cloud Console 2.18
-FF52-TB52