Author Topic: avast 7.0.1426 sandboxie bug  (Read 4487 times)

0 Members and 1 Guest are viewing this topic.

LunarWolf

  • Guest
avast 7.0.1426 sandboxie bug
« on: April 17, 2012, 10:39:30 PM »
When will avast solve the sandboxie bug where after closing the sandboxed program, windows will give a werfault error?

Windows 7 32-bit

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89421
  • No support PMs thanks
Re: avast 7.0.1426 sandboxie bug
« Reply #1 on: April 17, 2012, 10:54:58 PM »
I don't know what this but is as my netbook has win7 Starter 32bit edition and I don't have any problem when using sandboxie on the occasion I use it for firefox 11.0.

What version of sandboxie are you using (mine is 3.62)?
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.6.6121 (build 24.6.9241.848) UI 1.0.809/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

LunarWolf

  • Guest
Re: avast 7.0.1426 sandboxie bug
« Reply #2 on: April 17, 2012, 11:04:23 PM »
3.68

If you do a quick search in google, and look in sandboxie forum, many are having the same issue since version 7 was release. Even tzuk mention something about avast memory.

Direct quote from tzuk
Quote
Thank you for the debug log. The log doesn't indicate a specific error in Sandboxie. What I see is that during program termination, an Avast DLL tries to free some memory it has set aside for itself. While freeing the memory, the system memory bookkeeper stumbles upon an inconsistency in the bookkeeping records of memory areas, and the program crashes.
Read here : http://www.sandboxie.com/phpbb/viewtopic.php?p=76925#76925

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89421
  • No support PMs thanks
Re: avast 7.0.1426 sandboxie bug
« Reply #3 on: April 17, 2012, 11:32:12 PM »
I have just updated sandboxie to the 3.68 version and am running it with firefox 11.0 in private browsing on my win7 netbook right now.

I guess I don't come across this Freeing memory issue, whilst I only have 2GB of RAM, it would appear that doesn't cause a problem on that system.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.6.6121 (build 24.6.9241.848) UI 1.0.809/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

LunarWolf

  • Guest
Re: avast 7.0.1426 sandboxie bug
« Reply #4 on: April 25, 2012, 09:37:13 PM »
I already pin point the problem. It is avast behaviour shield which is causing that problem. I stop one shield at a time and run firefox sandboxed (any program will do), all give the error when I close it. (I set sandboxie to auto delete contents when close)

But when I stop the behaviour shield and repeat the process, there was no  error this time. Sandboxie close and delete contents like normal. Hope this helps.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89421
  • No support PMs thanks
Re: avast 7.0.1426 sandboxie bug
« Reply #5 on: April 25, 2012, 10:38:25 PM »
Well generally I don't clear the contents when I close sandboxie.

However I would suggest that you try unchecking the 'Monitor system for unauthorised modifications' option in the Expert Settings, alternatively you can add the sandbox executable to the Trusted processes.

Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.6.6121 (build 24.6.9241.848) UI 1.0.809/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

LunarWolf

  • Guest
Re: avast 7.0.1426 sandboxie bug
« Reply #6 on: April 26, 2012, 04:10:34 AM »
However I would suggest that you try unchecking the 'Monitor system for unauthorised modifications' option in the Expert Settings

That work.

add the sandbox executable to the Trusted processes.
That didn't work.

Any response from avast team on this matter? Am I the only one having this problem? Were they able to reprosuce that error?

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89421
  • No support PMs thanks
Re: avast 7.0.1426 sandboxie bug
« Reply #7 on: April 26, 2012, 01:29:10 PM »
<snip>
add the sandbox executable to the Trusted processes.

That didn't work.
<snip>

It will only work if the autosandbox is actually blocking sandboxie, you would need to check its log file to see if there is an entry for any sandboxie executable. 

Check the C:\ProgramData\AVAST Software\Avast\log\autosandbox.log file, to see if there any entries (probably not or you have entered the incorrect executable in the trusted processes).
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.6.6121 (build 24.6.9241.848) UI 1.0.809/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security