Author Topic: Avast Mail Shield Service Stopped  (Read 10051 times)

0 Members and 1 Guest are viewing this topic.

Offline Alikhan

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2224
Avast Mail Shield Service Stopped
« on: February 23, 2012, 10:28:11 PM »
I was using the RC of Avast and everything was working fine including the mail shield. I then used the avast uninstall utility so I could install the final version. Since I have been installing the final shield my mail shield doesn't work. Please help.

Avast IS - Latest Version
Windows 7 Home Premium 64 bit
Mbam Pro
« Last Edit: February 23, 2012, 10:47:34 PM by Alikhan »
Windows 10 Home 64-bit • Avast Internet Security (latest stable version) • Malwarebytes 3 Premium (latest) • Google Chrome • CCleaner •

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11665
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Avast Mail Shield Service Stopped
« Reply #1 on: February 23, 2012, 10:41:04 PM »
What does "doesn't work" mean, exactly? It says STOPPED? What happens if you try to start it? And does the problem persist even after a reboot?

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.

Offline Alikhan

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2224
Re: Avast Mail Shield Service Stopped
« Reply #2 on: February 23, 2012, 10:43:05 PM »
It basically says "module isn't started". I click fix me and it still stays as service stopped. The fix me button doesn't do anything. I've also now reinstalled and rebooted thrice. I did have my mail shield set up in the RC. By starting it, nothing happens. I've also tried a repair and that also didn't work.
Windows 10 Home 64-bit • Avast Internet Security (latest stable version) • Malwarebytes 3 Premium (latest) • Google Chrome • CCleaner •

Offline logos

  • Avast Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 9443
Re: Avast Mail Shield Service Stopped
« Reply #3 on: February 23, 2012, 10:49:33 PM »
@the OP: the avast uninstall utility doesn't remove the avast folder in program data so, did you remove it manually before installing V7 final? ... if an upgrade process between V7RC and V7 is an issue, it's better to really install V7 from scratch.
w7 - ais7

Offline Alikhan

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2224
Re: Avast Mail Shield Service Stopped
« Reply #4 on: February 23, 2012, 10:50:16 PM »
I deleted the file from ProgramData manually already and have installed from scratch.
Windows 10 Home 64-bit • Avast Internet Security (latest stable version) • Malwarebytes 3 Premium (latest) • Google Chrome • CCleaner •

Offline ady4um

  • Massive Poster
  • ****
  • Posts: 2667
Re: Avast Mail Shield Service Stopped
« Reply #5 on: February 23, 2012, 10:53:45 PM »
I deleted the file from ProgramData manually already and have installed from scratch.

And it works now? If it doesn't, then instead of "repair", try "change", select all the components and "next", and when it finishes, reboot. Please report back.
ADD/REMOVE PROGS -> avast -> CHANGE/REMOVE -> REPAIR & REBOOT
Avast! 7 FAQ | FAQ & KB | Docs | Removal Utils | Configure Mail Shield | report FP | License Registration | UNSECURED?

Offline logos

  • Avast Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 9443
Re: Avast Mail Shield Service Stopped
« Reply #6 on: February 23, 2012, 10:57:22 PM »
I deleted the file from ProgramData manually already and have installed from scratch.

And it works now? If it doesn't, then instead of "repair", try "change", select all the components and "next", and when it finishes, reboot. Please report back.

that's the thing, doesn't seem to work after that. And on a side note, the times I've had issues with a mail shield not running (during the beta testing), repairing, removing, re-installing the module... didn't change anything. I had to re-install completely. Same thing when it happens with the firewall, but that's not new. You never know why it happened ;D ... as it starts working again following an install - apparently - in the same conditions as when it didn't work.
« Last Edit: February 23, 2012, 10:59:29 PM by logos »
w7 - ais7

Offline Alikhan

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2224
Re: Avast Mail Shield Service Stopped
« Reply #7 on: February 23, 2012, 11:15:47 PM »
Done another clean install, removed the programdata avast folder. Still doesn't work. Done everything which has been mentioned from the above posts. Anything else?
« Last Edit: February 23, 2012, 11:18:25 PM by Alikhan »
Windows 10 Home 64-bit • Avast Internet Security (latest stable version) • Malwarebytes 3 Premium (latest) • Google Chrome • CCleaner •

Offline logos

  • Avast Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 9443
Re: Avast Mail Shield Service Stopped
« Reply #8 on: February 23, 2012, 11:25:44 PM »
Done another clean install, removed the programdata avast folder. Still doesn't work. Done everything which has been mentioned from the above posts. Anything else?

that's weird, the devs might want to get some of your logs ... Vlk ?
w7 - ais7

Offline Alikhan

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2224
Re: Avast Mail Shield Service Stopped
« Reply #9 on: February 23, 2012, 11:30:53 PM »
I know it is wierd. How would I even get logs?
Windows 10 Home 64-bit • Avast Internet Security (latest stable version) • Malwarebytes 3 Premium (latest) • Google Chrome • CCleaner •

Offline logos

  • Avast Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 9443
Re: Avast Mail Shield Service Stopped
« Reply #10 on: February 23, 2012, 11:34:20 PM »
I know it is wierd. How would I even get logs?

the mail shield log is in Avast program data folder, with other logs in a folder called "logs" ;D ... but wait until a dev asks you, they may need more than just this log.... setup log etc...
w7 - ais7

Offline ady4um

  • Massive Poster
  • ****
  • Posts: 2667
Re: Avast Mail Shield Service Stopped
« Reply #11 on: February 23, 2012, 11:41:35 PM »
Done another clean install, removed the programdata avast folder. Still doesn't work. Done everything which has been mentioned from the above posts. Anything else?

Sorry I have to ask now, but I want the info to be perfectly clear for the devs.

Is the mail shield:

1_ "unstable" and can't be started nor installed?
2_ showed as installed, but can't be started?
3_ started but not scanning ( 0/0 )?
ADD/REMOVE PROGS -> avast -> CHANGE/REMOVE -> REPAIR & REBOOT
Avast! 7 FAQ | FAQ & KB | Docs | Removal Utils | Configure Mail Shield | report FP | License Registration | UNSECURED?

Offline Alikhan

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2224
Re: Avast Mail Shield Service Stopped
« Reply #12 on: February 23, 2012, 11:41:55 PM »
I have now just realised my Web Shield is running but it is NOT scanning anything.
Windows 10 Home 64-bit • Avast Internet Security (latest stable version) • Malwarebytes 3 Premium (latest) • Google Chrome • CCleaner •

Offline Alikhan

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2224
Re: Avast Mail Shield Service Stopped
« Reply #13 on: February 23, 2012, 11:45:04 PM »
2_ showed as installed, but can't be started? is the answer.

Here is a screenshot of the mail shield...

http://tinypic.com/view.php?pic=1z6b9lf&s=5
Windows 10 Home 64-bit • Avast Internet Security (latest stable version) • Malwarebytes 3 Premium (latest) • Google Chrome • CCleaner •

Offline ady4um

  • Massive Poster
  • ****
  • Posts: 2667
Re: Avast Mail Shield Service Stopped
« Reply #14 on: February 23, 2012, 11:50:52 PM »
If you go to "summary -> current status", can you turn it on? Try "turn on", wait a minute and reboot so to see if the status is still saved.

To be clear, it should say specifically that the mail shield is turned off (look down the window). If it is not there, then use the "general turn on" to the side of "real time shields".
ADD/REMOVE PROGS -> avast -> CHANGE/REMOVE -> REPAIR & REBOOT
Avast! 7 FAQ | FAQ & KB | Docs | Removal Utils | Configure Mail Shield | report FP | License Registration | UNSECURED?