Author Topic: Avast is broken... any solutions?  (Read 10473 times)

0 Members and 1 Guest are viewing this topic.

DarkRadience

  • Guest
Re: Avast is broken... any solutions?
« Reply #15 on: February 25, 2012, 11:04:02 PM »
Why do most of you think its complex?
Step one
http://www.avast.com/uninstall-utility

Step two once rebooted
Avast! Free Antivirus 7.0.1407
http://www.filehippo.com/download_avast_antivirus/
Run the installer and use the custom install option of you wish, I recommended it always.
« Last Edit: February 25, 2012, 11:07:16 PM by DarkRadience »

Paul Rodgers

  • Guest
Re: Avast is broken... any solutions?
« Reply #16 on: February 25, 2012, 11:10:21 PM »
Why do most of you think its complex?
Step one
http://www.avast.com/uninstall-utility

Step two once rebooted
Avast! Free Antivirus 7.0.1407
http://www.filehippo.com/download_avast_antivirus/
Run the installer and use the custom install option of you wish, I recommended it always.

This is the proper way to fix this issue. I would also suggest after running the uninstaller (and restarting) that you use a program like ccleaner to clean up the registry.

itsjustme2

  • Guest
Re: Avast is broken... any solutions?
« Reply #17 on: February 25, 2012, 11:12:54 PM »
Why do most of you think its complex?
Step one
http://www.avast.com/uninstall-utility

Step two once rebooted
Avast! Free Antivirus 7.0.1407
http://www.filehippo.com/download_avast_antivirus/
Run the installer and use the custom install option of you wish, I recommended it always.
this uninstaller is for avast 6, avast 7 uninstaller isn't out yet, it may cause an unknown glitches.

Paul Rodgers

  • Guest
Re: Avast is broken... any solutions?
« Reply #18 on: February 25, 2012, 11:14:41 PM »
Why do most of you think its complex?
Step one
http://www.avast.com/uninstall-utility

Step two once rebooted
Avast! Free Antivirus 7.0.1407
http://www.filehippo.com/download_avast_antivirus/
Run the installer and use the custom install option of you wish, I recommended it always.
this uninstaller is for avast 6, avast 7 uninstaller isn't out yet, it may cause an unknown glitches.

I have used the installer on a bad v7 install and it does work.

lhui

  • Guest
Re: Avast is broken... any solutions?
« Reply #19 on: February 25, 2012, 11:21:36 PM »
Well, now I'm stumped about that. I'll try to find someone else that may know how to proceed.

Hopefully someone will be able to solve this problem. Starting to no like Avast... its been giving me problems for the last year.

DarkRadience

  • Guest
Re: Avast is broken... any solutions?
« Reply #20 on: February 25, 2012, 11:22:27 PM »
Did you read my post?

iroc9555

  • Guest
Re: Avast is broken... any solutions?
« Reply #21 on: February 25, 2012, 11:22:48 PM »
this uninstaller is for avast 6, avast 7 uninstaller isn't out yet, it may cause an unknown glitches.

That aswclear.exe is for Avast! 7, 6, 5 and so on. It is the right uninstall tool.

lhui

  • Guest
Re: Avast is broken... any solutions?
« Reply #22 on: February 25, 2012, 11:42:11 PM »
Did you read my post?
Did not know there was a second page.

It seems to have uninstalled Avast fine. Now I am reinstalling, hope that works out fine too.

ady4um

  • Guest
Re: Avast is broken... any solutions?
« Reply #23 on: February 25, 2012, 11:53:46 PM »
Well, now I'm stumped about that. I'll try to find someone else that may know how to proceed.

Hopefully someone will be able to solve this problem. Starting to no like Avast... its been giving me problems for the last year.

Well, I don't know which problems you had. I don't even know why or what is preventing you from changing those settings. It sounds like if you were not an administrator (or part of the administrators group).

@all

In theory, the following procedure should work:

1_ Download http://www.avast.com/uninstall-utility and the avast installer (so to reinstall anew after the procedure).
2_ Boot into Windows Safe Mode (WSM for short here).
3_ Uninstall avast using "Add/Remove Programs", if possible.
4_ Reboot again into WSM.
5_ Run aswclear for avast 7.
6_ Reboot again into WSM.
7_ Run aswclear for avast 6.
8_ If you ever had installed or updated from other older avast versions (like v.5. or even v.4.), then repeat the last 2 steps - ie the reboot into WSM and run aswclear - selecting each time each version of avast.
9_ Reboot again into WSM.
10_ Set Windows Explorer to show all "System" and Hidden" files, and to show known files' extensions.
11_ Search for any folder with a name containing "avast*" and/or "alwil*". For example, "Alwil Software", or "avast5".
12_ Delete those folders found in the previous step.
13_ Search for files starting with "asw*" inside "C:/windows/system32/drivers/".
14_ For each file found in the previous step, right click -> properties. If the file is from "Alwil" or "Avast", delete the file.
15_ Reboot into Windows Normal Mode.
16_ Select the setup.exe installer of avast. Right click on it -> properties -> UNBLOCK (if the button is not grayed out).
17_ Select the setup.exe installer of avast. Right click on it -> "Run as administrator" if such option is available. If it is not, the simply "Run".
18_ Once the installation procedure finishes, wait until the HDD led stops blinking "like crazy" (as oppose to blinking infrequently as usual).
19_ Reboot.
20_ After the first reboot, use the system as usual. Test it. Avoid rebooting immediately. Keep testing. No need for immediate registration nor avast accounts. Leave it for when all is fine and really working correctly.
21_ After a couple of hours, reboot and test if any strange quirks show up.
22_ Report back.

DarkRadience

  • Guest
Re: Avast is broken... any solutions?
« Reply #24 on: February 25, 2012, 11:59:21 PM »
Hope any of the posts here help, and as always please report back :)

lhui

  • Guest
Re: Avast is broken... any solutions?
« Reply #25 on: February 26, 2012, 12:02:02 AM »
Hope any of the posts here help, and as always please report back :)

Your method was simple and it seems to have worked. I will wait a few hours or days and see if it stays fine.

DarkRadience

  • Guest
Re: Avast is broken... any solutions?
« Reply #26 on: February 26, 2012, 12:03:49 AM »
Hope it will :) enjoy your Avast and good luck.
EDIT: You might also mark the topic as [Solved] by editing you first posts title.