Author Topic: Upgrading to Avast 7x results in losing control of files/folders (Access Denied)  (Read 36294 times)

0 Members and 1 Guest are viewing this topic.

bellsal

  • Guest
I am having the same issue.  After updating to Avast 7.0.1407, I have a broken Windows XP environment.  I cannot rename any file or folder.  Also, I cannot delete or drag to the recycle bin any file or folder.  Luckly I imaged my hard drive with Clonezilla, and I will go back to my previous working state (this means that I will stay with Avast 6.x) until this issue is resolved.  I would like to help Avast find a solution as quickly as possible as I trust their product, so if you have any questions, please let me know.  Thanks.

XanderK

  • Guest
All --

As of yesterday evening (Saturday March 3rd, Amsterdam time) did I re-gain control of my XK SP3 environment. I'm able to delete/rename folders and am able to save/rename/delete files.

I didn't change anything on my environment, didn't install and/or remove programs and didn't change the setup of my Avast 7.0.1407 environment. I did ofcourse receive new engine and virus definitions since my last install on March 1st 2012 however can't imagine this to have had a postive affect on the Access Denied errors.

Any input to what might have caused the initial Access Denied errors OR towards the "unknown" fix would be appreciated.

Offline bob3160

  • Avast √úberevangelist
  • Probably Bot
  • *****
  • Posts: 46606
  • 61 Years of Happiness
    • bob3160 Protecting Yourself, Your Computer and, Your Identity
All --

As of yesterday evening (Saturday March 3rd, Amsterdam time) did I re-gain control of my XK SP3 environment. I'm able to delete/rename folders and am able to save/rename/delete files.

I didn't change anything on my environment, didn't install and/or remove programs and didn't change the setup of my Avast 7.0.1407 environment. I did ofcourse receive new engine and virus definitions since my last install on March 1st 2012 however can't imagine this to have had a postive affect on the Access Denied errors.

Any input to what might have caused the initial Access Denied errors OR towards the "unknown" fix would be appreciated.
Most likely a VPS update that addressed the problem you and others reported. The developers do read this forum.  :)
Glad to hear that another problem has been solved.
Free avast! Security Seminar: http://bit.ly/2N1eaR2  -  Important: http://www.organdonor.gov/ -- My Web Site: http://bob3160.strikingly.com/ - Win 11 Pro v21H2 64bit, 16 Gig Ram, 1TB SSD, Avast One 21.11, How to Successfully Install Avast http://goo.gl/VLXdeRepair & Clean Install https://goo.gl/t7aJGq -- My Online Activity https://bit.ly/BobGInternet

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11809
    • AVAST Software
Well... those things happen, but I'm afraid there wasn't any fix regarding this mysterious problem (or at least I don't know about it, which I probably would if it were the case). We haven't identified the problem yet - any attempts to simulate the behavior were unsuccessful so far.

So, either the change was caused by something very subtle and basically unrelated (the virus definitions have stopped/started scanning some file, which changed the timing of the boot just a bit, maybe caused two drivers or programs to be loaded in an opposite order, compared to the previous state... and the previously occurring conflict disappeared. If timing is the case, the problem can appear again any time, of course.) - or, some other program, maybe the one related to the conflict, has updated?
(Just to be sure - have you booted your machine before the problem disappeared, or are you saying that it started to work in the middle of a running Windows session?)


But, there's one interesting thing here... when you say that of course you received VPS updates. That means that at least avast! was able to write to the disk (which I wouldn't consider for granted in this strange state). Also, when you created the msinfo32 log - did you save the output on your disk, or somewhere else?
Basically, my question is what were the locations you were unable to write to - whether it was really everything, or just a specific drive, folder, maybe only when performed under a specific user account?
Regarding the operations - wasn't it maybe only rename/delete that was prevented, and creating new files might actually be possible? (I wouldn't rely e.g. on MS Office behavior - when saving a file there, it might actually first create a temporary file and then try to rename it).
Thanks.

XanderK

  • Guest
Igor --

In regards to your questions:

* I haven't updated/installed any other program and/or device driver since I installed Avast 7.x on my computer. To my knowledge the only program which automatically updated (and INSTALLED new defenitions) was Avast.
* My computer started to behave "normal" in the middle of a running Windows session and just to be sure it continued to work normally did I reboot my computer. After the reboot it continued to work normal.
* Creating the file fltmc.txt was done while using the command prompt.
* Creating the files msinfo32.nfo and msinfo32_zip.txt was indeed not easy; I had to copy (I'm not exactly sure how however it was not "easy": either using Total Commander or command prompt) an existing file to msinfo32.nfo and msinfo32_zip.txt before I was able to create the output.
* I only have one user account and was not able to perform the actions on any of my local drives AND not on any of my removable storage. Not even on a hot-pluggable USB stick.
* Using Explorer was I not able to create "New Folders" on any of my drives; it did create the folders but always using "New Folder"; "New Folder (copy1); etc. I was not able to rename the New Folder to a normal name. Also was I not able to move files.
* Using Total Commander was I able to create new folders using any name however was not able to rename those newly created folders to another name on any of my drives. Also was I not able to move files. I think I was able to copy files however I was not able to delete them.
* Using PAINT and OUTLOOK was I not able to save NEW files.

Please let me know if you have more questions since it all sounds very strange to me and if I should de-install followed by reinstalling Avast 7.x to determine if the initial problems occur again or are truely "solved"?

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11809
    • AVAST Software
You are certainly not the only one for whom it sounds strange.
I'll wait for suggestions from the driver guys, that's not really my area of expertise. But it indeed looks like creating new files was possible, while renaming/deleting was not. That most likely rules out one of the hypotheses that avast! self-defense might have something to do with that.

Offline essexboy

  • Malware removal instructor
  • Avast √úberevangelist
  • Probably Bot
  • *****
  • Posts: 40610
  • Dragons by Sasha
    • Malware fixes
It may be something system specific.  I have just loaded a fresh XP SP3 VM and installed avast free on it.  None of those problems were experienced, however as of the moment I have no other external progammes loaded

XanderK

  • Guest
To IronMan1968, hayley3 and bellsal:

Are you still experiencing the strange behavior?

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11809
    • AVAST Software
Yep... if anybody else is experiencing the problem, please let us know, preferably with the msinfo result.
Finding the common things (installed software, configuration, ...) might help us get on the right track.
Thanks.

XanderK

  • Guest
Igor:

I upgraded from 7.0.1407 to 7.0.1426 and the initial reported problems regarding not being able to save and delete files as well as not being able to rename and delete directories reappeared again! Almost all file/folder actions result in ACCESS DENIED or errors like "Access denied: Disk may be write protected or file in use" while I am able to perform these tasks using the command prompt.

Please help, Xander


nord

  • Guest

Any chance for you to provide a link to Avast Internet Security version 6.0.1367.0 so I'm able to secure my computer? I can't do any work on my computer and as such do I need to remove Avast 7.x but I don't want to be unsecured! Last resort would be to move to another security tool like MSE, but I don't want to get rid of my Avast.

Please help

I usually use FileHippo to find older versions, but that link was bad a few days ago. Haven't checked recently to see if it is fixed. So I used this link to get version 6.

http://www.oldapps.com/avast_antivirus.php

Scroll down and you'll find the old versions.


Offline Spec8472

  • Avast team
  • Sr. Member
  • *
  • Posts: 261
Hi XanderK,
I am trying to solve this issue and it seems to me that this must be some file system filter conflict, the most suspicios filters running on your system are nlem32nt and dlaifs_m. Would you be so kind and rename files c:\Windows\System32\drivers\nlem32nt.sys and c:\Windows\System32\dla\dlaifs_m.sys to prevent them from loading, then reboot and report if problem is gone or not. Or are you willing to provide me a TeamViewer session?

Thx

Igor:

I upgraded from 7.0.1407 to 7.0.1426 and the initial reported problems regarding not being able to save and delete files as well as not being able to rename and delete directories reappeared again! Almost all file/folder actions result in ACCESS DENIED or errors like "Access denied: Disk may be write protected or file in use" while I am able to perform these tasks using the command prompt.

Please help, Xander

skipm

  • Guest
I am also experiencing the same issue with one of my end user machines running Windows XP SP3. I have re-installed version 6 for the time being. I will be monitoring this thread for a fix.

Offline Spec8472

  • Avast team
  • Sr. Member
  • *
  • Posts: 261
Hi skipm,

please can you provide me output of fltmc.exe command from afflicted machine?


I am also experiencing the same issue with one of my end user machines running Windows XP SP3. I have re-installed version 6 for the time being. I will be monitoring this thread for a fix.

skipm

  • Guest
Here is the results:



Filter Name                     Num Instances Frame
------------------------------  ------------- -----
aswMon2                                      <Legacy>                     
DLAIFS_M                                     <Legacy>                     
aswFsBlk                                1       0
WavxDMgr                                3       0
aswSnx                                  1       0
sr                                           <Legacy>