Author Topic: Why is AVAST reporting back every application I run?  (Read 4679 times)

0 Members and 1 Guest are viewing this topic.

Offline jamesc

  • Newbie
  • *
  • Posts: 2
Why is AVAST reporting back every application I run?
« on: March 06, 2012, 05:21:54 AM »
I upgraded to Avast 7 and soon noticed a lag when I start up applications.  So I ran a sniffer to see and got a shock!  Avast was sending back whatever apps I start, here is a snippet:

Code: [Select]
Remote Host vl.ff.avast.com
Remote Port 80
Service Name http
Capture Time 3/6/2012 11:58:36 AM


POST /F/...............snipped...............  HTTP/1.1
Accept: */*
Content-Type: application/octet-stream
Host: vl.ff.avast.com
Content-Length: 122

........snipped..........*;C:\Documents and Settings\Administrator\Desktop\h2testw.exe2.ign:...



This raises security and privacy concerns.  My Windows account name, my folder structures, application name are all sent back to avast and it wasn't even encrypted.

And I have disabled all cloud and community functions within avast's settings beforehand.

Please, can Avast address this issue.

« Last Edit: March 06, 2012, 06:37:45 AM by jamesc »

Offline FlyingRobot

  • Full Member
  • ***
  • Posts: 105
Re: Why is AVAST reporting back every application I run?
« Reply #1 on: March 06, 2012, 06:40:35 AM »
The sending of such information seems consistent with one or more avast features, but you say you disabled those.  Have you gone back through all the settings and carefully double checked things to make sure for example that the avast community, WebRep, *and* FileRep (file reputation) features are disabled? 

Is this happening a) for files you just downloaded/ran, b) for files that have been on your machine for awhile, c) both?
« Last Edit: March 06, 2012, 06:58:12 AM by FlyingRobot »

Offline jamesc

  • Newbie
  • *
  • Posts: 2
Re: Why is AVAST reporting back every application I run?
« Reply #2 on: March 06, 2012, 07:26:45 AM »
I checked again, under Settings, everything is unchecked in Cloud Services and Community.

I don't see Webrep or Filerep, maybe because I chose a minimal install of v7.0.1407.

It sends back to Avast, all programs, new or old, for every new session of Windows; meaning, if I restart my Windows, it will log and send back the same programs I run again.

To me, its behaving like a keylogger or in this case a What-App-I-Use-logger. 

I can understand if it needs to send back suspected malware infected file info but NOT every apps I run.  And it is not encrypted, if someone is sniffing my traffic, he will have a very nice and complete profile of what I am doing on my computer.

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 72884
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Why is AVAST reporting back every application I run?
« Reply #3 on: March 06, 2012, 07:38:19 AM »
Please, can Avast address this issue.

That was a bug and should be fixed in the latest build.
http://forum.avast.com/index.php?topic=94790.0
Win 8.1 [x64] - Avast PremSec 21.11.6787.IBC [UI.679] - EEK - Firefox ESR 91.3 [NS/uBO/PB] - TB 91.3.2
Avast-Tools: Secure Browser 96.0 - Cleanup 21.3 - SecureLine 5.14 - Driver Updater 21.4 - CCleaner 5.87
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline FlyingRobot

  • Full Member
  • ***
  • Posts: 105
Re: Why is AVAST reporting back every application I run?
« Reply #4 on: March 06, 2012, 08:00:42 AM »
Asyn, what was the bug?  Since jamesc mentioned not seeing web or file reputation service settings... was the community feature checkbox not being honored? 

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 72884
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Why is AVAST reporting back every application I run?
« Reply #5 on: March 06, 2012, 08:14:22 AM »
Asyn, what was the bug?

Sorry, but only the devs can answer that.
Win 8.1 [x64] - Avast PremSec 21.11.6787.IBC [UI.679] - EEK - Firefox ESR 91.3 [NS/uBO/PB] - TB 91.3.2
Avast-Tools: Secure Browser 96.0 - Cleanup 21.3 - SecureLine 5.14 - Driver Updater 21.4 - CCleaner 5.87
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline RejZoR

  • Polymorphic Sheep
  • Serious Graphoman
  • *****
  • Posts: 9385
  • We are supersheep, resistance is futile!
    • RejZoR's Flock of Sheep
Re: Why is AVAST reporting back every application I run?
« Reply #6 on: March 06, 2012, 08:37:28 PM »
Are you sure this has been mentioned as a bug? I mean checking the cloud when it's supposedly disabled? I don't recall seeing it anywhere...
Visit my webpage Angry Sheep Blog

Offline Gargamel360

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2346
  • Memento Mori
Re: Why is AVAST reporting back every application I run?
« Reply #7 on: March 06, 2012, 09:24:48 PM »
Are you sure this has been mentioned as a bug? I mean checking the cloud when it's supposedly disabled? I don't recall seeing it anywhere...
http://forum.avast.com/index.php?topic=94926.msg757793#msg757793
http://forum.avast.com/index.php?topic=94145.msg749535#msg749535
Signature?  But I gots no pen....

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 72884
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: Why is AVAST reporting back every application I run?
« Reply #8 on: March 07, 2012, 07:49:45 AM »
Are you sure this has been mentioned as a bug? I mean checking the cloud when it's supposedly disabled? I don't recall seeing it anywhere...
http://forum.avast.com/index.php?topic=94926.msg757793#msg757793
http://forum.avast.com/index.php?topic=94145.msg749535#msg749535

Thanks for posting the links Gargamel. :)
Win 8.1 [x64] - Avast PremSec 21.11.6787.IBC [UI.679] - EEK - Firefox ESR 91.3 [NS/uBO/PB] - TB 91.3.2
Avast-Tools: Secure Browser 96.0 - Cleanup 21.3 - SecureLine 5.14 - Driver Updater 21.4 - CCleaner 5.87
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline Gargamel360

  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2346
  • Memento Mori
Re: Why is AVAST reporting back every application I run?
« Reply #9 on: March 07, 2012, 08:32:07 AM »
Np
Signature?  But I gots no pen....

Offline Vlk

  • Avast CEO
  • Serious Graphoman
  • *
  • Posts: 11664
  • Please don't send me IM's. Email only. Thx.
    • ALWIL Software
Re: Why is AVAST reporting back every application I run?
« Reply #10 on: March 07, 2012, 11:49:03 AM »
1. Yes, these are FileRep requests (on-exec).
2. Yes, there was a bug in version 7.0.1407 that these requests were being made even if FileRep was disabled. This is now solved in build 7.0.1426.

Thanks
Vlk
If at first you don't succeed, then skydiving's not for you.