Author Topic: I found a bug about the password.  (Read 5919 times)

0 Members and 1 Guest are viewing this topic.

Offline A4214909

  • Newbie
  • *
  • Posts: 4
I found a bug about the password.
« on: March 07, 2012, 09:34:36 AM »
I set the password for avast.
In principle, I need to type the correct password to stop avast working or change the setting.
But I discovered I just have to type thousands of words when avast ask for password and it will stop its service.
And then, I can change anything I want.
It just like password doesn't exist.
PLEASE FIX THE PROBLEM ASAP.

----------------
This video shows everything

http://www.youtube.com/watch?v=y3Fl5w2nLPg
« Last Edit: March 07, 2012, 11:44:17 AM by A4214909 »

Offline Andrey,pro

  • Avast Überevangelist
  • Ultra Poster
  • *****
  • Posts: 5016
  • Things happen
Re: I found a bug about the password.
« Reply #1 on: March 07, 2012, 10:11:00 AM »
Hello,A4214909! Welcome to the forum!
I've just updated to 7.0.1426 via the GUI and i can't reproduce it!

Offline A4214909

  • Newbie
  • *
  • Posts: 4
Re: I found a bug about the password.
« Reply #2 on: March 07, 2012, 11:44:57 AM »
hi

this video can tell you what happened

http://www.youtube.com/watch?v=y3Fl5w2nLPg

Offline logos

  • Avast Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 9441
Re: I found a bug about the password.
« Reply #3 on: March 07, 2012, 11:56:14 AM »
hmm ... just checked and can't reproduce ... anyone from Avast can have a look ? ;D
w7 - ais7

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11805
    • AVAST Software
Re: I found a bug about the password.
« Reply #4 on: March 07, 2012, 12:00:29 PM »
Yeah, I'll fix that.

Offline logos

  • Avast Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 9441
Re: I found a bug about the password.
« Reply #5 on: March 07, 2012, 12:00:52 PM »
@A4214909 what version of Avast did you use to do that? 7.0.1407 ?
w7 - ais7

Offline logos

  • Avast Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 9441
Re: I found a bug about the password.
« Reply #6 on: March 07, 2012, 12:01:31 PM »
Yeah, I'll fix that.

is 1426 affected?
w7 - ais7

Offline A4214909

  • Newbie
  • *
  • Posts: 4
Re: I found a bug about the password.
« Reply #7 on: March 07, 2012, 12:05:19 PM »
7.0.1426
 :o

Offline RejZoR

  • Polymorphic Sheep
  • Serious Graphoman
  • *****
  • Posts: 9384
  • We are supersheep, resistance is futile!
    • RejZoR's Flock of Sheep
Re: I found a bug about the password.
« Reply #8 on: March 07, 2012, 12:05:53 PM »
Apparently it's not affected. See Andrey,pro's post above...

@A4214909
Yeah, new update has just been released.
Visit my webpage Angry Sheep Blog

Offline logos

  • Avast Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 9441
Re: I found a bug about the password.
« Reply #9 on: March 07, 2012, 12:11:30 PM »
okay I could reproduce :o ... just pasting 20 times or more the same wrong password (in one single row) ... jesus ;D ... then getting a wrong password alert, and opening the settings panel without any problem ...

>>> 1426 is affected
w7 - ais7

Offline Asyn

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 72274
    • >>>  Avast Forum - Deutschsprachiger Bereich  <<<
Re: I found a bug about the password.
« Reply #10 on: March 07, 2012, 12:19:52 PM »
Win 8.1 [x64] - Avast PremSec 21.9.6675.IBC [UI.671] - EEK - Firefox ESR 78.15 [NS/uBO/PB] - TB 91.2.1
Avast-Tools: Secure Browser 94.0 - Cleanup 21.3 - SecureLine 5.13 - Driver Updater 21.3 - CCleaner 5.85
Avast Wissenswertes (Downloads, Anleitungen & Infos): https://forum.avast.com/index.php?topic=60523.0

Offline A4214909

  • Newbie
  • *
  • Posts: 4
Re: I found a bug about the password.
« Reply #11 on: March 07, 2012, 12:39:21 PM »
Has the problem be fixed?

Offline Tetsuo

  • Poster
  • *
  • Posts: 594
Re: I found a bug about the password.
« Reply #12 on: March 07, 2012, 03:23:51 PM »
Has the problem be fixed?

I don't think so. Currently the latest program update is v. 7.0.1426

A couple of users have reported that also v. 7.0.1426 is affected. We'll see what happens...

Offline Tetsuo

  • Poster
  • *
  • Posts: 594
Re: I found a bug about the password.
« Reply #13 on: March 07, 2012, 09:40:53 PM »
Some information here:
http://forum.avast.com/index.php?topic=95170.msg759211#msg759211

It will be fixed tonight (in the next VPS update).

Regards