Author Topic: Opera can't send and receive mails when Avast is active.  (Read 7139 times)

0 Members and 1 Guest are viewing this topic.

thinman24

  • Guest
Opera can't send and receive mails when Avast is active.
« on: March 21, 2012, 10:53:41 PM »
As I wrote in an other thread with the same Problem (sorry for that) I can't receive and send mails from Opera as long as Avast is active.
This started a couple of weeks ago. Before that Avast was working fine with Opera.
I'm not using encription for the mail traffic betwen the server and my mail client.
Any suggestion would be great. Thanks.

Cheers,
Steve

Opera. 11.61 Build 1250; Avast "7.0" "1407"

Offline Pondus

  • Probably Bot
  • ****
  • Posts: 37182
Re: Opera can't send and receive mails when Avast is active.
« Reply #1 on: March 21, 2012, 10:56:22 PM »
So.....why not try with latest avast. 7.0.1426 

thinman24

  • Guest
Re: Opera can't send and receive mails when Avast is active.
« Reply #2 on: March 24, 2012, 07:35:25 PM »
The Update is done but the Problem is still there.
There is one change though: before the update the mail check went on indefinitely without any message.
After the update it tells me after a couple of seconds, that I don't have any new mail and stops the checking.
When I turn Avast off and try it agan, my mails are downloaded correctly.

Cheers,
Steve

Online DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86518
  • No support PMs thanks
Re: Opera can't send and receive mails when Avast is active.
« Reply #3 on: March 24, 2012, 08:09:41 PM »
Is Opera Mail embedded into the Opera browser or a stand alone email client ?

Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.2.6003 (build 22.2.7013.717) UI 1.0.697/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

thinman24

  • Guest
Re: Opera can't send and receive mails when Avast is active.
« Reply #4 on: March 24, 2012, 08:41:24 PM »
It's embedded in the browser.

Online DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86518
  • No support PMs thanks
Re: Opera can't send and receive mails when Avast is active.
« Reply #5 on: March 24, 2012, 09:28:27 PM »
OK, it is probably using port 80 in the same way as webmail viewed through the browser and as such probably routed through the Web Shield local proxy. This may be the issue as it is not using strict http protocol.

-  Try opening the avastUI, Real-Time Shields, Web Shield, Expert Settings, and check the 'Scan traffic from well-known browser processes only,' option.
« Last Edit: March 24, 2012, 09:31:51 PM by DavidR »
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.2.6003 (build 22.2.7013.717) UI 1.0.697/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

thinman24

  • Guest
Re: Opera can't send and receive mails when Avast is active.
« Reply #6 on: March 24, 2012, 09:56:31 PM »
It did not help.
- Turning off HTTP Shield completely = no sucess
- Turning off Mail Shield completetly = no sucess
- Turning off all the other shields on by one (Including Network) = no success

Turning off Avast completely from the Windows Task Bar = mail works.

In the Mail account setup the incoming server port number is 110 and the outgoing is on port 25.
I suppose it is only the port setup for the mail server on the provider side.

Can I check anything else?

Thanks for your help by the way!

Online DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86518
  • No support PMs thanks
Re: Opera can't send and receive mails when Avast is active.
« Reply #7 on: March 24, 2012, 11:20:02 PM »
My problem is I haven't a clue how the opera mail works.

It sounds like it is independent of the browser since you say it uses port 110 (POP3 port) and port 25 (SMTP port). Though you say it is integral (embedded) to opera browser, so you are viewing the and to me that puts opera mail between two stools, neither an email client or webmail (like hotmail). So my thoughts were that it is using a proprietary protocol to convert the email so that it can be viewed in the browser, but that gets blown out of the water by the fact that it worked before.

Why turning off the Mail Shield and Web Shield doesn't have any effect is strange as there are the areas where I would have expected any interaction to occur. Then You say you turned off the other shields one at a time with no success. If that also included the File System Shield (?) I can't understand why with no shields active it didn't work.

Then there is the fact that this worked fine before, can't you recall when this happened and any significant change on your system (e.g. opera update, etc.) ?

Are there any entries for the opera mail accounts in the Mail Shield, Expert Settings, SSL Accounts ?
If so they should also be showing encryption = none.

What is your operating system and firewall ?
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.2.6003 (build 22.2.7013.717) UI 1.0.697/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

thinman24

  • Guest
Re: Opera can't send and receive mails when Avast is active.
« Reply #8 on: March 24, 2012, 11:47:59 PM »
OS is Windows 7 Ultimate
Firewall is Comodo.
You could imagin Opera as a joint software of Firefox and Thunderbird mail or a comnbination of Windows Explorer and Outlook Express.
That is what makes it so simple to use.
Unfortunately I can't tell you what was the initiator for this behaivor as Opera is also on Automatic update and I don't really keep track of what gets installed and when.
As I don't use my PC every day and I keept using the quick workaround of turning off Avast for some weeks, it is even more fuzzy how this all started.
I would like to stick to Avast as it gives the best performance/protection ratio on my PC but we don't have to solve this quickly.
I can live with the workaround for some times.
I tried to google my problem, but I have not found anyone else complaining about the same issue.
Looks like I'm the only lucky one...  :)


Entries in the mail shield are present (Port 110 and 25). Encription is NONE.
« Last Edit: March 24, 2012, 11:49:43 PM by thinman24 »

Online DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86518
  • No support PMs thanks
Re: Opera can't send and receive mails when Avast is active.
« Reply #9 on: March 25, 2012, 01:14:20 AM »
Well I use Firefox and Thunderbird, but they are in no way embedded, they are individual stand alone applications.

So if Opera Mail is a separate installation, then it might be considered like thunderbird or outlook express.

The entries in the avast SSL Accounts indicate that the opera mail is an email client, so it should work in the same way as thunderbird and outlook express.

First I would suggest opening comodo and deleting any rules for avast as we have seen instances of comodo blocking avast. That should force comodo to ask permission again for the avast elements that connect to the internet (avastSvc.exe and avast.setup, .etc).

If that doesn't resolve it - Your first post says you started off with 7.0.1407 and then updated to 7.0.1426, so my suggestion would be to do a clean install of avast (that is likely to be the best/quickest option):
- Download the latest version of avast, 7.0.1426 http://files.avast.com/iavs5x/avast_free_antivirus_setup.exe and save it to your HDD, somewhere you can find it again (if you didn't save your last download). Use that when you reinstall.

- Download the avast! Uninstall Utility, aswClear.exe find it here and save it to your HDD (it has uninstall tools for 5.x, 6.0.x and 7.0.x).
  • 1. Now uninstall avast! (using add remove programs, if you can't do that start from the next step), reboot.
  • 2. run the avast! Uninstall Utility from safe mode, first for 6.x if previously installed and then for 7.0, once complete reboot into normal mode.
  • 3. install the latest version, reboot.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.2.6003 (build 22.2.7013.717) UI 1.0.697/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Chikai

  • Guest
Re: Opera can't send and receive mails when Avast is active.
« Reply #10 on: March 25, 2012, 03:24:15 AM »
I also use Opera 11.61 and I cant send or receive emails while Avast is running. I can not even get out onto the Internet. The page says, Internal Sever error. My other browsers, Maxthon and Slim Browser behave in exactly the same manner while Avast is on and then works perfectly normal when it is turned off. As far as the mail client in Opera goes, it works just like any other mail client except it is integrated with the Browser. I have two accounts, 1 with my Internet provider and Opera uses port 110 for receiving and port 25 for sending. On my gmail account Opera uses port 995 for receiving and port 587 for sending. This was all working just fine before the update to Avast. My firewall program is Online Armour and its web shield was turned off while I was using Avast. Since I have had to turn off Avast I have turned on the Online Armour web shield and the Browsers are working fine. Going by the experiences of other Avast users in the other posts since the update, I would have to say that the new version of Avast is seriously flawed, and the developers need to examine the code closely and quickly if they want to wipe the egg of their faces.         

Chikai

  • Guest
Re: Opera can't send and receive mails when Avast is active.
« Reply #11 on: March 25, 2012, 04:03:25 AM »
I should of mentioned my operating system is Vista Home with all updates installed. I have also uninstalled Avast with the Uninstall Utility, cleaned the registry with Windows Registry Repair, downloaded and installed the new Avast. Alas, nothing had changed, it is exactly the same as it was before. For now I will leave Avast turned off and rely on Online Armour until Avast is fixed. Online Armour and Avast work in perfect harmony in my computer as a combination against malware and viruses. I like Avast and will wait for a fix to this current problem.   

Offline Pondus

  • Probably Bot
  • ****
  • Posts: 37182
Re: Opera can't send and receive mails when Avast is active.
« Reply #12 on: March 25, 2012, 10:08:52 AM »
@thinman24
Quote
OS is Windows 7 Ultimate
Firewall is Comodo.
You could imagin Opera as a joint software of Firefox and Thunderbird mail or a comnbination of Windows Explorer and Outlook Express.
Try this....delete all avast rules in Comodo...reboot and create new





@Chikai

Quote
For now I will leave Avast turned off and rely on Online Armour until Avast is fixed.
Try this.....delete all avast rules in OA, reboot and create new rules


« Last Edit: March 25, 2012, 10:15:55 AM by Pondus »

AdrianH

  • Guest
Re: Opera can't send and receive mails when Avast is active.
« Reply #13 on: March 25, 2012, 12:21:28 PM »
I have Win7 64Bit and avast 7 (AIS).

I normally use Windows Live mail or Outlook for mail and Opera is my default browser. I just added my main email account to Opera Mail and it works perfectly, Avast scans mail in and out without the need for any changes to settings or firewall.


Offline Pondus

  • Probably Bot
  • ****
  • Posts: 37182
Re: Opera can't send and receive mails when Avast is active.
« Reply #14 on: March 25, 2012, 12:52:54 PM »
Quote
I just added my main email account to Opera Mail and it works perfectly, Avast scans mail in and out without the need for any changes to settings or firewall.
The firewall problem often happen when you upgrade avast to new version.
same thing with those that cant surfe unless they turn off webshield.

so lets wait and see if it solve the problem this time...