Author Topic: AVAST Unsecured: Not Starting or Scanning  (Read 30311 times)

0 Members and 1 Guest are viewing this topic.

VAIO-II

  • Guest
AVAST Unsecured: Not Starting or Scanning
« on: April 02, 2012, 01:03:00 PM »
Hello,

This is my first post on the forum and I am and have been using AVAST for many years without any problems.

However recently my AVAST has been disabled for some reason to the extent it will not scan anything not even pre-boot memory scan. I've had a look at services.msc and the services is scheduled to run automatically and all dependencies are also running.

I can't uninstall the program either or install a new one because it is not listed in the "Add/Remove Programs" in Windows 7.

I believe it could be this silly program I'm using - Wise Registry Cleaner - which may have removed the registry entry.

So what is the solution and can someone please help as my system is now not protected and I've got the kids using my computer so don't know what they'll be upto.

1. System Status: UNSECURED - If I press
Quote
"FIX NOW"
nothing happens.
2.  Scan Now: Start : Error appears:
Quote
Unable to start scan. There are no more endpoints available from the endpoint mapper.
 


Please help, thank you very much.

Offline CraigB

  • Avast Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 11239
  • No support PM's thanks
Re: AVAST Unsecured: Not Starting or Scanning
« Reply #1 on: April 02, 2012, 02:15:45 PM »
Did you do a registry backup with wise? if you have you can restore the registry to before you cleaned it, if that doesn't work i would try a system restore to a point before the problems ( disable the avast self defence first via settings troubleshooting ).

Registry cleaners can do more damage than good so i thoroughly dont recommend them, stick to CCleaner in future which also has registry cleaning capability but does not go very deep and remains safer to use but still requires viewing with some knowledge so not to remove anything that you shouldn't.

loverdorf

  • Guest
Re: AVAST Unsecured: Not Starting or Scanning
« Reply #2 on: April 02, 2012, 07:45:10 PM »
HELP.....first time visitor.  Im an old lady with only the very basic computer skills. Its all so confusing for me. But Im trying to learn as I go. Please bare with me.....
Im having a similair issue as previous post.  Nothing happens when I select the "fix now" or "start program".... and now Im getting "script error"  everytime I try to navigate thru this site. Ive had a terrible time lately with hangs or freeze. I tried to do a sytem go back yesterday and my system restore is not working.
Can anyone help this old lady ...advise

Penway

  • Guest
Re: AVAST Unsecured: Not Starting or Scanning
« Reply #3 on: April 03, 2012, 01:36:02 AM »
I am having this very same problem.  It just started today.  Avast (Free version 7.0.1426) comes up as "UNSECURED" when I boot up my computer (running Vista 64-bit).  Clicking on "Fix It" a couple of times does seem to work but there is obviously a problem here.  I've been using Avast for two years now and have never had this problem before. 

Offline CraigB

  • Avast Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 11239
  • No support PM's thanks
Re: AVAST Unsecured: Not Starting or Scanning
« Reply #4 on: April 03, 2012, 09:33:16 AM »
HELP.....first time visitor.  Im an old lady with only the very basic computer skills. Its all so confusing for me. But Im trying to learn as I go. Please bare with me.....
Im having a similair issue as previous post.  Nothing happens when I select the "fix now" or "start program".... and now Im getting "script error"  everytime I try to navigate thru this site. Ive had a terrible time lately with hangs or freeze. I tried to do a sytem go back yesterday and my system restore is not working.
Can anyone help this old lady ...advise
loverdorf please navigate to remove programs and double click on avast, from the popup screen click on repair and ok, when completed reboot your system.

Offline CraigB

  • Avast Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 11239
  • No support PM's thanks
Re: AVAST Unsecured: Not Starting or Scanning
« Reply #5 on: April 03, 2012, 09:37:43 AM »
I am having this very same problem.  It just started today.  Avast (Free version 7.0.1426) comes up as "UNSECURED" when I boot up my computer (running Vista 64-bit).  Clicking on "Fix It" a couple of times does seem to work but there is obviously a problem here.  I've been using Avast for two years now and have never had this problem before.
What happens if you just leave it for a while after starting the system - if it does eventually start on its own then this could be due to to many processes running at startup, if it doesn't start on it's own then i suggest doing a repair as i explained in my prior post to this.

VAIO-II

  • Guest
Re: AVAST Unsecured: Not Starting or Scanning
« Reply #6 on: April 07, 2012, 12:18:18 AM »
Did you do a registry backup with wise? if you have you can restore the registry to before you cleaned it, if that doesn't work i would try a system restore to a point before the problems ( disable the avast self defence first via settings troubleshooting ).

Registry cleaners can do more damage than good so i thoroughly dont recommend them, stick to CCleaner in future which also has registry cleaning capability but does not go very deep and remains safer to use but still requires viewing with some knowledge so not to remove anything that you shouldn't.

Thanks for your response Craigb and sorry for my late reply.

I managed to uninstall Avast 7 using RevoUninstaller because I couldn't uninstall it using the regular Windows procedure. Just before that I did restore backup reg file but that didn't help and neither did a fresh install of Avast. I still have the problem of all the Avast services being disabled and neither the "FIX NOW" or "Enable All Shields" will work.

From services.msc Avast services: "C:\Program Files\Alwil Software\Avast5\AvastSvc.exe" can't be started. The services status is: Stopped.

The error that appears when trying to start the service is:

Quote
Windows could not start the avast! Antivirus service on Local Compute. Error 127: The specificed procedure could not be found.

From the service dependencies are:
1. aswMonFit (sub tree: FltMgr) - I can't find this anywhere to enable/disable
2. RPC (DCOM & RPC subservices)

Any help would be great as I love AVAST and have never experienced any problems.

I initially disabled the avast services because I needed to but can't enable them now.

Many thanks. 

Offline CraigB

  • Avast Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 11239
  • No support PM's thanks
Re: AVAST Unsecured: Not Starting or Scanning
« Reply #7 on: April 07, 2012, 09:06:37 AM »
Revo should never be used to remove security software as it does not know the software or where all file and registry keys are stored and in what order things should be removed so to prevent further corruption, download and run the legitimate avast removal tool http://files.avast.com/files/eng/aswclear.exe  in safemode for all versions of avast ever installed and when completed reboot back into normal mode and re-install avast 7.0.1426.

VAIO-II

  • Guest
Re: AVAST Unsecured: Not Starting or Scanning
« Reply #8 on: April 12, 2012, 12:01:49 PM »
Thanks for that CraigB - it worked! I just uninstalled it using the link above and reintsalled and all is well. Did a full scan and no virus.

Many thanks :)

Offline CraigB

  • Avast Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 11239
  • No support PM's thanks
Re: AVAST Unsecured: Not Starting or Scanning
« Reply #9 on: April 12, 2012, 02:01:50 PM »
Thanks for that CraigB - it worked! I just uninstalled it using the link above and reintsalled and all is well. Did a full scan and no virus.

Many thanks :)
Your welcome :)