Author Topic: WTF: REGISTERING IS CHANGING SETTINGS!!! AVAST: ARE YOU CRAZY???????  (Read 2920 times)

0 Members and 1 Guest are viewing this topic.

Offline Anacunga

  • Sr. Member
  • ****
  • Posts: 252
WTF is that???????? I have here AVAST just running normally on two systems (a desktop-PC and a Subnotebook); both were new installed some three weeks ago. I had set all the settings to my needs (what always takes some time). I have here another Notebook that had avast running for about one year; there is still AVAST 6.0 (latest version) running there. All three are running WinXP and AVAST had to be registred - what was done yesterday. Settings here ALWAYS have to be to "manual updating" and "delete" as "action" is not allowed!

And what happens today???? Turning on both PCs with new system install and AVAST 7, first thing they do is an autoupdate by itself!!!!!!! They have (or better: had!) both the setting NOT TO AUTOUPDATE, BUT TO POPUP as soon as an update is ready! That means that AVAST has changed the settings by itself!!!!!! And that was only because of registering and NOT because of manually changing any settings!!!!

THERE ARE MANY THINGS TO BE ALLOWED IN SOFTWARE - BUT CHANGING SETTINGS ONLY BECAUSE OF REGISTERING (AND NOT BECAUSE OF CHANGING ANY SETTINGS MANALLY) WITHOUT WARNING OR ANNOUNCEMENT IS AN OFFENSE AND AN ATTACK TO TRUSTWORTHINESS AND INTEGRITY OF THE USER HIMSELF!!!!!!

Additionally, on the Subnotebook, the Action-Settings of the file system shield was reset to delete for second action.

AND THAT IS A SECOND OFFENSE TO CHANGE ACTION SETTINGS TO DELETE WITHOUT WARNING OR ANNOUNCEMENT!!!! You never know what else additionally was changed without warning or announcement!

Sorry, but THAT BEHAVIOUR IS NOT ACCEPTABLE!!!! By doing such things, AVAST ITSELF HAS TO BE CONSIDERED AS BEING MALWARE (as it has the allowance to tamper almost everything very deep inside the system)!!! It's really unbelievable that AVAST is doing things like that - as this leads to the fact that AVAST cannot be trusted to do only what it pretends to do, but to do just anything else - uncontrolable by the user - and he even does not know what else is happening in the background!

Sorry, but my confidence in AVAST is really in the cellar!!! And it's not the first time that settings were changed without announcement or warning to the user!!!! And I remember the case that an virus update was blocking all eMail of certain accounts.

What's up with AVAST???? It is still one of the best AV-solutions on the market (if not THE BEST) - but something like that IS JUST NOT ALLOWED TO HAPPEN!!!!
« Last Edit: April 29, 2012, 06:25:02 PM by Anacunga »

Offline Anacunga

  • Sr. Member
  • ****
  • Posts: 252
Re: WTF: REGISTERING IS CHANGING SETTINGS!!! AVAST: ARE YOU CRAZY???????
« Reply #1 on: April 29, 2012, 06:45:03 PM »
Additionally, not only the Action-Settings of the file system shield on the Subnotebook was reset to delete for second action, but also on the PC the status bar icon for definitions auto updates was reset to on (as it was as default settings, but was not before registering).

Offline !Donovan

  • Web Analyst
  • Avast Evangelist
  • Super Poster
  • ***
  • Posts: 2219
    • The WAR Against Malware
Re: WTF: REGISTERING IS CHANGING SETTINGS!!! AVAST: ARE YOU CRAZY???????
« Reply #2 on: April 29, 2012, 06:49:27 PM »
What? ???

Before avast! 7 was installed, you did have the option to back-up your previous settings.

See: https://support.avast.com/index.php?_m=knowledgebase&_a=viewarticle&kbarticleid=1241

Quote
THERE ARE MANY THINGS TO BE ALLOWED IN SOFTWARE - BUT CHANGING SETTINGS ONLY BECAUSE OF REGISTERING (AND NOT BECAUSE OF CHANGING ANY SETTINGS MANALLY) WITHOUT WARNING OR ANNOUNCEMENT IS AN OFFENSE AND AN ATTACK TO TRUSTWORTHINESS AND INTEGRITY OF THE USER HIMSELF!!!!!!
Did you read the EULA? See attached.

Quote
Sorry, but THAT BEHAVIOUR IS NOT ACCEPTABLE!!!! By doing such things, AVAST ITSELF HAS TO BE CONSIDERED AS BEING MALWARE (as it has the allowance to tamper almost everything very deep inside the system)!!! It's really unbelievable that AVAST is doing things like that - as this leads to the fact that AVAST cannot be trusted to do only what it pretends to do, but to do just anything else - uncontrolable by the user - and he even does not know what else is happening in the background!
Considering the way you talk and the way you take this incident, I can tell that you are not knowledgeable of computers. It is suppose to be able to access many areas inside of the computer. Some malware can only be removed by using a specific strategy, such as terminating the back-up file first and then the virus file.

It could have been avoided.
I think that you are just confused.
Familiarize Yourself! | Educate Yourself! | Beautify Yourself! | Scan Yourself!
"People who say it cannot be done should not interrupt those who are doing it."

Offline RejZoR

  • Polymorphic Sheep
  • Serious Graphoman
  • *****
  • Posts: 9407
  • We are supersheep, resistance is futile!
    • RejZoR's Flock of Sheep
Re: WTF: REGISTERING IS CHANGING SETTINGS!!! AVAST: ARE YOU CRAZY???????
« Reply #3 on: April 29, 2012, 06:51:41 PM »
Sorry but i don't understand what are you trying to achieve. I mean, the whole purpose of having antivirus is to keep it up to date as possible. Otherwise there is no point in using outdated technology to combat CURRENT threats.

So, from what i understand, you had updating set to "Manual" (both, signatures and program), but it updated by itself anyway? I find that a bit hard to believe, but at this point only avast! team can tell if they've done any changes to the update side that could do such a thing on its own.
Visit my webpage Angry Sheep Blog

Offline Anacunga

  • Sr. Member
  • ****
  • Posts: 252
Re: WTF: REGISTERING IS CHANGING SETTINGS!!! AVAST: ARE YOU CRAZY???????
« Reply #4 on: April 29, 2012, 07:23:15 PM »
Sorry but i don't understand what are you trying to achieve. I mean, the whole purpose of having antivirus is to keep it up to date as possible. Otherwise there is no point in using outdated technology to combat CURRENT threats.
Yes - that's clear that any AV-solution has to be updated permanently; but I cannot allow to update by itself as I have to control what happens on my line to the internet - as it could take bandwith of a process that needs the entire bandwith. Additionally there are running time critical processes on the machine - and doing anything in the background is not allowed. So as soon as a new update was announced AND as soon as it is clear that the line is free and no process is disturbed, it will be updated manually. Needs some discipline - but works fine - for years so far!!!!
So, from what i understand, you had updating set to "Manual" (both, signatures and program), but it updated by itself anyway?
Exactly!!!! And that on TWO SEPARATE MACHINES that both were registred yesterday - but nothing else in the configuration was changed!

BTW: it was NOT THE FIRST TIME that this happened - and it's even not the first time that I complain about that here.
I find that a bit hard to believe, but at this point only avast! team can tell if they've done any changes to the update side that could do such a thing on its own.
I fear that this is a real bug in AVAST - that by registering process, some things are set to default values again. But that's not allowed for a software that wants to have a good reputation!

@!Donovan: the question here is the reputation of AVAST! itself! If you consider it as "normal" that an AV-solution itself just does anything else - but not always what the user could and should be able to trust in, it would just be an evidence of incapacity of the AVAST-programmers. And that would be a very, very bad sign: it would mean that the avast programmers are tamperers. Who would want to install an AV-solution that is known to be untrustworthy? AVAST IS the Number one - for many good reasons; but even for the number one, something like that is not acceptable - for two reasons: first, if it would be known that just the simple process of registering would change any settings, it would be a very bad sign for the users to use such a piece of software for security reasons; and if the programmers would know or fear that this problem could occur, the software should include a "save settings" before and "restore settings" after the registering process to avoid such problems. But just entering a registration string and then important settings are changed without warning? Sorry, that's really inadmissible!
« Last Edit: April 29, 2012, 07:25:20 PM by Anacunga »

Gargamel360

  • Guest
Re: WTF: REGISTERING IS CHANGING SETTINGS!!! AVAST: ARE YOU CRAZY???????
« Reply #5 on: April 29, 2012, 07:26:10 PM »
Well, this has never happened to me....and I would know, I change a lot of settings as soon as I install (before I register), and rarely use the normal update process with new versions, prefer to clean install them.

Offline RejZoR

  • Polymorphic Sheep
  • Serious Graphoman
  • *****
  • Posts: 9407
  • We are supersheep, resistance is futile!
    • RejZoR's Flock of Sheep
Re: WTF: REGISTERING IS CHANGING SETTINGS!!! AVAST: ARE YOU CRAZY???????
« Reply #6 on: April 29, 2012, 07:29:09 PM »
I don't think it has anything to do with the registration itself. I've made hundreds of instalaltions, hundreds of registrations and avast! never ever changed any setting.
Visit my webpage Angry Sheep Blog

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 86916
  • No support PMs thanks
Re: WTF: REGISTERING IS CHANGING SETTINGS!!! AVAST: ARE YOU CRAZY???????
« Reply #7 on: April 29, 2012, 07:48:11 PM »
I have never found a 'program update' from the UI changed any settings.

Even when one or more of the default settings changed, like those who had early builds of avast7 were the AutoSandbox was set to Auto (not Ask), later builds of avast 7 reversed that default to Ask. But since it was a program update from the UI it left the old Auto setting.

Delete has never been a default action (Move to chest being the default, other than the web shield, abort connection) from as far back as I can remember from avast 4.x in eight years of using avast. Certainly nothing has changed for me on any of the registrations that I have done over the years and various versions of avast.

So I'm at a loss as to what is going on with your system/s.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.9.6034 (build 22.9.7554.734) UI 1.0.728/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

Offline Anacunga

  • Sr. Member
  • ****
  • Posts: 252
Re: WTF: REGISTERING IS CHANGING SETTINGS!!! AVAST: ARE YOU CRAZY???????
« Reply #8 on: April 29, 2012, 08:31:21 PM »
I have never found a 'program update' from the UI changed any settings.
Caution! Here it's not an update to change settings - it's the registering process; and that's even worse! An update that would change some settings could have some valuable reasons. If it would be really good for all users is another question - but it is imaginable that there are existing reasons for changing some settings with an update; but first not for such fundamental things (like the taken action in case of a detected threat), and secondly you'll have to inform the user that some settings were changed! But here it's just the registering process only that is changing some settings - and that's really weird!

Even when one or more of the default settings changed, like those who had early builds of avast7 were the AutoSandbox was set to Auto (not Ask), later builds of avast 7 reversed that default to Ask. But since it was a program update from the UI it left the old Auto setting.
That would all be acceptable and not be a (fundamental) problem - as said above: there might some reasons that an update could change some settings (if the programmers detect that some settings combinations cause som problems or what else). But the user has to be informed with such a settings-changing update!

Delete has never been a default action (Move to chest being the default, other than the web shield, abort connection) from as far back as I can remember from avast 4.x in eight years of using avast. Certainly nothing has changed for me on any of the registrations that I have done over the years and various versions of avast.
Delete is second action in file shield in default settings - and in some other settings. There must be at least one other thread here where I complain about that (there I proposed to introduce some kind of "global base-settings pack" for all shields - in the sense of: a standard-user uses different settings than the IT-specialist).

So I'm at a loss as to what is going on with your system/s.
I have no Idea what could cause that. But as said: these machines got a brand new installed WinXP (with all software and drivers installed from scratch) less than four weeks ago.