Author Topic: Glitch in avast! password  (Read 5287 times)

0 Members and 1 Guest are viewing this topic.

afa

  • Guest
Glitch in avast! password
« on: May 22, 2012, 12:00:17 AM »
So I just downloaded and installed the software on my phone, and the first impressions, I must say, are decidedly not good. In fact, they're terrible.

I followed the instructions exactly as stated and enabled the Anti-Theft app, which is now in stealth mode. As required, I entered a 4-digit passcode to lock the app. Well, now every time I try to open avast! Mobile Security it asks me for my passcode, and then foolishly refuses to accept it as correct.

The first time it happened, I finally got it to accept the passcode after entering it 5 or 6 times. But now, it won't accept it regardless. Anyone know how to solve this? (And before anyone asks - yes, I am positive I'm entering the correct passcode.)

I am using an HTC One X running ICS with HTC's Sense 4.0 UI skinned over.

I thought of uninstalling the apps, but while I can see the Anti-Theft (which I very inconspicuously named "Thief") in my app management list, clicking it just brings up the info for the app. I can't find any option to disable that "Device Admin" thing or whatever it was called.

Please advise.


[EDIT: Okay, the second part of the problem is fine. I figured out how to deactivate "Thief" as device admin and uninstalled it. Would still like to know about the passcode problem, though.]
« Last Edit: May 22, 2012, 12:32:04 AM by afa »

Offline Filip Havlicek

  • Avast team
  • Massive Poster
  • *
  • Posts: 2647
Re: Glitch in avast! password
« Reply #1 on: May 22, 2012, 09:12:35 AM »
Hi,

might be a HTC Sense 4.0 issue. Could you try 0000 as the password and see if it is accepted or not? (Shouldn't be, but just in case.)

Filip

svehlak

  • Guest
Re: Glitch in avast! password
« Reply #2 on: May 22, 2012, 11:56:14 AM »
I did try our solution on HTC One X with ICS 4.0.3, HTC SDK API level 4.12 and Sense 4.0 (update 1.29.401.11) and everything is running smoothly and correctly. Password is accepted without any troubles anytime is inserted.
As I understood you did set up the password in basic setting of antitheft (your name, password for avast, friendĀ“s number) - in this case the password is valid for whole suite, so every time you will change the settings or use another app and return to avast or the time out happened you will be prompted about password. The password must be entered correctly, otherwise red exclamation mark will appear beside the dialog - did you see one during the troubles?

Finally, you can uninstall avast by application manager; antitheft is set as device administrator, so you have to go to settings (through notification bar), select "security" and then "device administrators" - here you can un check antitheft application and uninstall it by application manager.

I am assuming that you have factory system and you have no major changes done (rooting, special launcher, etc.) - in case I am wrong, please let us know.

Thanks.

afa

  • Guest
Re: Glitch in avast! password
« Reply #3 on: May 23, 2012, 02:17:01 PM »
Thanks for the replies, guys.

I don't know what the problem was the first time, but it's fine now.

I basically uninstalled avast! (both Mobile Security and the anti-theft app) and re-installed it again and it seems to be working fine now. No idea why it gave me a problem before, but all's well that ends well as someone once said (foolishly).

Thanks again.

Offline Filip Havlicek

  • Avast team
  • Massive Poster
  • *
  • Posts: 2647
Re: Glitch in avast! password
« Reply #4 on: May 23, 2012, 02:22:56 PM »
Hi,

glad it's working :)

Filip

FerenczyAS

  • Guest
Re: Glitch in avast! password
« Reply #5 on: May 25, 2012, 10:51:05 AM »
Dear Avast Team,

As I am a dedicated Avast user on my pc and I installed the first mobile versions on my htc desire hd I wanted to give it a try on my new phone also. Its an htc sense xe running official Android 4.03 rom but rooted. Ive entered my old password, it accepted it then it happened like described by the fellow poster above. The program just keep saying the password is not good. Ive never had similar problems on Gingerbread and my old htc desire hd (rooted, alternative cyanogen mod and so on)...
I am uninstalling right now but its better for you guys to know about this issue. Keep up the good work.

FerenczyAS

  • Guest
Re: Glitch in avast! password
« Reply #6 on: May 25, 2012, 11:52:47 AM »
reinstalled, now works as supposed. strange...

svehlak

  • Guest
Re: Glitch in avast! password
« Reply #7 on: May 25, 2012, 01:04:59 PM »
Yes, it may be a HTC Sense behavior; anyway, I did not meet any similar behavior on older and newer HTC devices.