Author Topic: Avast Web Shield Blocking Internet BRowsing  (Read 12439 times)

0 Members and 1 Guest are viewing this topic.

mysticjim

  • Guest
Avast Web Shield Blocking Internet BRowsing
« on: May 12, 2012, 08:33:41 PM »
Hi Everyone, I've just signed up to this forum in the hope you assist in my Avast issue.  I have found various other threads relating to similar problems, but none really appeared to solve the issue 100%, and some descended into very bizarre territory, deviating sharply away from the actual issue, so apologies if the perfect fix is listed here somewhere - but in my inability to locate it I've decided to directly ask for your help.

Anyway, I have Avast 7 free, running on Win XP Home SP3.  All had been working perfectly up until about 3 weeks ago -  suddenly and without any prompting, my internet browsers refused to connect to any websites.  The problem would stay until the next reboot when the browsers would be come active again, only to return at seemingly random times - anything between 10 mins and 4 hours of connection.  There doesn't seem to be any particular pattern as to when this happens, its not when i visit specific websites or anything that I can detect as a trend.

Long story short, after much searching online I've ruled out many possible causes and tried out several fixes without success.

I can confirm it is not relating to any other 3rd part security apps or programs, there was a an installation of AVG prior to the current installation of Avast, but that was removed in its entirety using an approved removal method and no issues have occurred in the two years since removal.

I've noted that there are many reports of the Avast Web shield being directly responsible for the issue, in conjunction with the Windows XP Firewall(possibly - seen contradictary threads and posts.)  I can confirm that switching of the Avast Web shield does indeed make all my browsers work again.  I can confirm that while the shield is on and the browsers are not working, I can navigate to HTTPS web addresses and I can ping websites.  Also, other PC's can be directly connected to my router and can search the net without issue. 

I've tried the winsock / tcip repairs, both manual using a downloaded utility, and I've tried following some advice I think i might have found on a thread on here about deleting exceptions within the Windows Firewall relating to the browsers I use.  None of these fixes have resolved the issue, although perhaps I might not have understood exactly what I was supposed to do in each instance, more guidance welcomed.

Finally, the last thing I attempted was to update Avast to the latest available version - I went from the free version 6 to free version 7.  I did this while my connections and browsers were working, it did it without protest, and it worked after the reboot for about 3 hours, but then its fallen back into its predictable pattern.

Just for reference, Avast has not actually given me any feedback about if its blocking internet browsing for a specific security reason, I'm certainly not getting any warnings.  I also ran a full scan last night using Malware Bytes, it found nothing untoward.

So, I'm stuck!  Ideally I'd like to continue using Avast as its always appeared to have been sufficient for my needs, but I'm not really happy about having to browse most of the time with the web shield switched off, I get the impression that its a pretty important part of the whole security package!  ;D

Is there a definitive solution to fix this issue that you clever peeps might know of?

Many thanks

Jim (browsing without web shield!)

Offline Pondus

  • Probably Bot
  • ****
  • Posts: 37619
  • Not a avast user
Re: Avast Web Shield Blocking Internet BRowsing
« Reply #1 on: May 12, 2012, 08:41:34 PM »
how did you go from avast 6 to 7?   did you install on top of avast 6?

if so try uninstall 6 and 7 from safe mode with this and reboot

http://www.avast.com/uninstall-utility


then install 7 again and reboot

did it work?

mysticjim

  • Guest
Re: Avast Web Shield Blocking Internet BRowsing
« Reply #2 on: May 12, 2012, 09:37:31 PM »
Thanks Pondus, I'll give that a go and let you know.

Sunday 16.28 BST.  Have just completed the steps above, now got a fresh install of version 7.  The removal tool could only find my old version of V7, so couldn't follow your instructions to the letter and remove 6 as well.  Anyway, so far so good, has been running for about an hour without dropping out, I'll continue to monitor it and let you know how it goes.

Jim
« Last Edit: May 13, 2012, 05:32:16 PM by mysticjim »

mysticjim

  • Guest
Re: Avast Web Shield Blocking Internet BRowsing
« Reply #3 on: May 13, 2012, 08:55:16 PM »
Okay, its been almost four hours connected, I reckon the problem might be sorted.  So, I'm assuming this is something of a known issue - in future d'you guys suggest always upgrading via removal of the previous version then fresh, new installation of the latest version - seems a bit of a pain, have the developers of Avast confirmed why their automatic updating causes these issues?  Would be intrigued to know whats happening to address it.

Anyway, will continue to monitor my connections to ensure the problem is definitely fixed, but thanks in advance anyway.

Gratefully

Jim

mysticjim

  • Guest
Re: Avast Web Shield Blocking Internet BRowsing
« Reply #4 on: May 14, 2012, 11:54:59 PM »
Okay,

The situation is much improved, but not totally sorted.

After following the advice to remove my old installation of Avast and begin afresh, everything worked a dream until late last night when suddenly the problem returned.  My wife has advised that the problem happened again this morning, after about 10 minutes of browsing, 3 restarts in a row.  This evening, so far so good, so still keeping an eye on the situation, getting no feedback from Avast itself as to whats going on so still confused.

Any thoughts or can anyone suggest anything else to try to completely fix the problem?

Jim

REDACTED

  • Guest
Re: Avast Web Shield Blocking Internet BRowsing
« Reply #5 on: May 15, 2012, 12:19:20 AM »
I don't have much to add, mostly wanted to let you know that you are not alone on this. I have same issue from time to time including last night again. Checking my event logs I do see a bunch of these DNS errors. I know it is not my DNS provider since anytime I have the problem I just disable avast and walla all starts working again.

Quote
Name resolution for the name su.ff.avast.com timed out after none of the configured DNS servers responded.

martee99

  • Guest
Re: Avast Web Shield Blocking Internet BRowsing
« Reply #6 on: May 15, 2012, 04:47:34 AM »
I have a similar problem except that I have to disable the real-time shield before Avast will let me proceed to a ssubsequent web-site beyond my homepage.

REDACTED

  • Guest
Re: Avast Web Shield Blocking Internet BRowsing
« Reply #7 on: May 17, 2012, 10:19:51 AM »
Update on what seems to have fixed my issue so far.

Under Firewall > Firewall Settings > Expert Settings > Network Profiles I found multiple entries for my NIC. I also found entries in the Firewall Logs that indicated that avast had been switching between these profiles. At the time I had found this out my "interweb" browsing was working fine so I deleted the inactive profile. So far I have not experienced a return of the problem (3 hours).

Will provide an update in a day or so.

mysticjim

  • Guest
Re: Avast Web Shield Blocking Internet BRowsing
« Reply #8 on: May 18, 2012, 12:46:32 AM »
Update on what seems to have fixed my issue so far.

Under Firewall > Firewall Settings > Expert Settings > Network Profiles I found multiple entries for my NIC. I also found entries in the Firewall Logs that indicated that avast had been switching between these profiles. At the time I had found this out my "interweb" browsing was working fine so I deleted the inactive profile. So far I have not experienced a return of the problem (3 hours).

Will provide an update in a day or so.

Are you talking firewall as in the Firewall built into Avast?  I'm using the free version which I don't think includes that - I'm assuming you mean the Avast Firewall because I don't recognise your description relating to the Windows Firewall.

REDACTED

  • Guest
Re: Avast Web Shield Blocking Internet BRowsing
« Reply #9 on: May 21, 2012, 05:34:38 PM »
Ah yes, I was talking about the AVAST firewall. However this was not my problem as it came back after a day and this is first chance I had to come back and update.

I finally stepped back and looked at my home network as a whole and realized I had done a rather silly thing. My setup described below has probably caused a lot of strange behavior in the past but not enough to really have made me dig in until recently. While the increased problems do correspond to my upgrading to latest AVAST, I don't know why it would of made any difference since the below setup is generally a bad idea for such a small network.

In short, I had 2 NAT devices connected to each other and that would cause routing issues. In more detail, I have DSL connection via ISP (Frontier/Verizon) and by default their "modem" is set to NAT. I then have a Netgear wireless router connected to that, this was also set to NAT. Having 2 devices performing NAT like this and getting network stability is difficult to configure and not really worth trying to make it work in most cases.

Solution (for me) was to set the ISP modem to bridge mode and only do NAT with my Netgear. I also had to configure Netgear to connect directly to the DSL network like the ISP modem had been configured originally. In my case that meant setting WAN connection on Netgear to use PPPoE and giving it my ISP credentials for the connection.

My issue and solution are not  specific to my ISP or DSL. However each ISP, modem and router do have different ways of changing settings so your ISP is probably your best resource to assist you to determine if you have a double NAT configuration and how to change the ISP modem to bridge mode.

I could provide more details, however not sure if it will be very relevant to this discussion.

Offline DavidR

  • Avast √úberevangelist
  • Certainly Bot
  • *****
  • Posts: 89352
  • No support PMs thanks
Re: Avast Web Shield Blocking Internet BRowsing
« Reply #10 on: May 21, 2012, 05:46:05 PM »
@ jkladwig
If you are able to, please change your displayed user name, aside from it is hanging your email address out for all to harvest; it also exceeds the recommended maximum 12 characters, which makes it run into the topic headings.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.5.6116 (build 24.5.9153.762) UI 1.0.808/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security