Author Topic: Avast stopping POP3 Connector when virus is found  (Read 3153 times)

0 Members and 1 Guest are viewing this topic.

MHIA

  • Guest
Avast stopping POP3 Connector when virus is found
« on: March 21, 2012, 12:30:33 AM »
I am having an issue in SBS 2003 where Avast is causing the POP3 Connector to freeze when it finds a virus in an email.

The only way to get it to work is to kill the pop3 connector and remove the email from the external web server.

The version we are running of Avast is Avast Server 4.8 Antivirus.

I am unable to find a fix for this issue, all of Avasts settings appear to be correct.

Zak Pierce

  • Guest
Re: Avast stopping POP3 Connector when virus is found
« Reply #1 on: April 25, 2012, 06:38:41 PM »
I am also having this issue with Avast 4.8 server on my SBS2008/Exchange2007 server box.  I suspect the emails are truely infected (they contain suspisous .exe attachments) and I am glad Avast! is blocking them.

Is there a way to set the Avast exchange scanner to auto detele these emails without displaying the Virus Found alert window and halting the POP connector until a net admin chooses an Avast action: Delete / Move to chest ?

I have tried to stop the Exchange scanning provider and the alert persists.  Is this alert triggered by the standard shield or network shield?


Petetech888

  • Guest
Re: Avast stopping POP3 Connector when virus is found
« Reply #2 on: May 15, 2012, 08:45:22 AM »
See my post made a few minutes ago. It seems like a lot of us are being hit. Do you logs also say "Function setifaceUpdatePackages() has failed. Return code is 0x20000004, dwRes is 20000004"?
« Last Edit: May 15, 2012, 08:47:31 AM by Petetech888 »