Author Topic: Avast Unable to update/Shields offline (Free 7)  (Read 2359 times)

0 Members and 1 Guest are viewing this topic.

DocStock

  • Guest
Avast Unable to update/Shields offline (Free 7)
« on: June 14, 2012, 06:50:19 PM »
Since a few weeks ago, Avast has been acting up. The program is unable to update either the virus definitions or the program itself, returning with the error "The Package is broken" after maybe two seconds, and the real time shields icons disappear (see image). Windows detects that Avast is offline. The only way to solve it I have found is to do a reinstall, but this appears to be only a patch fix, as the problem will occur again after only a day or two. Restarting the Avast service via computer management is fruitless, and I'm unable to do a repair or full update via the control panel, getting the same error as the previous one "The Package is broken". All these problems persist even when booted into safe mode. I have of course considered the possibility of Malware or viruses, but after a boot time scan with Avast (this was following a re-install and Avast was working at this time), scans with Windows Defender and Malwarebytes without any Positives, I'm not so sure about what's causing this issue. My OS is Windows 7 32 bit and I'm using the latest Avast Free 7 (version 7.0.1426).


Offline CraigB

  • Avast Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 11248
  • No support PM's thanks
Re: Avast Unable to update/Shields offline (Free 7)
« Reply #1 on: June 14, 2012, 07:02:03 PM »
This sounds like there could be some remnants of an old AV maybe :-\ if you have used any of the AV's in this list http://singularlabs.com/uninstallers/security-software/ and not previously run there removal tool then please do so, of course if you have completed this before then there might be some other problem.

DocStock

  • Guest
Re: Avast Unable to update/Shields offline (Free 7)
« Reply #2 on: June 14, 2012, 07:14:29 PM »
I've run the uninstallers for all my AV programs when I uninstalled them. This began suddenly a week or so ago while I already had Avast installed. I hadn't uninstalled any AVs (including Avast) at any point then, so I don't beleive that this is what's causing the problem, but thanks anyways.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 89420
  • No support PMs thanks
Re: Avast Unable to update/Shields offline (Free 7)
« Reply #3 on: June 14, 2012, 07:19:29 PM »
In which case I would suggest you do a clean reinstall of avast if you haven't already done so:
- Download the latest version of avast, 7.0.1426 http://files.avast.com/iavs5x/avast_free_antivirus_setup.exe and save it to your HDD, somewhere you can find it again (if you didn't save your last download). Use that when you reinstall.

- Download the avast! Uninstall Utility, aswClear.exe find it here and save it to your HDD (it has uninstall tools for 5.x, 6.0.x and 7.0.x).
  • 1. Now uninstall avast! (using add remove programs, if you can't do that start from the next step), reboot.
  • 2. run the avast! Uninstall Utility from safe mode, first for 6.x if previously installed and then for 7.0, once complete reboot into normal mode.
  • 3. install the latest version, reboot.

Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 24.6.6121 (build 24.6.9241.848) UI 1.0.809/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security