Author Topic: avast! free web shield blocking internet connection.  (Read 13925 times)

Offline crawler30

  • Newbie
  • *
  • Posts: 2
    • Personal Message (Offline)
avast! free web shield blocking internet connection.
« on: November 30, 2010, 12:10:48 AM »
I have been using avast! for the last four years and have had no problems whatsoever but today I tried to access the internet and my homepage would not load. It just continuously says "loading" and nothing happens. First I tried to just reboot but still nothing. I tried to diagnose the connection and nothing. turned off my firewall (windows firewall) and nothing. searched some forums and tried to diagnose lan nothing positive. I turned off all avast! shields and it worked fine. I then turned them off one by one and found webshield to be the problem. I also had tried adding avast! to the exclusion list on my firewall but it did not help. I am currently running without the webshield until I get this figured out. Please help. I am running vista home premium 64 bit. I also run iobit security 360 but I do not believe it to be a problem as I have been running it with avast! for a couple years now and no problems, also turning it off does not change the issue.

Offline ziucqea

  • Full Member
  • ***
  • Posts: 149
  • Gender: Male
    • Personal Message (Offline)
Re: avast! free web shield blocking internet connection.
« Reply #1 on: November 30, 2010, 02:30:56 AM »
Try resetting winsocks.
-Click 'Start', type in 'cmd' in the searching tab, press enter
-Type in: 'netsh winsock reset'(without quotation marks), press 'enter'
-Restart your machine to see whether it's been fixed.
Firefox 3.6.13
avast! Free 6.0
OS:Win 7 Ultimate, 64bit
Hardware:
Intel P8700,2G RAM

Offline crawler30

  • Newbie
  • *
  • Posts: 2
    • Personal Message (Offline)
Re: avast! free web shield blocking internet connection.
« Reply #2 on: November 30, 2010, 04:27:06 AM »
Try resetting winsocks.
-Click 'Start', type in 'cmd' in the searching tab, press enter
-Type in: 'netsh winsock reset'(without quotation marks), press 'enter'
-Restart your machine to see whether it's been fixed.


I run a dsl modem, would doing this change settings that my router may have changed when installed? Also, is it possible to connect to the internet at all (even with the webshield turned off) if the winsocks are corrupted? Also, if they are corrupted Should I be getting error messages? As I have not gotten any error messages at all. Sorry for all the questions, I am definately not an IT proffessional. Thanx.

Offline ziucqea

  • Full Member
  • ***
  • Posts: 149
  • Gender: Male
    • Personal Message (Offline)
Re: avast! free web shield blocking internet connection.
« Reply #3 on: November 30, 2010, 05:40:23 AM »
1)No, it won't
2)Not necessary. Also, I think you can log in to your msn,QQ, Yahoo! Messenger or whatever currently, even with Webshield on, right?
3)I don't think you will get error messages at all....
Anyway, try it and see what happens...
Firefox 3.6.13
avast! Free 6.0
OS:Win 7 Ultimate, 64bit
Hardware:
Intel P8700,2G RAM

Online craigb

  • avast! Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 8079
  • Gender: Male
    • Personal Message (Online)
Re: avast! free web shield blocking internet connection.
« Reply #4 on: November 30, 2010, 05:41:13 AM »
Hi crawler30, You think you have no problem running iobit, maybe this is one of them.
Even with one of your av's turned off it will not solve your problem as there are low level driver's that are still running and will cause issue's and two av's will lesson your security, you need to choose which av you want and get rid of one and with iobit's untrustworthy history this would not have been on my system in the fist place.
Windows 8.1 Pro X64/ IE 11/ Avast 9.0.2018/ MBAM Premium 2.0.2

Offline SafeSurf

  • avast! Evangelist
  • Ultra Poster
  • ***
  • Posts: 4926
    • Personal Message (Offline)
Re: avast! free web shield blocking internet connection.
« Reply #5 on: November 30, 2010, 06:34:17 AM »
Hello crawler30 and welcome to the forum.

Craigb is correct in that we have seen MANY problems with users using iobit and having conflicts with other security software including Avast.  The only way to resolve this issue was to uninstall iobit per the vendor's uninstaller's tool or directions (NOT by a third-party uninstaller).

After you uninstall iobit, you will then need to reboot your machine.  There are other free security software that you can use in place of this that we can recommend that will not conflict with Avast to help you layer your protection.

Since you now have 2 AV software in your system, it is possible that Avast will not work correctly after you uninstall iobit even after rebooting.  Should this happen, do an Avast Repair:
- Go to Control Panel > Add/Remove programs > Avast Antivirus.
- Scroll down and choose Repair function in the pop-up window.
- Reboot.

If you still have problems with Avast, please post back and we will instruct you further.

Let us know if you have any questions.  Thank you. :)
iMac (Mavericks)/Safari and Firefox (NoScript/AdBlockPlus/BetterPrivacy/Ghostey)/
Vista Home Prem (same add-on's)/Avast Free/Online Armor Premium Firewall/MBAM Prem)/ Avast Mobile Security with MBAM Pro/ iPad 4th gen.

Offline Jab13

  • Jr. Member
  • **
  • Posts: 20
  • Gender: Male
    • Personal Message (Offline)
Re: avast! free web shield blocking internet connection.
« Reply #6 on: November 30, 2010, 10:51:16 PM »
Hello crawler30 and welcome to the forum.

Craigb is correct in that we have seen MANY problems with users using iobit and having conflicts with other security software including Avast.  The only way to resolve this issue was to uninstall iobit per the vendor's uninstaller's tool or directions (NOT by a third-party uninstaller).

After you uninstall iobit, you will then need to reboot your machine.  There are other free security software that you can use in place of this that we can recommend that will not conflict with Avast to help you layer your protection.

Since you now have 2 AV software in your system, it is possible that Avast will not work correctly after you uninstall iobit even after rebooting.  Should this happen, do an Avast Repair:
- Go to Control Panel > Add/Remove programs > Avast Antivirus.
- Scroll down and choose Repair function in the pop-up window.
- Reboot.

If you still have problems with Avast, please post back and we will instruct you further.

Let us know if you have any questions.  Thank you. :)

I don't mean to hijack this thread, but I thought it might be relevant.  I too have been unable to access the internet with the web shield running.  I was running iobit's Advanced System Care, along with Comodo firewall.  Initially I thought the problem was within Avast, because when I used system processes to disable all processes belonging to Comodo and iobit the problem persisted, and the only way to resolve the issue was to stop the web shield.  I have tried various suggestions on other threads and none of them have worked, that is until I came across this thread.  Not sure if this will fix Crawler30's problem, but his sounded very similar to mine, so I thought I would post.  Thank you for the suggestions made here.  :)

Offline inkcaj

  • Newbie
  • *
  • Posts: 2
    • Personal Message (Offline)
Re: avast! free web shield blocking internet connection.
« Reply #7 on: December 01, 2010, 01:40:05 AM »
I've had the same internet blocking problem since a reload last week.  After reading about the iobit security software issue, I turned off the generic Windows firewall, and connection restored.  Looks like the current version doesn't play well with firewalls.

Online craigb

  • avast! Überevangelist
  • Serious Graphoman
  • *****
  • Posts: 8079
  • Gender: Male
    • Personal Message (Online)
Re: avast! free web shield blocking internet connection.
« Reply #8 on: December 01, 2010, 04:24:35 AM »
I've had the same internet blocking problem since a reload last week.  After reading about the iobit security software issue, I turned off the generic Windows firewall, and connection restored.  Looks like the current version doesn't play well with firewalls.
You should not have to turn off the windows firewall or change any setting's with it or add exclusions for avast, your problem's must lie elsewhere.
Windows 8.1 Pro X64/ IE 11/ Avast 9.0.2018/ MBAM Premium 2.0.2

Offline SafeSurf

  • avast! Evangelist
  • Ultra Poster
  • ***
  • Posts: 4926
    • Personal Message (Offline)
Re: avast! free web shield blocking internet connection.
« Reply #9 on: December 01, 2010, 07:10:50 AM »
I've had the same internet blocking problem since a reload last week.  After reading about the iobit security software issue, I turned off the generic Windows firewall, and connection restored.  Looks like the current version doesn't play well with firewalls.
You should not have to turn off the windows firewall or change any setting's with it or add exclusions for avast, your problem's must lie elsewhere.
I agree with craigb on this.  Again, iobit has a known history of conflicting with other security software, and those using Avast have needed to uninstall iobit and ASC for Avast to work properly.  As a former user of ASC years ago, it offers very little, so I would not waste my memory or HDD on it, not to mention the headaches it seems to be giving everyone these days.

@ inkcaj, Follow the instructions above in my post regarding uninstalling it.  With Avast, a good FW, and MBAM, you will be well protected.  Let us know if you have any questions.  Thank you.
iMac (Mavericks)/Safari and Firefox (NoScript/AdBlockPlus/BetterPrivacy/Ghostey)/
Vista Home Prem (same add-on's)/Avast Free/Online Armor Premium Firewall/MBAM Prem)/ Avast Mobile Security with MBAM Pro/ iPad 4th gen.

Offline inkcaj

  • Newbie
  • *
  • Posts: 2
    • Personal Message (Offline)
Re: avast! free web shield blocking internet connection.
« Reply #10 on: December 02, 2010, 10:29:08 AM »
@ inkcaj, Follow the instructions above in my post regarding uninstalling it.  With Avast, a good FW, and MBAM, you will be well protected.  Let us know if you have any questions.  Thank you.

But I don't have iobit, or any other firewall, except what's running in my router.  My problems started after a clean XP install.  Meaning, an install from a Microsoft XP CD, then fully patched, and installed Avast only.  Locked my internet connection up.  Turn off Active shield, internet connection back.  Turn Active shield back on, lose internet.  Turn off Windows firewall, connection back.

Like I said, looks like current version of Active Shield is a bit picky about firewalls.

Offline SafeSurf

  • avast! Evangelist
  • Ultra Poster
  • ***
  • Posts: 4926
    • Personal Message (Offline)
Re: avast! free web shield blocking internet connection.
« Reply #11 on: December 03, 2010, 10:08:24 PM »
@ inkcaj,

I think everyone here got confused by your first post, so let's start from the beginning.
1.   What is your OS, 32 or 64-bit?  XP SP?
2.   What version of Avast did you install?  5.0.677 is the latest version.
3.   What product of Avast did you install?  Free, Pro, AIS?
4.   What other security software do you currently have or did you have in the past on this machine including antivirus (AV), firewall (FW), and other security programs?  If they were in the past, how did you remove them (the vendor's uninstaller's tool or another way)?
5.   Are your MS Updates (if you have Windows) current?
6.   Are your software updates current?
7.   Are the Avast definitions (updates) current?
8.   When was the last time you did any kind of scan in Avast, and if so what kind of scan was it?
9.   Why did you have to reinstall your OS from a CD?

Please try an Avast Repair:
- Go to Control Panel > Add/Remove programs > Avast Antivirus.
- Scroll down and choose Repair function in the pop-up window.
- Reboot.

In your next post, please answer the above questions and let me know if the Repair fixes your problems.  Thank you.

iMac (Mavericks)/Safari and Firefox (NoScript/AdBlockPlus/BetterPrivacy/Ghostey)/
Vista Home Prem (same add-on's)/Avast Free/Online Armor Premium Firewall/MBAM Prem)/ Avast Mobile Security with MBAM Pro/ iPad 4th gen.

Offline mshoward82

  • Newbie
  • *
  • Posts: 1
    • Personal Message (Offline)
Re: avast! free web shield blocking internet connection.
« Reply #12 on: December 04, 2010, 01:05:42 AM »
I just wanted to add that I was experiencing the same issues. My browsers would just hang and not load pages. Though i was connected. My updates still worked, my email program sent and received messages, and Zune software still downloaded music. It was just my browsers having the problem.

And like everyone else, they would work when I disabled the Avast Web Shield. I spent much time reading forums and found nothing good until I got here.

I found out the problem was with IObit. I had Advanced System Care installed.

I uninstalled IObit ASC, ran SuperAntispyware, and ran Malwarebyte's. Then restarted.
Reset my Avast settings to all Active and now my browsers work just fine.

I'm just glad that i finally found a forum that actually had the right solution.

Thank you for your guys help. :)

System:
Asus EeePC
Windows XP 32bit
Firefox 3.6
IE8
Avast! 5.0.677
SAS & MBAM
And IObit is history ;)
« Last Edit: December 04, 2010, 01:09:37 AM by mshoward82 »

Offline SafeSurf

  • avast! Evangelist
  • Ultra Poster
  • ***
  • Posts: 4926
    • Personal Message (Offline)
Re: avast! free web shield blocking internet connection.
« Reply #13 on: December 04, 2010, 08:31:25 AM »
Again, iobit has a known history of conflicting with other security software, and those using Avast have needed to uninstall iobit and ASC for Avast to work properly.

@ mshoward82,
I just wanted to add that I was experiencing the same issues. <snip> And like everyone else, they would work when I disabled the Avast Web Shield. 

I found out the problem was with IObit.  I had Advanced System Care installed.
I uninstalled IObit ASC, ran SuperAntispyware, and ran Malwarebyte's.  Then restarted.  Reset my Avast settings to all Active and now my browsers work just fine.

I'm just glad that i finally found a forum that actually had the right solution.
Thank you for your kind input.  I'm glad you are happy with our suggestions and the forum.  Most importantly, I'm glad your machine is working for you now!  :D

@ inkcaj,

I'm still waiting on your reply to my previous post to you.  Thank you.
iMac (Mavericks)/Safari and Firefox (NoScript/AdBlockPlus/BetterPrivacy/Ghostey)/
Vista Home Prem (same add-on's)/Avast Free/Online Armor Premium Firewall/MBAM Prem)/ Avast Mobile Security with MBAM Pro/ iPad 4th gen.

Online Tech

  • avast! team
  • Certainly Bot
  • *
  • Posts: 64885
  • Gender: Male
    • Personal Message (Online)
The best things in life are free.

 

Google Chrome

AVAST recommends using the FREE Google Chrome™ browser.

Download Google Chrome Now