Author Topic: Slow browser ~ Firefox  (Read 3448 times)

Offline Ganpixie

  • Newbie
  • *
  • Posts: 6
    • Personal Message (Offline)
Slow browser ~ Firefox
« on: February 15, 2012, 08:41:05 AM »
Hi Guys,
an input from the experts would be appreciated.

Current Avast v6.0.1367 / 120214-1

Have been using Avast freeware for some time now with no issues - just perfect performance  8)

About 7 - 10 days back my Firefox browser became very slow - taking between 49 seconds and 1 minute 23 seconds to load each page :o

Visit to the Firefox site indicated various checks to make - all negative with final comment being that it may be to do with a recent update for AV programme..........

The issue is only related to Firefox and I have had to revert to MS Internet Explorer which loads up in an instant ???

Any suggestions, please.

Ganpixie ;)

Offline nnoa110

  • Sr. Member
  • ****
  • Posts: 290
  • Gender: Male
    • Personal Message (Offline)
Re: Slow browser ~ Firefox
« Reply #1 on: February 15, 2012, 12:04:51 PM »
Hi Ganpixie, and welcome to the forums.

Have you installed any add-ons recently? If so, what is the name of these?

Also, Can you try to start Firefox in 'Safe Mode'?. To do this:

1.  Start > All Programs > Mozilla Firefox
2. Select Mozilla Firefox (Safe Mode)
Win 7 Home Premium SP1 64Bit/ Core i7 2630QM 2.0-2.9GHz/ 4GB RAM/ avast! Free AV 7.0.1474/ Outpost Firewall Pro 8.0/ MBAM PRO 1.70/ Sandboxie 3.76 Free

Offline Ganpixie

  • Newbie
  • *
  • Posts: 6
    • Personal Message (Offline)
Re: Slow browser ~ Firefox
« Reply #2 on: February 15, 2012, 02:15:36 PM »
Hi Ganpixie, and welcome to the forums.

Have you installed any add-ons recently? If so, what is the name of these?

Also, Can you try to start Firefox in 'Safe Mode'?. To do this:

1.  Start > All Programs > Mozilla Firefox
2. Select Mozilla Firefox (Safe Mode)

Thanks for the response ~~~

I have not installed any add-ons since early January - this issue only started about 7 - 10 days ago!
I did update Firefox to the latest version yesterday - made no difference at all  :-X

For some reason  ??? I am unable to start Firefox in safe mode!
That option is not available to me as described.

Since reading your reply I have completely removed all traces and evidence of Mozilla and its various components from my system, rebooted and re-installed Firefox v10.0.1 ~~~~

No difference at all - just crawling along (slowly!).
Whereas IE is sprinting at Warp-factor 10  8)

I guess I will now stay with IE...........

Computers, eh  ::)  Don't you just luv em  ;D

Thanks anyway  ;)

Offline MikeBCda

  • avast! Evangelist
  • Super Poster
  • ***
  • Posts: 2142
  • Gender: Male
    • Personal Message (Offline)
Re: Slow browser ~ Firefox
« Reply #3 on: February 15, 2012, 07:04:34 PM »
For some reason  ??? I am unable to start Firefox in safe mode!
That option is not available to me as described.
Just wanted to double-check that you understood nnoa110 correctly, and used the Start Menu to run Firefox - safe mode.  This essentially disables all of Fx's addons and extensions (possibly some other features as well?), enabling Fx to run considerably lighter.  As opposed to rebooting into safe mode and trying to start FX normally.
Intel Atom D2700, 2 gig RAM, Win 7 x64 SP1 & IE-11, Firefox 28.0 (default). 320 gig HD, 6Mb DSL, Win firewall, Avast 2014.9.0.2016 free, SpywareBlaster, MBAM Pro

Offline Ganpixie

  • Newbie
  • *
  • Posts: 6
    • Personal Message (Offline)
Re: Slow browser ~ Firefox
« Reply #4 on: February 16, 2012, 08:01:54 AM »
For some reason  ??? I am unable to start Firefox in safe mode!
That option is not available to me as described.
Just wanted to double-check that you understood nnoa110 correctly, and used the Start Menu to run Firefox - safe mode.  This essentially disables all of Fx's addons and extensions (possibly some other features as well?), enabling Fx to run considerably lighter.  As opposed to rebooting into safe mode and trying to start FX normally.

Hi,
yes I did understand the previous suggestion.........

When I went/go to All Progs - the full list of installations pops up - there is Mozilla - but JUST Mozilla - unlike all the other installations there are no extensions (such as start in safe mode etc)  ???

As a further comment to this topic I upgraded (yesterday) from IE7 to IE8 (remember I did not use IE previously).....
Now having installed IE8 it takes the same long time to upload the "home" page (Google) - items selected from "Favourites" load up pretty quickly.

So is this issue connected to Google ????????
Although with Fx EVERY page took ages to load.

I am still very much open to suggestions  8)

Offline DavidR

  • avast! Überevangelist
  • Certainly Bot
  • *****
  • Posts: 69198
  • Gender: Male
  • No support PMs thanks
    • Personal Message (Offline)
Re: Slow browser ~ Firefox
« Reply #5 on: February 16, 2012, 09:59:03 AM »
So in All Programs, you see Mozilla Firefox (not just Mozilla) and it doesn't expand to show further options, including safe mode, see image, click to expand.

If you haven't got a safe mode option, this is what is behind that option in the All Programs link for it "C:\Program Files\Mozilla Firefox\firefox.exe" -safe-mode so you could try running that from the Windows Run window. See image2, you can copy and paste the above bold text into the Run window and click OK.

You shouldn't have normal firefox running when you do this. You will also get a notification that it will run firefox without add-ons and do you want to do this all of the time (or words to that effect), you don't want that.

I haven't noticed any slowdown on my firefox 10.0.1, XP Pro system, nor my win7 netbook when I use that.
Core2Duo E8300/ 4GB Ram/ WinXP ProSP3/ avast! free 2014 9.0.2016/ Outpost Firewall Pro9.1/ Firefox 28.0, NoScript, RequestPolicy/ MailWasher Pro/ DropMyRights/ MalwareBytes AntiMalware Premium 2.0.1/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security

Offline Gopher John

  • avast! Evangelist
  • Super Poster
  • ***
  • Posts: 1392
  • Gender: Male
    • Personal Message (Offline)
Re: Slow browser ~ Firefox
« Reply #6 on: February 16, 2012, 01:59:48 PM »
You should also be able to restart Firefox in safe mode by going to Firefox | Help | Restart with add-ons Disabled...

When Firefox restarts, you will get the same small window as DavidR outlined with safe mode startup options.  Follow his instructions concerning that.
Pentium4 3.4GHZ, 2.0GB RAM, RADEON x850 XT Platinum Edition, WinXP Pro SP3 32bit, IE 8
i7-3610QM 2.3GHZ, 8.0GB Ram,  Nvidia GeForce GT 630M 2GB, Win7 Pro SP1 64bit, IE 11
Common to both: AIS 2014 9.0.2016, WinPatrol Plus, SpywareBlaster 5, Opera 12.16, Firefox 28, MBam Free, MCShield, CCleaner

Offline MikeBCda

  • avast! Evangelist
  • Super Poster
  • ***
  • Posts: 2142
  • Gender: Male
    • Personal Message (Offline)
Re: Slow browser ~ Firefox
« Reply #7 on: February 16, 2012, 09:12:10 PM »
Interesting - I just checked my own start menu, and somewhere in the recent flurry of new Firefox version releases they apparently removed that "Firefox safe mode" entry, I no longer have it either.
Intel Atom D2700, 2 gig RAM, Win 7 x64 SP1 & IE-11, Firefox 28.0 (default). 320 gig HD, 6Mb DSL, Win firewall, Avast 2014.9.0.2016 free, SpywareBlaster, MBAM Pro

Offline DavidR

  • avast! Überevangelist
  • Certainly Bot
  • *****
  • Posts: 69198
  • Gender: Male
  • No support PMs thanks
    • Personal Message (Offline)
Re: Slow browser ~ Firefox
« Reply #8 on: February 16, 2012, 09:20:17 PM »
Well it is obviously still in mine (FF 10.0.1) as the image shows.
Core2Duo E8300/ 4GB Ram/ WinXP ProSP3/ avast! free 2014 9.0.2016/ Outpost Firewall Pro9.1/ Firefox 28.0, NoScript, RequestPolicy/ MailWasher Pro/ DropMyRights/ MalwareBytes AntiMalware Premium 2.0.1/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security

Offline MikeBCda

  • avast! Evangelist
  • Super Poster
  • ***
  • Posts: 2142
  • Gender: Male
    • Personal Message (Offline)
Re: Slow browser ~ Firefox
« Reply #9 on: February 16, 2012, 09:41:09 PM »
No sub-menu for the Firefox entry on mine (also 10.0.1) -- possibly that has something to do with setting my start menu, ages and many versions ago, to "classic" (or whatever it's called) mode?
Intel Atom D2700, 2 gig RAM, Win 7 x64 SP1 & IE-11, Firefox 28.0 (default). 320 gig HD, 6Mb DSL, Win firewall, Avast 2014.9.0.2016 free, SpywareBlaster, MBAM Pro

Offline Saulius

  • Jr. Member
  • **
  • Posts: 62
    • Personal Message (Offline)
Re: Slow browser ~ Firefox
« Reply #10 on: February 18, 2012, 02:48:39 PM »
Hey, running Firefox in a Safe Mode that is interesting, but I can't get to it through the W7 Start Menu either however I can paste copy & paste -safe-mode into the Run bar and it comes up and works, cheers DavidR.

Offline DavidR

  • avast! Überevangelist
  • Certainly Bot
  • *****
  • Posts: 69198
  • Gender: Male
  • No support PMs thanks
    • Personal Message (Offline)
Re: Slow browser ~ Firefox
« Reply #11 on: February 18, 2012, 03:15:54 PM »
You're welcome.

The question after being able to run it in safe mode, is does the speed increase (as that was the whole point in trying) ?

If so there is an add-on which is having an impact on browsing speed.
Core2Duo E8300/ 4GB Ram/ WinXP ProSP3/ avast! free 2014 9.0.2016/ Outpost Firewall Pro9.1/ Firefox 28.0, NoScript, RequestPolicy/ MailWasher Pro/ DropMyRights/ MalwareBytes AntiMalware Premium 2.0.1/ WinPatrol+/ Drive Image 7.1/ SnagIt 10.0/ avast! mobile security

Offline Alievitan

  • Full Member
  • ***
  • Posts: 137
    • Personal Message (Offline)
Re: Slow browser ~ Firefox
« Reply #12 on: February 18, 2012, 03:22:36 PM »
http://www.makeuseof.com/tag/the-complete-guide-to-troubleshooting-mozilla-firefox-problems/

Has all the standard troubleshooting tips with illustrations to make it easier to do and why you need to do them. 

 

Google Chrome

AVAST recommends using the FREE Google Chrome™ browser.

Download Google Chrome Now