Avast WEBforum

Avast Products => Avast Free Antivirus / Premium Security (legacy Pro Antivirus, Internet Security, Premier) => Topic started by: swc-it on August 29, 2019, 01:57:35 AM

Title: Avast Premium Security v19.7.2388 Mail Shield will not turn on.
Post by: swc-it on August 29, 2019, 01:57:35 AM
I updated to the current version of Avast Premium Security v 19.7.2388 - b 19.7.4674.524 and the Mail Shield will not turn on.  I can toggle the on / off switch but it immediately turns back off.  This is a Win 7 x64 machine.  I have tried the Repair App option several times as well as the Reset To Default option of the settings but the problem persists.

Any suggestions to resolve this issue are appreciated.
Title: Re: Avast Premium Security v19.7.2388 Mail Shield will not turn on.
Post by: swc-it on September 12, 2019, 02:14:59 AM
I did a complete uninstall of Avast today, ran the Avast Clean tool in Safe Mode, then reinstalled Avast.  I did not restore settings.  The mail shield will not turn on.
Title: Re: Avast Premium Security v19.7.2388 Mail Shield will not turn on.
Post by: rocksteady on September 12, 2019, 10:38:43 AM
I have 19.7.2388 (build 19.7.4674.526) on Win10 1903. Whilst I do not seem to have been affected by it, there are other reports of mail shields issues on here:
https://forum.avast.com/index.php?topic=229190.0
https://forum.avast.com/index.php?topic=229043.0
Title: Re: Avast Premium Security v19.7.2388 Mail Shield will not turn on.
Post by: schmidthouse on September 12, 2019, 05:29:31 PM
There are some users with this issue however No issues here with latest Avast Premium and Win 10 1903
Title: Re: Avast Premium Security v19.7.2388 Mail Shield will not turn on.
Post by: swc-it on September 16, 2019, 07:24:52 PM
I submitted the issue to avast support & they replied with:

Quote
This issue is currently being investigated by our development team, it is probably caused by a bug in the latest version of Avast Antivirus. Once the fix is available, it will be released through the regular program or micro update.

In the mean time you can try this workaround:
Install the Anti-spam component.
Title: Re: Avast Premium Security v19.7.2388 Mail Shield will not turn on.
Post by: Asturias7 on September 29, 2019, 12:19:25 AM
Still hasn't been resolved. Mail Shield is off after every reboot. Plus, even if it's turned on after, emails aren't being scanned.