Author Topic: Win32 : Exdl (Adw)  (Read 9111 times)

0 Members and 1 Guest are viewing this topic.

03303

  • Guest
Win32 : Exdl (Adw)
« on: January 19, 2005, 11:54:09 AM »
Hi there, I'm new here and wondering if anyone can help ?

We've got a small network of 3 computers (2 x Win 98SE and 1x Win2000). Internet is ADSL broadband.

The Win2000 computer got infected with the Win32 : Exdl (Adw), which Avast finally got rid of.

The other two Win98 computers appear to be fine.

The problem I now have is that when I start internet explorer on the Win2000 machine the window opens up but won't connect to the internet. The message at the bottom of the window says -
res://C:\WINNIT\system32\shdock.dll/dnserror.htm

Can anyone advise me what I should do about this.

The Win2000 computer can still send and receive emails, but it won't go onto the internet.

Any help would be much appreciate.
Cheers...

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: Win32 : Exdl (Adw)
« Reply #1 on: January 19, 2005, 03:22:48 PM »
If you clean your temporary files, cookies, etc.
Open a cmd window and run:
C:\Windows\system32\ipconfig.exe /flushdns

Will it help?
The best things in life are free.

03303

  • Guest
Re: Win32 : Exdl (Adw)
« Reply #2 on: January 19, 2005, 04:24:26 PM »
Hello again.

Entered the line as -

C:\Winnt\system32\ipconfig.exe /flushdns

as Windows2000 doesn't have a Win folder, it's Winnt.

But I'm afraid nothing has changed !

Any more ideas ?

Thanks for trying

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: Win32 : Exdl (Adw)
« Reply #3 on: January 19, 2005, 05:29:04 PM »
Could be your firewall that are blocking the access?
If you have any, can you disable it? If this not work, can you uninstall it and see what you get?

Make sure your browser is not set to "Work Offline" (this option is generally in the File menu). If it doesn't help, try switching the proxy settings from "Auto-detect" to "No proxy" (I'm assuming you're not connecting to the Internet via proxy). Do you use a proxy filter?

Check your proxy settings into avast!:
Left click the avast icon > Settings
Update (Basic) > Details > Proxy
The best things in life are free.

03303

  • Guest
Re: Win32 : Exdl (Adw)
« Reply #4 on: January 20, 2005, 10:02:40 AM »
Hi there again.

Nope, it's not the firewall and we're not working off-line.

Just emails only, but still no internet explorer.

I'm still getting the -

res://C:\WINNIT\system32\shdoclc.dll/dnserror.htm

Whoops ! I've just noticed that I'd typed the wrong error line in my original post !

Will that make a difference to your advice ?

Thanks for taking the time to follow this up.

Cheers...

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67194
Re: Win32 : Exdl (Adw)
« Reply #5 on: January 20, 2005, 12:33:07 PM »
res://C:\WINNIT\system32\shdoclc.dll/dnserror.htm

If you use Google with the word dnserror.htm won't you find a solution?
The best things in life are free.

03303

  • Guest
Re: Win32 : Exdl (Adw)
« Reply #6 on: January 26, 2005, 10:06:54 AM »
Hi there again,

I've had a go with Goggle with no success !

It's took me to several site like this, had me downloading and running Winsock repair programs which haven't worked, and other programs that want me to give over cash in order fro them to work !

Wouldn't mind handing over the cash if I know they would really work !

Short of reformatting the HD and starting again I'm open to any options

Forever hopeful, David G