Author Topic: New AIS 8 and scanning SSL scanning  (Read 16572 times)

0 Members and 1 Guest are viewing this topic.

Offline BaluBig

  • Newbie
  • *
  • Posts: 12
New AIS 8 and scanning SSL scanning
« on: March 02, 2013, 11:14:06 AM »
Hello,

After upgrading to version 8 my email client started to show certificate errors when using SSL-enabled mail servers, like this:

 02.03.2013, 12:01:23: FETCH - Connecting to POP3 server pop.gmail.com on port 995
 02.03.2013, 12:01:23: FETCH - Initiating TLS handshake
>02.03.2013, 12:01:23: FETCH - Certificate S/N: 3B7494C80000000068A7, algorithm: RSA (2048 bits), issued from 9/12/2012 11:57:23 AM to 6/7/2013 7:43:27 PM, for 1 host(s): pop.gmail.com.
>02.03.2013, 12:01:23: FETCH - Owner: US, California, Mountain View, Google Inc, pop.gmail.com.
>02.03.2013, 12:01:23: FETCH - Issuer: generated by avast! antivirus for SSL scanning, avast! Mail Scanner, avast! Mail Scanner Root.
!02.03.2013, 12:01:23: FETCH - TLS handshake failure. Invalid server certificate (The issuer of this certificate chain was not found).

Unfortunately the email client I use, TheBat have got no 'Always trust this' option for this case.

Please advise.

Some system info:
Win 7 x64 Enterprise
AIS 8.0.1482
TheBat! v.5.2.2

Best regards - Serge.

Offline sanders

  • Newbie
  • *
  • Posts: 9
Re: New AIS 8 and scanning SSL scanning
« Reply #1 on: March 02, 2013, 04:12:11 PM »
Hello,
I have the same problem! I asked support for help but they suggested to reinstall the avast. I didn't do that yet because I guess that can not resolve the problem. I have been using the avast 7 for the whole year and SSL scanning worked perfectly.

Best regards.

Offline CCCP99

  • Newbie
  • *
  • Posts: 5
Re: New AIS 8 and scanning SSL scanning
« Reply #2 on: March 02, 2013, 08:57:13 PM »
Hello sanders,

so do I, everything worked fine in version 7, now with version 8 only turning off SSL-scanning helps to prevent getting error messages.

Kind regards,

Offline shotboy

  • Newbie
  • *
  • Posts: 3
Re: New AIS 8 and scanning SSL scanning
« Reply #3 on: March 03, 2013, 03:53:41 PM »
I had the same issue.  I deleted the certificates within Thunderbird for all my mail servers, including IMAP, closed Thunderbird and then restarted.  All appears to be working well with SSL scanning enabled within Avast!  Check out this article for how to delete the certificates.  Strangely, those certificates were grouped under an Avast! header.

http://support.appstate.edu/answers/certificate-error-thunderbird

Offline dansoftware

  • Newbie
  • *
  • Posts: 8

Offline BaluBig

  • Newbie
  • *
  • Posts: 12
Re: New AIS 8 and scanning SSL scanning
« Reply #5 on: March 04, 2013, 10:07:19 AM »
Yes, it used to work for 7.X

I see no Avast certificate installed in my system. Perhaps this is the cause of the problem (btw, solutions for Thunderbird will not work for me, I don't use Thunderbird  :P). Quite probably it will appear after I reinstall AIS cleanly, will try later.

Best regards - Serge.

Offline dansoftware

  • Newbie
  • *
  • Posts: 8
Re: New AIS 8 and scanning SSL scanning
« Reply #6 on: March 04, 2013, 11:55:06 AM »
Yes, it used to work for 7.X

The above solution worked under avast! v8.XX for me too.

Quite probably it will appear after I reinstall AIS cleanly, will try later.

It seems that you have not choice ;)

Offline sanders

  • Newbie
  • *
  • Posts: 9
Re: New AIS 8 and scanning SSL scanning
« Reply #7 on: March 04, 2013, 01:20:15 PM »
Hello,
I tried to reinstall AIS (with aswclear.exe)... Unfortunatelly without effect for SSL and TheBat!  :'(

Offline BaluBig

  • Newbie
  • *
  • Posts: 12
Re: New AIS 8 and scanning SSL scanning
« Reply #8 on: March 04, 2013, 02:01:04 PM »
The above solution worked under avast! v8.XX for me too.

Does this mean you see the AVAST's certificate installed in your system when using the certmgr.msc snap-in?

It seems that you have not choice ;)
Actually I do ;) I use two ssl-enabled mail servers, gmail and a corporate one. I trust the antivirus protection on both so currently the "check SSL" option is disabled.

Best regards - Serge.

Offline dansoftware

  • Newbie
  • *
  • Posts: 8
Re: New AIS 8 and scanning SSL scanning
« Reply #9 on: March 04, 2013, 02:44:14 PM »
Does this mean you see the AVAST's certificate installed in your system when using the certmgr.msc snap-in?

Yes, it does. I exported the certificate from the certmgr.msc snap-in and imported it to The Bat! successfully. There is no more any annoying messages and SSL mail checking works well.

Offline CCCP99

  • Newbie
  • *
  • Posts: 5
Re: New AIS 8 and scanning SSL scanning
« Reply #10 on: March 04, 2013, 04:42:43 PM »
Hello,
I tried to reinstall AIS (with aswclear.exe)... Unfortunatelly without effect for SSL and TheBat!  :'(

Hello sanders,

after following the above instructions, did you try to import the "avast! Mail Scanner Root"- certificate into the addressbook of TheBat! ?

Cordially,

Offline dansoftware

  • Newbie
  • *
  • Posts: 8
Re: New AIS 8 and scanning SSL scanning
« Reply #11 on: March 04, 2013, 05:22:30 PM »
The above solution helped me twice already. Here are two screenshots. Sorry for Russian.

This is AVAST's certificate in the certmgr.msc snap-in:


This is the same certificate imported to The Bat!:
« Last Edit: March 04, 2013, 05:24:24 PM by dansoftware »

Offline BaluBig

  • Newbie
  • *
  • Posts: 12
Re: New AIS 8 and scanning SSL scanning
« Reply #12 on: March 04, 2013, 08:02:35 PM »
So we are getting to the bottom of it  :) Thanks everyone  :)
It is necessary to have the certificate that was not installed into my system for some reason (and for the worst case it will never be installed by the installer).
It would be great if Avast team could make it publicly downloadable.

Best regards - Serge.

Offline dansoftware

  • Newbie
  • *
  • Posts: 8
Re: New AIS 8 and scanning SSL scanning
« Reply #13 on: March 05, 2013, 07:29:51 AM »
It is necessary to have the certificate that was not installed into my system for some reason (and for the worst case it will never be installed by the installer).
It would be great if Avast team could make it publicly downloadable.

Well, I am not sure but it can be unique for each installation.

Offline sanders

  • Newbie
  • *
  • Posts: 9
Re: New AIS 8 and scanning SSL scanning
« Reply #14 on: March 05, 2013, 08:57:14 AM »
Hello,
I tried to reinstall AIS (with aswclear.exe)... Unfortunatelly without effect for SSL and TheBat!  :'(
after following the above instructions, did you try to import the "avast! Mail Scanner Root"- certificate into the addressbook of TheBat! ?

I can't found the avast certificate in system storage, so I don't import that certificate into the thebat storage.