Author Topic: Avast 8 blocking or NOT SCANNING SSL emails - and Avast GUI disappears  (Read 33073 times)

0 Members and 1 Guest are viewing this topic.

TulipVorlax

  • Guest
Hi,

Since the 6 of july, i've stop receiving my emails on several of my accounts. It has gone unnoticed until today because sometimes life just wont let you...

Before reading about the certificates here, i was pulling my hairs trying to solve this problem.

But on my case, the thing to delete was on the Autorities tab and was called "avast! Mail Scanner Root".

But since i've been running several version of both avast and Thunderbird, I've deleted all certificates that weren't "builtin". There was a lot...

Anyways, thanks a lot.

helkav

  • Guest
@jcarlos : solution
« Reply #31 on: November 07, 2013, 10:11:04 AM »
@njcarlos not 100% sure if I followed your procedure exactly as avast did a program update in the middle of following it...but it certainly seemed to do the trick...this should have been sorted by export cert etc but didn't seem to work andI have been getting help from avast support which didn't seem to go anywhere - I think they might be advised to put your solution up as a FAQ or sticky

bizarrely I used Avast free for years and only paid in the last year as I felt it was only fair...then suddenly I have my first ever issue! this is not the first time I have had this happen with free vs paid software...it does really seem sometimes with software, that the best things in life are free (linux / thunderbird / firefox / openoffice : to name but a few)

thanks very much for posting this...neat solution

yann-gael

  • Guest
Re: Avast 8 blocking or NOT SCANNING SSL emails - and Avast GUI disappears
« Reply #32 on: November 11, 2013, 02:40:26 PM »
Hi all,

Thank you njcarlos for your help: I was able to solve this problem thank to your steps, which pointed me in the right direction! In my case, there was no certificates in the "Others" tab so:

1. Remove the avast! certificate from "Authorities" tab.
2. Close down and restart Thunderbird.
3. When reading mail from SSL IMAP or POP, Thunderbird will prompt a security exception for each of the mail servers. Just accept them.

Cheers!
Yann

After looking around the web for answers to this problem, none of them helped.

The solution I did find, however, seemed to solve my problem perfectly well.

My problem: hotmail/live e-mail accounts were unable to connect to pop3.live.com (i.e. you could see in Thunderbird status bar "Connected to pop3.live.com" but, nothing would actually happen).

To solve this problem, I took the following steps...

1. Right click on the e-mail address in the left-most addresses/accounts pane that's having issues.
2. Click "Settings"
3. Click on "Security" for the security sub-section of settings for this account
4. Click "View Certificates"
5. Click on the "Others" tab
6. You should see an avast! certificate there for the particular pop3 mailserver.
7. Delete it.
8. Close Thunderbird completely
9. Open avast!
10. Click on the "Security" tab
11. Click on the "Mail Shield" icon
12. Click "Settings" (next to Stop)
13. Go to "SSL Scanning" in the navigation menu
14. Uncheck "Scan SSL connections"
15. Click "OK"
16. Click "Settings" again (next to Stop)
17. Go to "SSL Scanning" in the navigation menu
18. Check "Scan SSL connections"
19. Click "OK"
20. You should get a warning you'll need to restart your e-mail client. If you haven't already closed it, restart it now.
21. When Thunderbird attempts to retrieve your e-mails, you should get warnings about certificates. Accept them all (make sure permanently). These are just avast! generated, you can check by clicking "View" and you will see the publisher/creator is avast! Mail Scanner.
22. Enjoy your e-mail (hopefully)

By deleting the certification, and what seems to force avast! to re-generate their SSL certificates, it should now be working fine and scanning your e-mails downloaded over SSL.

IMPORTANT: There is a lot of misinformation about removing ports from the Redirect Settings in the Troubleshooting section. Do not do this. If you have done this, replace them with the following:

HTTP port(s): 80,8080,8091,8081,8008,8888,3124,3127,3128
Check "Ignore local communication"

SMTP port(s): 25,587
POP port(s): 110
IMAP port(s): 143
NNTP port(s): 119
Check "Ignore local communication"

Hope this helps someone. If it does, please post and let others know.

Offline Hornet62

  • Newbie
  • *
  • Posts: 3
Re: Avast 8 blocking or NOT SCANNING SSL emails - and Avast GUI disappears
« Reply #33 on: February 14, 2014, 05:39:33 PM »
Thank you very much for this information.  Following these steps after the latest update got my email working with SSL again.  I was not getting error messages, but I was not getting my email either.  This fixed the problem and allows me to continue using SSL.  The only solution I had before was to not use SSL.