Author Topic: My scan time of over 2 hours - what is yours?  (Read 9141 times)

0 Members and 1 Guest are viewing this topic.

julian_ha_peck

  • Guest
My scan time of over 2 hours - what is yours?
« on: March 15, 2005, 01:16:31 PM »
I have posted this question at http://www.mistered.us/wwwboard/messages/9908.shtml and shown the CAP of the result.

Could anyone tell me why my avast! takes over 2 hours to run a scan? Or what is yours?

Thanks.

Julian


Offline Eddy

  • Avast Evangelist
  • Maybe Bot
  • ***
  • Posts: 31216
  • Watching (over?) you
    • Malware removal, Biljart and other things.
Re: My scan time of over 2 hours - what is yours?
« Reply #1 on: March 15, 2005, 01:46:29 PM »
This has been explained before on this board. How long a scan takes depends on a lot of things like:
cpu, memory, hd speed, settings, defragmentation, archive scanning enabled/disabled and so on.

Just see it this way:
Better slow and safe than fast and infected.

julian_ha_peck

  • Guest
Re: My scan time of over 2 hours - what is yours?
« Reply #2 on: March 15, 2005, 01:51:33 PM »
"Better slow and safe than fast and infected." I couldn't agree more. It just seems a very long time to scan, but if that is normal, then that's fine with me.

Thanks,

Julian

Francois_C

  • Guest
Re: My scan time of over 2 hours - what is yours?
« Reply #3 on: March 16, 2005, 04:12:15 PM »
I noticed the same issue, too.
Avast scanned the whole HD at least twice, and I had to stop the scan.
I think it's bug: Avast found a "pseudo-virus" which was in fact a program I compiled with RapidQ Basic*.
Avast deleted it, but Windows XP copied it in its system restoration files, where Avast finds the virus again, deletes it and so on...
The only solution is to disable system restoration while scanning with Avast.

*RapidQ compresses its executables with UPX File Compressor, which is considered a virus by Avast and some old virus definition files, because as far as I can remember, there was a virus written in RapidQ. This error happens only with files compiled with some versions of RapidQ libraries.
« Last Edit: March 16, 2005, 04:17:09 PM by Francois_C »

Offline igor

  • Avast team
  • Serious Graphoman
  • *
  • Posts: 11815
    • AVAST Software
Re: My scan time of over 2 hours - what is yours?
« Reply #4 on: March 16, 2005, 04:53:54 PM »
Is the false alarm still present?
Did you send us the file? (or can you post a link if it's downloadable anywhere?)
Thanks.

Offline DavidR

  • Avast Überevangelist
  • Certainly Bot
  • *****
  • Posts: 86651
  • No support PMs thanks
Re: My scan time of over 2 hours - what is yours?
« Reply #5 on: March 16, 2005, 05:41:17 PM »
"Better slow and safe than fast and infected." I couldn't agree more. It just seems a very long time to scan, but if that is normal, then that's fine with me.

What were your scan settings? - Through and Scan Archive files is likely take a very long time. I have only done this once after installing avast to ensure that my complete system was clean (I would also consider it as an option if I ever got infected).

For the most part I do a Standard Scan (no archives scanned) once a week. Web Shield/Mail scanner, combined with Standard shield should take care of day to day on access scans of newly created/modified files. Archives are dormant until you have opened them and/or clicked on one of the files inside it; when you try to open an archive, avast scans it by default.

Of course it is your decision as to the sensitivity of the scan, its frequency and if archives are also scanned, but you have good protection in depth with avast.
Windows 10 Home 64bit/ Acer Aspire F15/ Intel Core i5 7200U 2.5GHz, 8GB DDR4 memory, 256GB SSD, 1TB HDD/ avast! free 22.5.6015 (build 22.5.7263.730) UI 1.0.711/ Firefox, uBlock Origin, uMatrix/ MailWasher Pro/ Avast! Mobile Security

julian_ha_peck

  • Guest
Re: My scan time of over 2 hours - what is yours?
« Reply #6 on: March 16, 2005, 11:21:32 PM »
After these kind comment, I had a look in avast! "log viewer" and found this large report: "Error Report".

25/02/05 21:52:55   The User   4294918219   AAVM - initialization error: Aavm/RPC: RpcEpRegister failed (30 retries), 0000076B. 
25/02/05 21:53:15   The User   4294918219   Error in aswChestS: chestStart Error 1899. 
26/02/05 09:03:03   The User   4294919139   AAVM - initialization error: Aavm/RPC: RpcEpRegister failed (30 retries), 0000076B. 
26/02/05 09:03:26   The User   4294919139   Error in aswChestS: chestStart Error 1899. 

Deleted all between 26/02/05 and 13/03/05 as they are repetitious

13/03/05 15:44:02   The User   4294925423   AAVM - initialization error: Aavm/RPC: RpcEpRegister failed (30 retries), 0000076B. 
13/03/05 15:44:23   The User   4294925423   Error in aswChestS: chestStart Error 1899. 
13/03/05 18:10:46   The User   4294943467   AAVM - initialization error: Aavm/RPC: RpcEpRegister failed (30 retries), 0000076B. 
13/03/05 18:11:03   The User   4294943467   Error in aswChestS: chestStart Error 1899. 
14/03/05 09:31:15   The User   4294957421   AAVM - initialization error: Aavm/RPC: RpcEpRegister failed (30 retries), 0000076B. 
14/03/05 09:31:34   The User   4294957421   Error in aswChestS: chestStart Error 1899. 
14/03/05 10:08:33   The User   4294210165   Error in aswChestC: chestOpenList Error 1722. 
14/03/05 10:08:33   The User   4294210165   aswChestInterface - Program error description: CChestListView::LoadFiles() chestOpenList() failed: 1722. 
14/03/05 10:09:02   The User   4294210165   aswChestInterface - Program error description: CChestListView::OnCreate() !m_strErrorWnd.IsEmpty(). 
14/03/05 10:15:18   The User   4293960121   Error in aswChestC: chestOpenList Error 1722. 
14/03/05 10:15:18   The User   4293960121   aswChestInterface - Program error description: CChestListView::LoadFiles() chestOpenList() failed: 1722. 
14/03/05 11:27:50   The User   4293960121   aswChestInterface - Program error description: CChestListView::OnCreate() !m_strErrorWnd.IsEmpty(). 
14/03/05 13:23:04   The User   4294949171   AAVM - initialization error: Aavm/RPC: RpcEpRegister failed (30 retries), 0000076B. 
14/03/05 13:23:24   The User   4294949171   Error in aswChestS: chestStart Error 1899. 
15/03/05 06:45:39   The User   4294925331   AAVM - initialization error: Aavm/RPC: RpcEpRegister failed (30 retries), 0000076B. 
15/03/05 06:46:00   The User   4294925331   Error in aswChestS: chestStart Error 1899. 
15/03/05 08:08:28   The User   4294918151   AAVM - initialization error: Aavm/RPC: RpcEpRegister failed (30 retries), 0000076B. 
15/03/05 08:08:47   The User   4294918151   Error in aswChestS: chestStart Error 1899. 
15/03/05 09:55:10   The User   4294957089   AAVM - initialization error: Aavm/RPC: RpcEpRegister failed (30 retries), 0000076B. 
15/03/05 09:55:31   The User   4294957089   Error in aswChestS: chestStart Error 1899. 
15/03/05 14:00:41   The User   4294918449   AAVM - initialization error: Aavm/RPC: RpcEpRegister failed (30 retries), 0000076B. 
15/03/05 14:00:59   The User   4294918449   Error in aswChestS: chestStart Error 1899. 
15/03/05 22:34:11   The User   4294926303   AAVM - initialization error: Aavm/RPC: RpcEpRegister failed (30 retries), 0000076B. 
15/03/05 22:34:31   The User   4294926303   Error in aswChestS: chestStart Error 1899. 
16/03/05 13:50:45   The User   4294949759   AAVM - initialization error: Aavm/RPC: RpcEpRegister failed (30 retries), 0000076B. 
16/03/05 13:51:05   The User   4294949759   Error in aswChestS: chestStart Error 1899. 
16/03/05 15:29:41   The User   4294948493   AAVM - initialization error: Aavm/RPC: RpcEpRegister failed (30 retries), 0000076B. 
16/03/05 15:29:59   The User   4294948493   Error in aswChestS: chestStart Error 1899. 
16/03/05 20:09:02   The User   4294924717   AAVM - initialization error: Aavm/RPC: RpcEpRegister failed (30 retries), 0000076B. 
16/03/05 20:09:20   The User   4294924717   Error in aswChestS: chestStart Error 1899. 
 
Then in the "warning Log" - this:

26/02/05 09:04:55   The User   4294919139   Function setifaceUpdatePackages() has failed. Return code is 0x20000004, dwRes is 20000004. 
26/02/05 09:04:56   The User   4294919139   An error has occured while attempting to update. Please check the logs. 
26/02/05 18:29:04   The User   4294919511   Function setifaceUpdatePackages() has failed. Return code is 0x20000004, dwRes is 20000004. 
26/02/05 18:29:06   The User   4294919511   An error has occured while attempting to update. Please check the logs. 
26/02/05 22:08:58   The User   4294919581   Function setifaceUpdatePackages() has failed. Return code is 0x20000004, dwRes is 20000004. 
26/02/05 22:08:59   The User   4294919581   An error has occured while attempting to update. Please check the logs. 
26/02/05 23:37:47   The User   4294919587   Function setifaceUpdatePackages() has failed. Return code is 0x20000004, dwRes is 20000004. 
26/02/05 23:37:49   The User   4294919587   An error has occured while attempting to update. Please check the logs. 
28/02/05 09:05:52   The User   4294920003   Function setifaceUpdatePackages() has failed. Return code is 0x20000004, dwRes is 20000004. 
28/02/05 09:05:53   The User   4294920003   An error has occured while attempting to update. Please check the logs. 
28/02/05 09:34:36   The User   4294918947   Function setifaceUpdatePackages() has failed. Return code is 0x20000004, dwRes is 20000004. 
28/02/05 09:34:37   The User   4294918947   An error has occured while attempting to update. Please check the logs. 
28/02/05 13:41:02   The User   4294956073   Function setifaceUpdatePackages() has failed. Return code is 0x20000004, dwRes is 20000004. 
28/02/05 13:41:03   The User   4294956073   An error has occured while attempting to update. Please check the logs. 
28/02/05 14:30:11   The User   4294919023   Function setifaceUpdatePackages() has failed. Return code is 0x20000004, dwRes is 20000004. 
28/02/05 14:30:12   The User   4294919023   An error has occured while attempting to update. Please check the logs. 
28/02/05 15:04:10   The User   4294919023   Function setifaceUpdatePackages() has failed. Return code is 0x20000004, dwRes is 20000004. 
28/02/05 15:04:12   The User   4294919023   An error has occured while attempting to update. Please check the logs. 
05/03/05 12:02:57   The User   4294950015   AAVM - scanning warning: x_AavmCheckFileDirectEx: C:\WINDOWS\APPLICATION DATA\MOZILLA\FIREFOX\PROFILES\HVGRTLJY.DEFAULT\BOOKMARKS-1.HTML (C:\WINDOWS\APPLICATION DATA\MOZILLA\FIREFOX\PROFILES\HVGRTLJY.DEFAULT\BOOKMARKS-1.HTML) returning error, 00000002. 
09/03/05 12:13:11   The User   4294957349   Function setifaceUpdatePackages() has failed. Return code is 0x20000004, dwRes is 20000004. 
09/03/05 12:13:12   The User   4294957349   An error has occured while attempting to update. Please check the logs. 
10/03/05 11:04:12   The User   4294925979   Function setifaceUpdatePackages() has failed. Return code is 0x20000004, dwRes is 20000004. 
10/03/05 11:04:13   The User   4294925979   An error has occured while attempting to update. Please check the logs. 
10/03/05 17:06:16   The User   4294925979   Function setifaceUpdatePackages() has failed. Return code is 0x20000004, dwRes is 20000004. 
10/03/05 17:06:17   The User   4294925979   An error has occured while attempting to update. Please check the logs. 
13/03/05 15:24:27   The User   4294925441   Function setifaceUpdatePackages() has failed. Return code is 0x20000004, dwRes is 20000004. 
13/03/05 15:24:29   The User   4294925441   An error has occured while attempting to update. Please check the logs. 
14/03/05 10:26:47   The User   4294085429   Sign of "Win32:Kuang2" has been found in "c:\WINDOWS\SYSTEM\ActiveScan\imscan.dll" file. 
14/03/05 11:00:49   The User   4294085429   Sign of "JS:ClassLoader-7" has been found in "c:\WINDOWS\Application Data\Sun\Java\Deployment\cache\javapi\v1.0\jar\classload.jar-6f8bc9e5-5326fdc2.zip" file. 
16/03/05 02:44:07   The User   4294926303   Function setifaceUpdatePackages() has failed. Return code is 0x20000004, dwRes is 20000004. 
16/03/05 02:44:09   The User   4294926303   An error has occured while attempting to update. Please check the logs. 

Can you tell me what these errors are about and what to do to remedy them if necessary.  Is this what is slowing down my scans???

Thanks for your help.

Julian[/size]

Hopismum

  • Guest
Re: My scan time of over 2 hours - what is yours?
« Reply #7 on: March 16, 2005, 11:38:04 PM »
I did a through scan this morning of the entire drive and it took only 30 mins or so...     (winxp home here)

julian_ha_peck

  • Guest
Re: My scan time of over 2 hours - what is yours?
« Reply #8 on: March 17, 2005, 12:56:15 AM »
I wish mine would.

What is the explanation for all the error messages I am getting in these logs?

I update regularly as can be seen.

What to do?

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67241
Re: My scan time of over 2 hours - what is yours?
« Reply #9 on: March 17, 2005, 02:34:07 AM »
25/02/05 21:52:55   The User   4294918219   AAVM - initialization error: Aavm/RPC: RpcEpRegister failed (30 retries), 0000076B. 
25/02/05 21:53:15   The User   4294918219   Error in aswChestS: chestStart Error 1899.

An RPC (Remote Procedure Call, Windows service) error in avast Chest.

14/03/05 10:08:33   The User   4294210165   aswChestInterface - Program error description: CChestListView::LoadFiles() chestOpenList() failed: 1722. 
14/03/05 10:09:02   The User   4294210165   aswChestInterface - Program error description: CChestListView::OnCreate() !m_strErrorWnd.IsEmpty(). 
14/03/05 10:15:18   The User   4293960121   Error in aswChestC: chestOpenList Error 1722.

Again... some trouble in Chest.
For these two errors, try repairing your installation?
Go to Control Panel > Add/Remove programs > avast! antivirus > Remove
Then choose Repair function in the popup window (Repair).
You must be connected to the internet while repairing.
 
26/02/05 09:04:55   The User   4294919139   Function setifaceUpdatePackages() has failed. Return code is 0x20000004, dwRes is 20000004. 
26/02/05 09:04:56   The User   4294919139   An error has occured while attempting to update. Please check the logs. 

Update troubles. Not to worry that much.

14/03/05 10:26:47   The User   4294085429   Sign of "Win32:Kuang2" has been found in "c:\WINDOWS\SYSTEM\ActiveScan\imscan.dll" file.

You've used Panda on-line scanning  ;D
They do not encript their signature files. It's a shame of Panda  :P

14/03/05 11:00:49   The User   4294085429   Sign of "JS:ClassLoader-7" has been found in "c:\WINDOWS\Application

Infected files... Run a scan and clear your system if it's not already cleaned.
The best things in life are free.

julian_ha_peck

  • Guest
Re: My scan time of over 2 hours - what is yours?
« Reply #10 on: March 17, 2005, 10:29:47 AM »
YOU have been really helpful. Thank you. I'll let you know how I get on.

julian_ha_peck

  • Guest
Re: My scan time of over 2 hours - what is yours?
« Reply #11 on: March 17, 2005, 10:42:59 AM »
Hi Technical,

That was painless, easy and very quick.

Now what?

Thanks so much.


By the way ...... When I right click on the "a" icon > Programme Settings > Update (Basic) and hit "update now" .......... nothing happens. That doesn't seem right to me - neither "Virus database" nor "Programme"

jingarfield

  • Guest
Re: My scan time of over 2 hours - what is yours?
« Reply #12 on: March 17, 2005, 10:52:46 AM »
I find deleting my temporary internet files prior to scanning speeds things up a whole lot (and it also speeds up AdAware and Spybot S&D scans too!).

julian_ha_peck

  • Guest
Re: My scan time of over 2 hours - what is yours?
« Reply #13 on: March 17, 2005, 11:49:38 AM »
I have recently changed my Internet Explorer settings to empty my Temporary Files on exit ........... Tools > Internet Options > Advanced > (to the bottom) Security > check .... Empty Temporary Internet Files Folder when browser is closed > Apply > OK

If I want to save any of those Temporary files [Particularly flash files - Great aren't they!!], I do it while my browser is still open and just transfer them over to a Folder on my PC.

Offline Lisandro

  • Avast team
  • Certainly Bot
  • *
  • Posts: 67241
Re: My scan time of over 2 hours - what is yours?
« Reply #14 on: March 17, 2005, 03:03:52 PM »
By the way ...... When I right click on the "a" icon > Programme Settings > Update (Basic) and hit "update now" .......... nothing happens. That doesn't seem right to me - neither "Virus database" nor "Programme"

Can you manually update your database and program?
Are you sure you're using the last avast version?
Did you allow avast.setup to connect the Internet into your firewall settings?
The best things in life are free.